Norns Shield - adding audio files

I imagine there is a very simple solution to this problem, but I cannot figure it out for the life of me.

I’m trying to add audio files to the crypt folder for use in arcologies. Initially, I downloaded some .mp3 files (from the PennSound archive of poetry readings) and tried to drag them into maiden. That didn’t work. Then I tried converting them to .wav and dragging them in. That also didn’t work. In both cases, the file would just open in a separate browser window. I consulted the file sharing documentation on monome.org, and I realized I probably needed to enable smb features, since I’m using a Windows machine. So I did that, restarted the computer, and tried accessing norns.local in the file explorer rather than the browser. But the browser just opened when I typed norns.local into the file explorer address bar.

I tried just playing the .wav files from my computer into the norns audio input and recording to tape, but then I couldn’t move the .wav file from tape to crypt from maiden, so that didn’t solve my problem either.

Could anyone quickly explain how to get around this, so I can get these audio files from my computer to the norns? I imagine I’m not the first to ask this question, but I couldn’t find any answers from searching existing threads. Any help would be very much appreciated!

1 Like

sure, there a few ways to do this but my preferred way is (on osx)

  • connect shield to the network, or create a hotspot
  • connect your computer to the same network
  • find norns in the finder sidebar
  • connect as we, password sleep
  • drag your files in there

or, on any unix system:

  • in a terminal:
  • scp /path/to/file we@norns.local:/home/we/dust/audio/.......

edit: oops, you totally said you’re on a windows machine, this is probably useless to you! maybe i’ll leave it up for future travelers’ reference?

5 Likes

hope all’s well otherwise!

in addition to @zbs’s timely assistance, this particular cocktail sounds like a case where SFTP will help: sftp | monome/docs. cyberduck gives the same functionality as the samba method.

4 Likes

@dan_derks cyberduck did the trick! SFTP worked like a charm.

And yes, @zbs, I’m sure future travelers will find the OSX and Unix instrux very helpful!

Thanks so much to you both.

4 Likes