Norns shield - exiting scripts

Per play | monome/docs, E1 allows navigation of top-level menus. This is frequently false.

For example, on entering the script oooooo, E1 is commandeered for a new purpose, selecting loops. This behavior is documented.

Needless to say the top-level menus are necessary. For example there is no way to exit oooooo. The one method to restore control is to unplug the unit. As UX goes this is suboptimal.

Is there some other incantation short of unplugging?

Hi @lucasgonze, I don´t know if I understood your question correctly - in oooooo, I press K1 to access top-level menus and navigate them with E1, where I can change the script and/or sleep the unit.

1 Like

press K1 to toggle between the script interface and the menus…

E1 continues to work until you K3. After that point E1 is locked out.

I also do not understand the problem. I just tried lauching oooooo and K1 always works to toggle back and forth between script and main Norns menu (as it does for every other script I’ve tried).

After pressing K3 in oooooo, things are exactly the same. E1 does its usual job in oooooo (selecting the loop) and when in the main menu E1 switches between pages…

ah, i think this resulted from an assumption between the words + images in the play docs. sorry you’ve been caught in ambiguity, @lucasgonze !

hopefully this rewrite helps clarify?

6 Likes

I have created a demo video:

It works on my shield. A tap of K1 takes me back to the menu. Are you sure your K1 is working?

K1 is working initially and always begins to fail after K3 is activated.

OK. I have to admit it took me a few tries to learn exactly what “a quick tap” is, but now I always get it. You don’t have to restart to access the menus. In the video it looks like you’re maybe a little quick, I don’t know.

i watched the video.

  1. you seem to be still expecting E1 to navigate menus when the script UI is active, but i hope it is clear by now that it doesn’t work that way and isn’t intended to. when the script UI is active, all keys and encoders are captured by the script except for K1.

  2. the wayh to exit script UI is to tap K1. i only see you attempt this once near the end of the video, very briefly. can you just make very sure that you are totally depressing K1 and that it really really is not working? just try and toggle between script and menu without doing anything else.

in other words:

(1) i’m not seeing any evidence that your K1 is working at all. i see you use E1 to navigate menus, E2 to scroll through scripts on the selection page, and K3 to select a script.

(1b) you say above that “K1 is working initially” - you mean at some point, K1 does work to flip between script and menu? (it has no other defined function, though scripts can make use of a K1 “long press” or use it as a momentary mode swtich.)

(2) if it is not working at all, hardware failure of the switch or its connections is the simplest explanation.

Ahah! Your point #1 is correct. K1 never works in any context.

What I didn’t know until now - because I have only ever had a broken K1 - is that a functioning device always has the ability to toggle between the current script and the system. This explains a lot of baffling stuff.

4 Likes