Norns shield - external usb audio/sound card?

I have recently got a Norns shield and loving it! I’m blown away by the possibilities and the affordability of it so thanks to everyone who has made this possible!

I have done some searching but not found a definitive answer so apologies if I have missed it somewhere…

I have been browsing the " Friends of norns" thread and I have seen a people mention using a zoom h4n or similar as a preamp for the Norns.

Is it possible to take advantage of these devices as usb sound card or do I just need to route it in using the line out?

Thanks in advance


My norns shield is broken, i get a supercollider failure (some issue with the soundcard from the shield). I managed to setup and use my external USB sound card with it, but it is hardcoded, it only works with that (might be a way around, but my lack of knowledge only allowed me to reach that part).

Here is a github gist with what i changed:

1 Like

Thanks for taking the time to reply. Ok cool - I thought this might be the case. I’ll stick with using the Zoom line out for now and using that as a mic preamp. I don’t feel comfortable digging around in the code just yet.

This is relevant I think.


Cool. Before settling for the “pass audio also to OP-Z, not only either norns or OP-Z by multiplexing the signal” setup of Connect-OPZ, I messed around with the using OP-Z as an external sound card by changing the alsa -d flag. Yours is hw:K6,0, mine was at the time hw:1.

Good job changing those things. Besides being a music instrument and of course a unique special magicorn butterfly pegasus sparkle gadget :sparkles:, norns is also a vanilla GNU/Linux computer with Debian.


ok great - thanks for the info, thats really helpful

1 Like

After playing around with this tonight I can’t quite get Norns → external DAC working 100% and would appreciate any pointers. So far I have been able to:

  • stop Norns-jack.service and play sound from Norns to the external dac (via ssh’ing into Norns, and changing the default alsa device)
  • use connect-opz as a reference to start alsa_out, and use jack_connect to rewire Crone to the external dac

What I can’t do yet is follow the example above (Setup NI Komplete Audio 6 with NORNS - to bypass the supercollider fail error of bad soldering of DAC · GitHub) and modify norns-jack.service and my .asoundrc to set the external dac as the default device. I tried rebooting Norns, but it seems like jack doesn’t choose the external dac for system out. I also noticed Crone failed to start in this case. But, if I stop norns-jack, then I can play audio files from ssh and it works.

Is the card connected before powering up?

I am also on an old version, cause i am afraid the update will mess things up and i need to fix things again.
When i have some time i will update and do it again.

Yep, I slept/restarted Norns a few times trying it out. To clarify, I can change the alsa output and play through the external, but only if norns-jack isn’t active. I have to do the connect-opz incantations to run norns-jack and use the external together.