Norns Shield MIDI out?

I built 2 Shields recently and both dont output midi through 3 different midi interfaces (roland um-one, maudio uno and another one branded as the shop i bought it at) , some people told me norns should output midi instantly as long as the midi interface is selected at system/midi/device, that is not true for me, I should mention that all Interfaces are recognized and accept midi in…
So how to get the midi out going?

1 Like

What script are you using? You might need to point to the correct midi device from the script settings.

I tried all scripts that came with the firmware i uploaded, presumably the latest from the github, and sure I chose the correct midi interface at settings/midi/device…

Each script may behave differently. Knowing which specific scripts will help people offer solutions to your query

Awake for example would require you to go to the Params menu and explicitly select midi for the output (or audio + midi).

Other scripts use a different divide for in and out. Others yet don’t have midi out at all.

Check the params menu as a first step though

3 Likes

I am also facing this same issue, I’ve tried Awake, Kria, Buoys and Loom making sure that I have MIDI out where applicable, as well as making sure I have it outputting on the correct device. I’ve even changed the device number, changed the MIDI channel number on the Norns, the Virus and the Keystep. Which are the pieces of equipment I am attempting to use. I also checked to see if I was getting any signal by plugging the MIDI cable into my computer and also nothing.

1 Like

sorry to hear about the trouble :confused:
let’s try some specific repro steps for Awake:

  • plug in a UM-ONE and load Awake
  • navigate to SYSTEM > DEVICES > MIDI
  • I have UM-ONE in port 1 only (if you have any duplicated devices listed, click into any duplicates and either assign that slot to another connected device or none)
  • I go to PARAMETERS > EDIT
    • I set output to midi
    • I confirm midi out device is the same port as my UM-ONE was under the MIDI menu (port 1)
  • I see the MIDI out LED on my UM-ONE start flashing as MIDI data is being transmitted

alternatively, the CLOCK settings can also send MIDI clock:

  • select CLOCK
  • scroll down to midi out
  • set to the same port as the UM-ONE (port 1)
  • I see the MIDI out LED on my UM-ONE start flashing

if either of you can provide repro steps for your situation, that’d help us be able to test closer to your conditions and understand the issue better. thanks all! :slight_smile:

3 Likes

Thanks! I follow those steps, but with my Keystep and still nothing.
Detailed signal: Shield –USB– >Keystep –MIDI out– >Virus

If I play the keyboard, I trigger the synth, but midi data is not moving through the USB and out of the Keystep. I also tried plugging the Virus into the Norns directly, which I hadn’t considered before, and it also shows up, but no MIDI goes through it either.

I appreciate the help, hopefully @Lunaire has better luck and I will keep trying things.

happy to help!

hmm. which script in particular are you working with?
i ask because keystep > norns > external synth isn’t possible without the script offering some form of passthrough.

edit: ohhhh i understand now — norns sending usb midi out to keystep which is sending din midi out to virus…

1 Like

not sure the keystep offers midi thru via USB? (i mean, can you do this by connecting keystep to ableton? have ableton send midi to virus directly thru keystep)

Hey, thank you all again for the help and inspiring more deep digging. Hopefully this helps anyone encountering the same problem with their Keystep either in the Norns environment or when using the Keystep as a MIDI host.
By default, MIDI Thru is turned off!
To remedy this, you need to use the MIDI Control Center software that Arturia provides to save the default profile to have MIDI Thru turned on.

After adjusting this I have been able to get MIDI to output from the Norns. Problem solved!

8 Likes

I bought this midi interface in order for my Norns Shield to send midi out. It does not appear in midi devices list though :frowning: Any advice ?

Edit: Couldn’t get it to function and went out an bought a Roland UM-ONE mk2 instead. That one works perfectly.