Norns Shield - pset/pmap file locations

I have a question for other norns shield users, do some of the scripts also not load properly for other people? Two examples FM7 and Molly the Poly. Both attempt to load .pset files from /home/we/dust/data/~scriptname~/~scriptname~.pmap which fails as those files don’t exist.

image

When I look at the filesystem, the pmap file is actually located in the /home/we/dust/code/~scriptname~/ folder.

Any ideas?

pmaps should be saved/loaded from the /data/ folder. if you haven’t saved one, it’s ok that it fails.

can you clarify what you’re trying to do and what’s not working?

So my original problem was with the FM7 script, and I was getting an error that it couldn’t load the .pmap file which in turn made it impossible to select presets that were supposed to be loaded with the script. Then I tried to run the Molly the poly script which also had the same issue.

On my Norns Shield filesystem in the /home/we/dust/code/fm7/data directory there are a bunch of pset files which I believe should get loaded into the script to allow paging through presets and a pmap file which is likely the default settings.

Maybe I’m going about this wrong.

-edit-

Looks like if I save the parameters using the scripts menu, it now does not complain about it when loading, however it still doesn’t load the presets as shown in the script - so looks like this might be localized to the script.

pretty sure its an issue with the script being out of sync with current norns version. i’ll follow up in the script thread. i think we should also close this topic because the Q has a simple answer, which has already been given, and is now a red herring.