norns shield

Not that you can know for sure, but do you anticipate the next batch to last for a couple of months, or is it more likely that they’ll be sold out again within a week or two? I’m trying to budget my expenses & decide whether to get a shield as soon as they’re available again or if I could wait a month or two. Don’t wanna miss out.

Thanks for any thoughts.

1 Like

they should last a couple months, but we’ll post an update when we’re running low

9 Likes

Thanks a ton, that helps!

I get the feeling there’s a few of us refreshing the store page every day and hanging on Brian’s every word here :laughing:

4 Likes

Was looking at the website just now updated Norns shield for 2022 looks like it’s compatible with the pi4 - still says sold out but shipping March 8… I’m a little confused by what’s on the site but possible I just happened to look while it’s being updated. If there’s any additional info I’d love to know more

6 Likes

Hey guys, sorry if this is not the right spot for this but I need some help with my norns. I recently got a new norns shield kit from the Monome website and put it together. I booted it up and it opened the initial scripts with no problem. When I go to connect to wifi, I’m having the same issue that others in the forum had before. I go to connect to wifi and follow the steps, adding password and everything. I did notice that my wifi was showing up twice(not 5g/2g I don’t think, only 1 has shown up on my phone/computer before and there’s no designation on the norns to indicate 2g or 5g). When I add my wifi network, STATUS shows as “activating” which never changes. The network shows up as my wifi name, but goes away after about 30 seconds and the status stays as activating.

The IP stays blank, and the signal stays at dBm the whole time. I am using a windows machine so I’m not sure how to go about doing the serial login. I’ve tried resetting it and turning it off and on and even deleting the wifi and adding it back in all different steps of the process.

Has anyone had this issue before and come across a solution? The solutions that worked for others isnt working for me so I’m not sure what to do.

Thanks in advance!

hi hi! hope all’s well otherwise :slight_smile:

just to confirm, the wifi troubleshooting steps for shields use ethernet and SSH to connect to shield via another computer on your network – windows computers should be able to complete these steps as well as a mac/linux machine. serial is only for standard aluminum norns units.

the nmtui, country code, and extended logs via journalctl in those docs should help illuminate where things are going sideways. past that, since network connectivity relies on the pi itself rather than the norns software stack, it could also help to search for any known connection issues with your pi model and your router.

I’ve had this same issue for as long as I’ve had my Norns shield. I narrowed it down to possibly being something to do with my router because I’m able to connect to my iPhone hotspot but not my house’s wifi network.

It’s a goofy workaround but if I’m downloading lots of scripts n such I’ll connect my phone to wifi and Norns to my phone. Then for transferring files I just use the hotspot function and it will connect directly to my MacBook.

Try a USB WiFi dongle. I had a problematic one, turned out that Raspberry Pi had a slightly iffy WiFI module and so I tried a TP Link USB one which had much better reception and for the cost of one $5 or so it was an easy fix.

Thank you for pointing this out! I think that it may be an issue with my router or something. I was able to follow the steps to get the memory expanded.

Yeah the issue seems to be with my router since the hotspot is working so I’ll try this for now until i look into the connection stuff.

Thanks! this could be another easy fix. Setting my phone as a hotspot seems to work. I’ll try a module if I get tired of doing that. I might have a wifi dongle around here somewhere anyways.

Hi all,

I’m brand new to Norns and have no coding experience, but I recently got a Shield and am really enjoying it. The only issue is that half of the scripts I load onto it seem to just hang in “loading” status and never start up. I’ve tried restarting the device and installing, updating, and replacing the scripts. Had a few successes but it still seems to be a fairly common issue. Is there anything else I can try?

Could you try starting some of the scripts that don’t work while the Maiden window is open, and let us know if you get any errors in the box at the bottom?

1 Like

I have been using it for a week.
I am very excited about the potential of NORNS.

But unfortunately I have one very serious problem.

I have searched for some articles but could not find any.
Sorry if this is a duplicate.

There is a signal even though the input is not connected to anything.

Looking at the picture of the mixer, it looks like there is a problem with the L channel input.

The parameter settings are as shown in the picture.
Maybe the effect is looping back.
But I cannot find the setting.

Can anyone help me to find the cause of the problem?


just to confirm— is this a pi4? if so, did you remove the tape from the bottom of the shield circuit board? it needs to be there to prevent a short in case the assembly is over-tightened (which is easy to do). try loosening the screws of the case, or replace the tape if it was removed. (if not a pi4, let us know!)

5 Likes

hope all’s well!

if this is a Pi4 – adding to brian’s excellent troubleshooting above, i just had a convo with another artist with the same situation. to resolve it, they replaced the white tape on the back of the shield board with a bit of electrical tape, then added a bit of electrical tape on the Pi4’s left-most bank of USB ports and it resolved.

if loosening doesn’t resolve things, this might help!

3 Likes

Brian and Dan, thank you both for your help and advice!
As you say, my norns is Pi4.
And I had removed the tape during assembly…

But I had the tape neatly tucked away in the box just in case,
so I put it back and magically the L channel was quiet again!!

So a big thank you for your prompt and spot on advice!

4 Likes

Will the protective sticker on the back be a permanent thing going forward? I didn’t remove it on mine and was fine. This keeps popping up as a problem and also isn’t shown in the image on the shield assembly page so many users may assume it should be removed. I see that the sticker is mentioned, but maybe that text should be bold and repeated again around the paragraph that states “Peel the protective sheet away from the screen”

1 Like

Hi all,

It seems like my Norns Shield suddenly won’t record to tape at all. I select “Rec”, name the file and hit “K3” on “Start”, but nothing happens - no timecode, and the orange progress bar doesn’t move. All that happens is I get an empty file in my tape folder with the correct name. It seemed to work fine before, am I missing something totally obvious?

Thanks so much!

Full disc? What does the system menu say about how much storage is available on your norns?

3 Likes