norns shield

Try a USB WiFi dongle. I had a problematic one, turned out that Raspberry Pi had a slightly iffy WiFI module and so I tried a TP Link USB one which had much better reception and for the cost of one $5 or so it was an easy fix.

Thank you for pointing this out! I think that it may be an issue with my router or something. I was able to follow the steps to get the memory expanded.

Yeah the issue seems to be with my router since the hotspot is working so I’ll try this for now until i look into the connection stuff.

Thanks! this could be another easy fix. Setting my phone as a hotspot seems to work. I’ll try a module if I get tired of doing that. I might have a wifi dongle around here somewhere anyways.

Hi all,

I’m brand new to Norns and have no coding experience, but I recently got a Shield and am really enjoying it. The only issue is that half of the scripts I load onto it seem to just hang in “loading” status and never start up. I’ve tried restarting the device and installing, updating, and replacing the scripts. Had a few successes but it still seems to be a fairly common issue. Is there anything else I can try?

Could you try starting some of the scripts that don’t work while the Maiden window is open, and let us know if you get any errors in the box at the bottom?

1 Like

I have been using it for a week.
I am very excited about the potential of NORNS.

But unfortunately I have one very serious problem.

I have searched for some articles but could not find any.
Sorry if this is a duplicate.

There is a signal even though the input is not connected to anything.

Looking at the picture of the mixer, it looks like there is a problem with the L channel input.

The parameter settings are as shown in the picture.
Maybe the effect is looping back.
But I cannot find the setting.

Can anyone help me to find the cause of the problem?


just to confirm— is this a pi4? if so, did you remove the tape from the bottom of the shield circuit board? it needs to be there to prevent a short in case the assembly is over-tightened (which is easy to do). try loosening the screws of the case, or replace the tape if it was removed. (if not a pi4, let us know!)

5 Likes

hope all’s well!

if this is a Pi4 – adding to brian’s excellent troubleshooting above, i just had a convo with another artist with the same situation. to resolve it, they replaced the white tape on the back of the shield board with a bit of electrical tape, then added a bit of electrical tape on the Pi4’s left-most bank of USB ports and it resolved.

if loosening doesn’t resolve things, this might help!

3 Likes

Brian and Dan, thank you both for your help and advice!
As you say, my norns is Pi4.
And I had removed the tape during assembly…

But I had the tape neatly tucked away in the box just in case,
so I put it back and magically the L channel was quiet again!!

So a big thank you for your prompt and spot on advice!

4 Likes

Will the protective sticker on the back be a permanent thing going forward? I didn’t remove it on mine and was fine. This keeps popping up as a problem and also isn’t shown in the image on the shield assembly page so many users may assume it should be removed. I see that the sticker is mentioned, but maybe that text should be bold and repeated again around the paragraph that states “Peel the protective sheet away from the screen”

1 Like

Hi all,

It seems like my Norns Shield suddenly won’t record to tape at all. I select “Rec”, name the file and hit “K3” on “Start”, but nothing happens - no timecode, and the orange progress bar doesn’t move. All that happens is I get an empty file in my tape folder with the correct name. It seemed to work fine before, am I missing something totally obvious?

Thanks so much!

Full disc? What does the system menu say about how much storage is available on your norns?

3 Likes

rad, thank you for the great suggestion!

  • i highlighted the callout here in red: norns shield | monome/docs
  • i added another callout where you suggested
  • i also added a section to the help docs for shield noise troubleshooting, which includes:
    • an image of the sticker on the board
    • the suggestion to insulate with a few layers of electrical tape (confirmed as very effective in the workshop)
    • the suggestion to not over-tighten the enclosure screws, as that can contribute to interruptive noise

hopefully these lil bits help folks stay out of the unwanted noise zone!

1 Like

Looks great! I think that should really help reduce the issues going forward.

1 Like

You were right, thanks so much! It wasn’t exactly that the disk was full, but I had to expand the filesystem as per the instructions here. Now I have literally days of available recording time, lol!

I really appreciate how helpful this forum is, so thanks for taking the time to reply and hopefully this can help someone else who runs in to this issue.

2 Likes

Glad to hear you had it sorted. Happy bleeping!

Check in Maiden if there are any errors when the scripts load, see maiden | monome/docs .

I’m finally about to attempt an update to the latest image for the Norns shield and am considering just getting a new SD card to do it with. (Just in case things go sideways then I can just pop my current card back in.) Is there any reason to spend the extra money for cards rated for high video transfer rates? It’s been so long since I bought one I have no clue what all the ratings mean for case like the raspberry pi and Norns (despite having looked up the markings.)
A simple recommendation would be great if you have one. I have a Pi 3B+ and shield 191106. Thanks!

monome recommends this one: Raspberry Pi Official "NOOBS" microSD Card

1 Like

Thanks very much, @zbs !

1 Like

Last one I bought (for my Shield) was this 128gb Sandisk one.

It’s been great; no issues with it at all.

4 Likes