norns shield

Thanks again for your time and insights. I just try and keep learning every day and never seems like there is enough time.


When I connect the shield to mpc one I’m using a simple TRS to 2xTS patch cable but the noise level is pretty bad. If I connect them via single TRS cable it’s much better but then I get only one channel.

Do I need to get a Y split cable like this?


question regarding strange noise issue:

when using certain scripts that are graphic heavy (even though the issue appears also on scripts like flora) I get a high pitched hum, that disappears as soon as go to parameters menu or any submenu (within the script) that only shows text.

this issue persists not only when the shield is battery powered but also using the Pi’s official power adapter. I have tried numerous things like, seeing if other gear affect this behaviour but without luck. The issue still persists.

Any ideas?

Sorry if not right place to post still new at this and new to Norns shield. Trying to hook midi out of shield to Pittsburghmodular lifeforms midi3 module. Have module set to channel 1. Have gate patch cable to gate I put on disting ex. Same with cv out to disting cv in. Running fall and have usb top row jack closest to front plugged in. That “in” of the 5 pin into the eurorack module. Under parameters on shields I have use midi selected yes and midi out 1: device shows (device) not specific name. I have midi out channel set to 1. I realize this is noob 101 here and the oldest question in the book and thought it would be easy. Does it matter which usb jack is used? I would think no. Should it say some name for where it just says device in the midi out setting?

I appreciate the time as always.

Which usb jack on the shield shouldn’t matter. “(device)” seems odd, but on the shield if there’s no device it says “none”.

Have you tried using the same cables and plugging the modular into another computer’s midi interface? Also try switching the din out/in, unless you’ve used them this way before.

Thanks for reply I really appreciate it. I went into menu on shields to assign the jack and all 16 say none. I tried switching the in and used the out into module and got same result. It’s like it’s not reading it at all. I don’t have a computer in my set up so I don’t have any more options. I had a midi solutions quadra thru from my old electron days and the power on it lights up when plugged in out from shield but not flashing like transmitting data.

If you select one of those ports with encoder 2 and press key 3, what’s in the list it shows?

First select midi under devices and get pic on bottom. Highlight 1. And press k3 and get first pic. I actually selected usb midi as option but didn’t work either. Every video I watch shows device name to pick and not usb midi.

I would try selecting USB MIDI for port 1 again, that looks like your cable. For example I have a similar USB->din converter cable and it shows up as the cable name, not the device name. Then go back to the midi settings for your script and confirm port 1 is selected. Try a different script (Awake, etc.) if the first one doesn’t work.

I will try that again. I have attached cable for reference just bought brand new arrived today. The MIDI module in the rack is old but still seemed ok as I selected channel 1 with no problem. There is no in cable or out cable into shields at this point as I was expecting sound to come from from mixer out on modular. That is correct right? No cables in or out on jacks on top of unit.

Assuming you are converting the midi messages sent to the Lifeforms midi3 to something that triggers audio in your modular, yeah you’re good.