Norns showing both audio output and input but nothing playing?

Hey, weirdness going on with my stock norns (silver) running latest update. I haven’t picked up the Norns in a bit (less than 2 weeks) and powered up for an update of a script and to have a play. I plugged in the L/R outputs and there’s no sound from either output or the headphone out but both out and in levels show there is a signal of some kind? I’ve also tried playing something in tape and also tried to run a script and no sound output. I’ve tried a restart and reset after backing everything up and no sound there either. I made a log in case it helps. Thanks in advance for any help diagnosing :raised_hands:

system.log (636.3 KB)

I’m not sure if it that is exactly what I experienced with my shield but the symptom seems identical.

I’d do a full reflash before much else to be honest. That solved a bunch of my issues with Norns in the early days.

not sure if this helps and if you have any external devices plugged in but i recently experienced a super low volume issue with my new black stock norns related to midi mapped global levels. i discovered the problem by unplugging all external devices and solved it by clearing the mapped globals.

does the situation change if input cables are inserted?

email help@monome.org for a quick hardware diagnosis

:person_shrugging:
I will just reset mine a few times, or power off and leave it alone for a while, and the problem seems to fix itself.
NOT ideal, I know.

hey everyone, thanks so so much for all the advice and suggestions. i powered on the norns this morning and all is back to “normal” :upside_down_face: . in other words: the audio output is functioning as it should and no more “ghost” audio I/O levels are showing! of course i am so curious as to what might have caused the issue but for now all seems a-ok. i’ve done a test of all the audio I/O and nothing seems concerning. i’ll reach out if it happens again :raised_hands:

2 Likes

@mmryspace i took a glance through the attached logs and didn’t see any error messsages from audio services etc. so no smoking gun as far as that goes.

one thing i do notice is that you have some mods enabled including broadcast by @infinitedigits. although there’s no particular reason to suspect the mod, it does perform reconfiguration of the JACK routings. we could be seeing a race condition of some kind and it’s probably worth trying with mods disabled if the issue recurs.


@juicynoisebits that sounds like a different issue since (IIUC) it only affects one input channel and no output channels. reports of these kinds of issues (silence or DC on one channel) are pretty common with shields, and in 100% of cases so far they have been traced to hardware/assembly issues with the PCB, jacks or cabling.

1 Like

much appreciated for taking a peek at the logs and I will keep the broadcast mod in mind if the issue recurs. thanks!

Hey everyone, I was just running the script Chaos Operator and experienced this issue again. There is another thread here that mentions this issue happening but figured I would post in the dedicated thread here since it does not seem to be related to latest update (happened on previous stack back in September 2022).

My setup is OG Norns on latest update, I had L/R outputs plugged into my audio interface, one MIDI controller plugged in USB jacks, and running on battery power. While the script was playing, I turned PARAMS > Reverb> ON and lost all audio output from the script engine.

When I checked the LEVELS page, I saw the same thing happening as in the photo above. I unplugged the USB controller, unplugged the L/R outputs, put Norns to sleep and powered back on and the issue was resolved.

Here is a system.log file in case it is helpful :raised_hands:
system.log (378.0 KB)

log indicates this is the well-known time-sync bug, where if the system is start up without a network connection and then the network time is set automatically later (ie, by plugging in a wifi dongle, or a very delayed network access) supercollider will try to “catch up” to the current real time and just… die.

this is not, as far as i can tell, related to any changes in the last update.

please let me know if this bug can be reproduced in a way that does not relate the wifi or networks, i can take a look at another batch of logs.

(also apologies for this bug upstream with supercollider. it’s incredibly difficult)

2 Likes

Thanks for confirming @tehn and no worries. I’m glad the issue doesn’t seem to be an outlier or hardware issue. After, my previous post, I was playing the fall script. I had both L/R audio outs (into an audio interface) and audio ins (from Roland PMA-5 audio out) connected, a Roland UM-ONE MKII USB MIDI interface connected between Norns and Roland PMA-5.

All was going well and then I received the jack fail message. The K3, K2, K1 combo didn’t soft restart so I rebooted from the white bottom button underneath and then proceeded to plug in my wifi dongle. Wifi was powered off at the time of powering the Norns on, so once the dust cleared I enabled the wifi on the Norns so I could export a log file.

I then went back to the fall script and the same thing happened as previously mentioned above. So in this case it sounds like the time-sync bug. The prior time it happened however, I was running on battery power and only had a MIDI controller connected to Norns via USB, and audio L/R outs connected to my audio interface… Hopefully this system log will provide some clues for both instances :raised_hands:

system.log (849.7 KB)

of first note in the most recent boot, the fall script is throwing a ton of error messages about a missing PNG image file (worth raising in the fall thread)

strangely, the network manager seems to be re-running some sort of initialization constantly, which i’m confused by.

which wifi dongle are you using? i’m also assuming (since your post was in the other thread) that you’re on the newest version? could you run SYSTEM > RESET and make sure any MODs are disabled?

i apologize this isn’t an instant-fix, thanks for the follow-up info

After this last occurence, I unplugged the audio I/O, USB MIDI interface and wifi dongle after putting the Norns to sleep and left it charging for a while. Powered on and the issue is no longer happening.

I noticed that in Matron as well. I will pass it along to the creator.

I consistently use the Panda Wireless PAU06 when I need to update scripts or the Norns. I also have the wifi nub that came with the Norns.

Mods were disabled when the issue was happening and I am on the most recent update. I’ll run a SYSTEM > RESET and keep MODs disabled for now.

All good! I’ll certainly follow up here if/ when the issue happens again. Thanks!

UPDATE:
@tehn I just had the same issue occur again. This morning, I was using Norns with the wifi nub instead of the Panda PAU06 mentioned above. I was running on battery power and had only the wifi nub and L/R Audio outs connected to my audio interface. I made sure to keep the wifi enabled between powering on and off and even tested to make sure it was on so I wouldn’t run in to the time-sync issue.

Just prior to my post here, I powered up to update the Lamination script and it requires reinstalling a ugen, which then requires a restart. All that went successfully and the script, engine, and sound output started without an issue and then the issue occurred.

If I understand the known time-sync bug correctly, this instance of the issue happening does not fit with the wifi plugged in and enabled after the fact cause you mentioned above. Perhaps there is a network access delay although I don’t think that is an issue b/c I am able to see the Norns restart and boot up in Maiden REPL in real time?

Wondering if I should try to connect as a hotspot instead of directly to my wifi network? Aside from that, maybe a fresh Norns image is my next move. Thanks for continuing to investigate this issue. I really appreciate it.

Attached is the latest system log.
system.log (809.5 KB)