Norns: update 181023

download here: https://github.com/monome/norns/releases

181023

see update instructions

norns 1.1.1

  • NEW cpu and temp monitoring in system menu
  • FIX engine reset at cleanup

image

  • updated supercollider to 3.10.0 @artfwo

dust

  • NEW r engine and examples @jah
  • NEW fm7 @lazzarello
  • NEW tuner @markwheeler
  • FIX softcut bus deinint @catfact
  • FIX mlr long file loading, increase buffer size, reduce to 4 tracks

if you’re having trouble with the USB disk update method, i’ve written up how to run the update via wifi hotspot. see the bottom of the update instructions.

if you’re seeing crashes, i highly suggest running the update via hotspot which has clearer confirmation that the update completed. i suspect some of the recent issues have been related to incomplete updates.

please post further issues. making progress.

huge thanks to @zebra for the epic debugging sessions

23 Likes

thank you all so much for the hard work. ran mlr for a while with no problem. did get a crash from loom but i currently don’t have time to find reproducible steps

1 Like

Looking forward to testing this out.

FWIW, I used 181008 today on an Appalachian Trail hike. It was under 60˚F at the top of the mountain when I used mlr with the OP-1. I did a few takes, one going over 20 minutes and experienced no crashes. I rebooted between takes, just to be safe, but that last one @ 20+ min surprised me.

I say this just because I felt how cold the devices were upon returning home and wondered if temperature has anything to do with the mlr crashes. I see that “NEW cpu and temp monitoring in system menu” is part of the changelog, but don’t know if you mean temp(orary) or temp(erature) … temp(tation) … temp(ranillo) …

Cheers ~

1 Like

Update worked first try! Thanks. Noticed a little note-on latency in FM7 that I hadn’t noticed before. Not sure if that’s a supernova vs scsynth thing or if I’m remembering poorly.

interesting. could be. new supernova build (SC 3.10 beta-2) has some things “fixed” for “latency compensation” which maybe just means “more latency.” there are, of course, ways to test this and work around. (lets do that now.) if you want, you should be able to manually install supercollider .debs from an older release with no problems.

Could you tell us more about @jah’s crazy R engine? From what I can tell, it looks like an entire modular engine where the connections are made in Lua instead of via SC code.

3 Likes

I’ll try a downgrade. The first time I heard it I played the same chord again, thinking it might have been my fingers and the time shift felt larger than a little “flam” (is there a word for that in piano playing) effect from not pressing three keys evenly. The second time the notes sounded as expected. It happened a few more times. I’ll try and reproduce more reliably.

I only messed with those scripts on the norns for a few minutes, but as someone with no SC knowledge but/and a willingness to really explore the lua side of things, this excites me greatly.

would love to see more experienced SC users sharing engines (even if they aren’t hooked up to a script)

Yeah, kind of - it’s a generic audio generator/processor patcher engine with a couple of included modules.

Docs here: https://github.com/monome/dust/blob/master/docs/jah/r/index.md

I consider it beta stage but the set of engine commands is stable and will not change.

7 Likes

20 characters of thanks for docs and the engine.

First observations:

mlr stable
tape rec/play not working?
fx engine adds 20% on cpu

Many thanks for the update :slight_smile:

Got the update installed without a hitch, and MLR has been awesome in my two sessions so far!

This is the case for me as well. Just tried recording two MLR takes to tape, and neither of them took. The levels interface is fine, and recording seems to work, but then I get nothing when I play back.

thanks for reporting the broken tape (yikes)

will get a fix right away

2 Likes

confirmed. record is actually working. it’s TAPE playback that isn’t. i just recorded some earthsea and then played it back within mlr. issue: https://github.com/monome/norns/issues/618

is anyone else seeing differently?

Ya I made some recordings last night that load up in MLR but don’t play back in TAPE.

Edit: to clarify, i agree with you @tehn

Does this update include the rollback described in the help thread?


after many hours of testing and triage we decided that the kernel faults were probably not caused by supernova and only correlated with its introduction. we think the changes in the update should help. since you were one of the norns users experiencing regular kernel faults it would be great to get your feedback on it. (as far as i can tell, this is a minority of users which didn’t happen to include anyone in the core development group.)

this update also pulls in the supercollider 3.10 beta2. this exposed a bug in the TAPE playback as described above. we have a fix for this (https://github.com/monome/norns/pull/620) and are also adding a few more things (including a fix for upstream supercollider: https://github.com/supercollider/supercollider/pull/4137) for the next “hotfix” update which will come very soon.

3 Likes

With the upgrade to the new version, when I turn off the effects, I don’t get any volume out of my headphones - I “reset” the audio but that didn’t seem to have any impact. Am I missing something at a controls level?