Norns: update 181101

norns

#1

this is mainly a CPU improvement update and a few small fixes. highly recommended.

https://github.com/monome/norns/releases/tag/v1.1.2

181101

norns 1.1.2

  • NEW cpu and temperature monitoring in SYSTEM menu
  • FIX i2c cpu hit bug
  • FIX tape playback
  • FIX revert to heavy reverb algo
  • ADD lockout PLAY mode if script does not define redraw()

dust

  • ADD mlr clip save to file
  • ADD passthru example engine @catfact
  • FIX loom optimizations @markwheeler

mlr clip saving

  • clip screen, use ENC2 to change between load / clear / save and then KEY2 to execute command (note that clear doesn’t work presently (sc bug) but will be fixed in the next update. save saves to /dust/audio/ and creates an automatic filename (that can be manually text-entry changed)

Norns: updates
#2

small inconsequential ‘bug’ in update script.
bashrc is not in this image… so cp norns-image/config/bashrc /home/we/.bashrc will fail.


#3

Another minor install script issue…

when running the sc/install.sh script on RasPi I would get some errors about failing to created symlinks

apparently adding -p flag to the mkdir commands fixes that.


#4

Possible bug.
When I load up KAYAN the main screen is the parameters page and not the vibrating line/string.
@tehn are you seeing the same behaviour?


#5

this looks like norns.menu.status() is never evaluating to false and thus draw_screen() is not running.

  x.callback = function(stage)
    if norns.menu.status() == false then draw_screen() end
  end

#6

updated this morning, gave MLR a quick spin and played for 15-20 minutes, no crashes yet. However loading up @Dan_Derks’s wonderful Cranes script and about 10 minutes in I get the same crash that I’ve experienced across several apps in the past, including MLR where the system hard locks up and the output becomes a loud constant waveform sound.


#7

thanks for feedback
since they are using same engine,
(cranes should be lighter since it it is using only 2x voices, but maybe it should explicitly disable the unused voices,)
and cranes is not doing too much as far as fast sequencing on lua side (afaict),

i wonder if there are other distinguishing differences in the use cases, such as whether you are using the reverb in one case and not the other. that’s important to know.

also important to know is whether wifi is enabled, if you have maiden connected, if you have ssh sessions open.

in any case we continue to work on scsynth/supernova stability.


#8

Had few Mlr crashes. Feels more unstable compared to the previous version…


#9

can you report CPU usage and temperature? (listed in SYSTEM menu)

try disabling the reverb (aux) for better stability in the meantime.


#10

I’ve been experiencing some strange behavior as well since the update yesterday. got a crash out of loom (i was admittedly trying to push it to its limits with all notes and triggers firing and the bpm at 450 or something lol) but the wifi was not on, the reverb was on and cpu was at about 70-80% and temp was reading 70c (which was a bit alarming) saw similar stats when running mlr after a hard reboot but it never crashed.

another thing that began happening after i updated, the battery seems to be draining its self while the unit is turned off. this has happened 3 times so far, yesterday i activated sleep mode with 30% charge and now norns wont turn on until i connect the power supply


#11

I’ve had multiple crashes since updating. One made norns totally unresponsive but the screen was still on (might have tried to open moln, I had crashes with that in the previous version too), one where norns wouldn’t turn on (the light on the back was lighting but no screen on repeated attempts), one weird one where it let me get to the title of the application in select menu but no further (on any application, I tried many). In all these cases I had to use the hard reset button on the bottom. Lots of general mini hang ups where buttons/ encoders are unresponsive for a few seconds while navigating, I never noticed this in previous versions. I’ve made sure wifi and reverb were all off btw. Sorry all this isn’t more specific, I’ll try and keep some notes and see whether I can recreate bugs next time I’m using norns.


#12

@HateNames @rdfm what does free disk space read?


#13

1348mb

its at a 100% charge and i’m going to leave it off and disconnected from the power supply. I’ll report back when i get off work in a couple hours


#14

i’m suspecting some updates are not completing correctly. we’re working on a more robust update process, but in the meantime i’ll get fresh system images online along with instructions for a full system reset.


#15

2146Mb. Thanks. 20 char


#16

updated norns via alternate method, cause I can’t update via usb for for some time now. don’t know why…

at the end I got this line:
cp: cannot stat 'norns-image/config/bashrc': No such file or directory

once complete I did this:
rm -rf /home/we/update/*
sudo shutdown now

now it shows updates 181101 so I assume everything is ok, right?


#17

FWIW, I ran 181101 and updated with no problems. I am not using wifi and I only have Grid in USB port #1. I ran Loom yesterday - just running 5-8 notes/triggers and barely editing to see how long it would run until it crashes. 10 trials and everyone resulted at some point (5mins to 40mins) to lock up Grid, get the buzzing sound of death and had to “hard reset”. Battery is fully charged and running off my USB power directly into grounded power outlet. Curious why I keep getting crashes. I am new to Norns/Monome so it may be me, but any ideas? Thanks in advance. It also crashed on Boing twice as well. I have yet to use MLR other than some playful exploration BTW.


#18

we’re working on some CPU optimizations. try disabling the AUX reverb in the meantime for some extra headroom.


#19

thanks! Will do, appreciate the heads up!


#20

Since turning off Reverb, Loom has been smooth and steady!