Norns: update 181101



Hello everyone,

I have also been having more stability issues since updating to this version, specifically with apps like MLR, RYMD and Shifty that allow for use of norns two inputs. Any audio signal that I send into norns becomes incredibly distorted and glitchy regardless of the app that is currently running. I have also been having numerous lock ups with Kayan as well as the apps previously mentioned. I have tried disabling the AUX reverb and my CPU never goes above 40% or so with no concerning temperature changes either. Let me know if there is any other info I can provide


hey im on update 181023 with 4 tracks in mlr. is the 181101 update have 7 tracks ?


something certainly seem broken. i would suggest re-running the update manually, which requires a bit of tinkering. here’s a repost of how to do this:

how to re-run an update

Start up norns, connect via serial. Open a Terminal window and type:

screen /dev/tty.usbTAB 115200

Where TAB is push tab on your keyboard to autocomplete the name of the usb device. Push enter again to get a login.

User: we

PW: sleep

Now you’re loggged in.


cd update


If you see norns181101.tgz then jump to step 2 below. If it’s not there, insert your USB stick with the .tgz file on it. Then type

sudo cp /media/usb0/*.tgz /home/we/update

Step 2:

tar xzvf norns181101.tgz

tar xzvf 181101.tgz

cd 181101


on completion:

sudo shutdown now

@kin.sventa mlr is not updated in 181101. an update with 7 tracks and mute groups (4 voices max play at once) is forthcoming (working on it now, alongside many general norns features and fixes)

Norns: help

Thanks Brian,

I just tried to re-run the update, however when i get to the ./ step i receive an error saying

cp: cannot stat ‘norns-image/config/bashrc’: No such file or directory

I have tried a couple of times and it gives an identical error each time.


That sounds so awesome. Can’t wait ! Thank you for all your hard work.


Warning: I am not a programmer, so please take this with not a grain, but a ton of salt. Can the error above be caused by this missing directory?

@tehn: Can this be fixed manually by creating an according folder via e.g. Cyberduck?


I had the same error occur and had a quick investigate. It does need to be fixed, but in this instance it’s not that important.

(That step occurs at or near the end of the update script and the change it makes is very minor, AFAIK all it changes is the prompt when you ssh in.)


I am still having the same issues persist so I don’t believe the re-update worked or applied properly again. Would it most likely be this that is preventing the update?


seems it’s time to do some deeper investigation. can you e-mail and i’ll get together some image reset instructions.


Did this get resolved? Fascinating script.


Nope, I’ve reinstalled the firmware and resented my dust folder on a USB but it has fixed anything. I miss the script. Any ideas on getting working again?


try changing line 168 of kayan from “function draw_screen()” to “function redraw()”

this sounds like the behavior on the current norns where if it doesn’t see a redraw function it locks you to the parameter menu. (this is going to get changed back on the next update)


I’ve also wondered about this


I have also been having this issue since the last update as well and have no been able to find a resolution as of yet. Brian and I did some troubleshooting and it turns out I had a bad CM3 board in my norns as well however this did not resolve the kayan issue (I didn’t think they were related) so I am still trying to figure it out as well


That solved the problem here. Thanks.



someone should really update the script on github. guess i need to finish the “github for poets” tutorial series i bookmarked on here like 90 years ago


I did that and now I see just a horizontal line …not moving…:slight_smile:


Are you hearing the generated melody? You may need to tweet ENC 2 and BTN 2 to get a melody going.


Yes I hear the melody…


ok i am visualizing the code so i’m probably wrong but i bet there is another thing that needs to be changed. any instance of “draw_screen()” that was there now also needs to be updated to “redraw()”. it sounds like the screen update isn’t being called. sorry i don’t have access to mine right now to confirm so just spitballing