Norns: update 190930


use SYSTEM > UPDATE while connected via wifi.


  • NEW crow support
  • FIX vu polls now use dbfs scaling @catfact
  • FIX (BREAKING) audio.file_info now uses absolute path
  • NEW system_cmd async os call function
  • NEW softcut.level_slew_time slews level (not rec/pre level)
  • FIX softcut.level_slew_time -> softcut.recpre_slew_time
  • NEW softcut.pan_slew_time
  • FIX softcut pan flip channels, scale from -1.0 (left) to 1.0 (right)
  • FIX softcut.level_cut_cut arg order @license
  • FIX softcut equal power pan @catfact
  • FIX softcut initialization @catfact

softcut got a few upgrades and fixes. slewing level and pan is quite nice. i will be updating/finishing softcut studies very soon.


there are several breaking changes in the update. some scripts may break (i don’t know how many use audio.file_info) and some others may sound weird (if they use softcut pan).

please report problems here or (even better) in the script’s Library thread and we’ll get them fixed up right away— the changes are incredibly simple.

side note: awake is updated for crow CV and JF connection. you’ll need to update your copy.

reference: github release


Hm. This is working less well than I’d like it to. Ran SYSTEM > UPDATE and then not much happens. norns says nothing. Matron says:

checking for update
lua: /home/we/norns/lua/core/menu.lua:1154: attempt to concatenate a nil value (field 'version')
stack traceback:
	/home/we/norns/lua/core/menu.lua:1154: in upvalue 'check_newest'
	/home/we/norns/lua/core/menu.lua:1236: in field '?'
	/home/we/norns/lua/core/menu.lua:208: in field 'set_page'
	/home/we/norns/lua/core/menu.lua:748: in field 'key'
	/home/we/norns/lua/core/menu.lua:165: in function </home/we/norns/lua/core/menu.lua:142>

Version remains 190817. :frowning:

EDIT: Odd. Tried again from the office, and the update was successful. :slight_smile:

This was actually me :slight_smile:


Query… what should happen once the update runs and the screen says complete?

on my pi4 I got to this stage and nothing else happened. SSH connection showed all the systemd units were running though.

Reboot get’s me going again, but I’m wondering if something’s missing or getting stuck in the update script.

at the [complete] screen on my monome-built norns, i pressed the far right button 3 to confirm, and the unit powered itself off. pressed and held button 1 again to power on as usual, and after boot finished normally, i checked the system screen to verify it was running 0930. no issues with the monome hardware; it was a standard update process.

Thanks for that.

Perhaps I missed the button 3 to confirm? (I thought I tried all the buttons)

I’m still confirming with another user (and need to check with my pi3 install), but this might be a pi4 issue. I’ll take a look at the update script and logs and see if anything jumps out at me.

thanks!! fixed in the credits up top :slight_smile:

1 Like

i should up update some of the text displayed so the situation is less confusing. thanks for the tip.


am i correct in gathering that this update fixes the rec/playback volume inconsistency with mlr?

i modified the mlr script to compensate - so after updating norns i should probably revert back to the stock version of mlr, yes?


It does halve the volume of recorded buffer in the default ( ,“reset”) state. No effect if you are explicitly setting filtered and dry route levels.