Norns: update 191016

use SYSTEM > UPDATE in the norns menu while connected via wifi for easy updating.

191016

  • FIX multi-port midi devices @ryanlaws
  • FIX crow detection
  • FIX select menu doesn’t stall lua scheduler
  • FIX tape audio clipping wrap @catfact
  • FIX clock details @artfwo @Dewb
  • FIX crow reset function @pq
  • FIX globals cleanup @pq
  • ADD crow user receive function
  • ADD new glyphs in default font @Dewb
32 Likes

What is multi-port midi?

Also, how long should scanning take if one has accumulated about 70 scripts by now? Mine’s been “scanning…” for a while (15 minutes?) and I’m hesitant to interrupt, though it seems to have gone unresponsive. Maiden won’t connect and the keys and encoders aren’t doing anything either.

Everything seemed to be working fine yesterday, on the previous update. Reset button, or too risky in this case?

Means you should now be able use any / all ports of devices which expose multiple ports. previously, norns could only see the first port of such devices. Edited top post for clarity

Dunno about the scanning issue but will review relevant changes (70 scripts is a lot in any case.)

… yeah there was a thread-backed asynchronous system command feature added in last update. but this is the first attempt to actually use it in the menu code. the intention is that it should not make “scanning” any faster, but should leave the menu usable during “scanning.” if nothing’s responding then it’s not working. visual inspection shows a few wonky things so i will try to reproduce and clean up. (in fact, if it’s not too much trouble to send me a copy of your dust/code folder that might speed things up a little.)

reset if you need to. if you have a computer on hand, it’s always better to connect via screen and reboot from the terminal. (sudo reboot 0). it’s extremely unlikely that any software problem on norns will prevent you from doing this.

2 Likes

It is very exciting to hear about this midi improvement! I was just playing with a couple of scripts yesterday (shfts and less concepts) and wondered why this wasn’t working.

No luck with the scanning issue yet. I have tried the reset button for a 2nd attempt, but it did the same thing, even with nothing plugged into the USB ports. I have Wi-Fi connectivity - as Cyberduck is able to connect to norns while it’s stuck scanning. But connectivity with Maiden is severed as soon as I go into the script selection menu. I’m also able to SSH in via Terminal, and I suppose I could safely shut it down from there rather than hitting the reset button. I will try removing some of the scripts next.

Edit: Sure, I’d be glad to send you a copy of my dust/code folder. How would you like me to share it with you?

1 Like

yeah i’m not able to reproduce just yet.

but, i was only able to find 47 scripts to install :slight_smile:

however… i believe the system command thread is leaking memory, like, quite a lot. will PR a fix. (PR’d.)

just to sanity-check: do you get this crash after a long uptimeor right away after boot?

1 Like

It was right away that I got the crash, I had just booted norns and updated to 191016. I don’t believe that there is a super deep file tree present. I just think that I had perhaps an excessive number of scripts in my code folder as you’d mentioned earlier. Once I removed some of those - it worked just fine and the “scanning” time is unnoticeable/doesn’t hang.

I’m not truly sure whether it’s working since I perhaps coincidentally removed some problematic scripts, but you can see which ones I removed in the email I sent if you’d like to investigate this further. Thanks again for your help!

cool thanks.

yea after looking more i can’t actually get a crash even with the memleak, eventually it goes virtual. so i’ll be curious to look at your code tree. we’ve had one or two other reports of weird behavior with large numbers of scripts and it would be nice to understand them.

What exactly is “scanning” doing?

will get on this right away.

edit: pulled in @zebra’s memory fix and re-uploaded the files.

anyone who has installed can re-run the update by deleting the file /home/we/version.txt (ie, via SFTP or SSH) and re-running the SYSTEM > UPDATE.

please post here if you see further problems.

“scanning” is simply collecting the list of scripts from the dust/code folder. i have a few page-fulls of scripts and it barely blinks on my screen. but importantly, it doesn’t stall out lua, so if you have (for example) a drum sequencer triggering tons of sounds, you won’t get a sync hiccup (and huge smash of noise) when entering the SELECT menu.

1 Like

I just did that and now for some reason my Norns on RPI install won’t start anymore. The screen is not displaying anything and Maiden can’t connect to Matron. That’s strange.
With the previous 191016 update (one hour ago) it was still working (minus a Supercollider fail error that I was trying to solve). I should probably try a fresh install of the whole system.

oh, i know the problem. new files in two minutes.

EDIT: the files have been updated. please try them again. i apologize for the re-upload trouble.

3 Likes

Thanks @Tehn . Quick question, i’ve deleted the version.txt via ftp but is there a command for running the update via ssh ? The screen shows nothing so I can’t run the update directly from the device. Edit: I’ve found it, I’ll download the .tar and run update.sh manually.

Edit: Yep, it’s back, it’s working again. thanks :wink:

1 Like

Installed no problems. I didn’t notice the shutting down message that I think I should have seen from the code. I wonder if extending the sleep prior to shutdown would make sense?

norns didn’t show any available updates after i deleted version.txt, but after powering norns off and on, checking for updates again showed the revised 191016 update, which then installed cleanly from within norns.

Just updated via the norns hardware and, following the on-screen text ‘complete.’, the screen went black and norns is utterly unresponsive (although wifi adapter is lit, and so is the rear status light). First time this has occurred and not sure where to go from here?

UPDATE: approx 30min after first update process, screen came alive again and showed update being available. Followed installation, but now back to a black screen and unresponsive interface. Maiden shows “update complete.” as final line, but I can’t seem to do anything with the hardware.

When the update isn’t complete, press key 3 and the Norns will shutdown. Restart it as normal.

Ahh…many thanks. I thought I had done that the first two efforts, but obviously not.

i would’ve thought any key would’ve shut it down but wow i am sorry. i will fix this.

1 Like

Thanks @tehn. I’m not ruling out a small sprinkling of user error…it’s been one of those days…but it was a new issue in the handful of updates I’ve made.

Hi, there used to be a way to update offline. I can’t seem to find the info for that. Is it still possible to do, and if so how? The wifi settings at my work are a little troublesome.