Norns: update 191230

191230

norns 2.2.5

  • NEW softcut buffer disk worker thread @catfact
  • FIX overhaul API docs @scazan
  • FIX reset encoder sens/accel on script reset

image

  • NEW kernel update, adds powermate support, shield wifi @ngwese @simonvanderveldt
  • NEW samba file server
  • FIX clean up logs, remove rsyslog
  • XXX webdav

longer explanations

  • SAMBA: since webdav didn’t work well with windows we switched to samba. for file sharing address type smb://norns.local (we’ll update the docs)
  • built-in wifi now works on the shield
  • logs are cleared out and syslog logging disabled (hopefully we won’t see filled disks anymore)
  • softcut buffer read/write use worker threads, which is a big performance improvement

use SYSTEM > UPDATE when connected to the internet

for stranded non-internet shield-norns: https://monome.org/docs/norns/help/#manual-update

NOTE: FATES users do not run this update.

20 Likes

blinking “downloading” is a nice touch.

is this doing a kernel change? (gotta go look at the update script)

My Fates is bricked (not starting) after running update.

1 Like

i cant seem to connect to wifi after the update

Ok (looked at update script) - this is super not good for Fates as the kernel replacement (or at least the config.txt file) will kill those devices.

Going forward - is there some way that kernel changes could be moved to a different update method (separate from norns software updating) or can I make some kind of flag file to check so this does not replace the kernel/config.txt on Fates?

EDIT - after replacing config.txt with the fates config, I can startup normally, but getting SUPERCOLLIDER FAIL. Will investigate further and update.

6 Likes

Update went well here. :grin:

updated oem and DIY shield norns. Onboard wifi works!

1 Like

can you clarify with which device you’re using? (i apologize, now that there are multiple “norns” out there). and any errors/symptoms?

Factory norns, no other symptoms to provide everything else seems to be functioning properly. I’m using one of those panda wireless WiFi nuns mentioned elsewhere on the forum

Edit: after restarting with everything unplugged it worked. Weird

1 Like

Hello, just bought a new Norns This week. Do I need to download this update as soon as my unit arrives?

I had to when I got mine a few weeks back. It’ll be good practice to check for an update in case it needs one and thus you’ll know how to do it again in the future.

1 Like

@okyeron i think it’d be a good idea for you to fork the norns repo and rewrite (or just remove) the SYSTEM > UPDATE option. a rewrite could just issue a git pull; ./waf — this way the only thing getting updated would be the norns app, and you can manually sync the “fates” branch to the main norns repo.

2 Likes

hey yall

with this update what is the current best practice for uploading engines, libs, scripts to the device for testing (before it’s added to the community hub)??

i can manage it but am curious what others are doing

SFTP still works, but smb is a little easier.

On mac, if you type in smb://norns.local in the url bar of a browser, it will ask to open finder. There you can type we/sleep and then it will show and behave the same as if norns was an external hd or sd card


for engines, I believe you will still need to ;restart in the sc repl (or hit the reset audio menu item on the norns itself)

2 Likes

I still mostly use git to manage scripts :sweat_smile:

4 Likes

Non-coder Norns user, just updated and connected via smb through a macbook running catalina. I’m now unable to delete scripts/files due to permissions issues. Might be unrelated to the Norns update but I didn’t have this problem a few days ago. Any ideas?

hmm. have you checked out this article from Apple about File Sharing settings? please let us know how it goes!

thanks
i’m pretty comfortable accessing via sftp or samba but dont know where my engine or other required libs should go

i’ve loaded other peoples scripts before in the past but the project manager has made it so easy i forgot the old way (and cant find a clear answer in the docs)

My typical structure for a script with an engine is to have the engine at
/dust/code/script-name/lib/engine.sc
and the script at
/dust/code/script-name/script.lua
Additional libs go in the lib folder
/dust/code/script-name/lib/libstuff.lua

2 Likes

Is anyone else having trouble sending clock now? Was working fine last night prior to updating and then i updated this morning and now Ableton isn’t receiving any clock data on any of the scripts i run.

what is your setup? is your midi device selected in system devices?