Norns: update 200424



norns 2.4.0

  • NEW clock system! @artfwo
  • NEW clock support for crow in/out
  • NEW clock menu
  • NEW OSC remote for key/enc
  • FIX pset naming and save cancel
  • FIX crow reset behavior @trentgill
  • FIX various minor issues, see github

new clock documentation:

beatclock to clock migration by @dan_derks

CLOCK is the big feature update: it allows a new way of scripting with time (different then metro) and includes a global tempo system with sync in/out capabilities for midi, crow, and link (which works with much more than ableton, ie norns to norns, ios to norns, etc etc).

note, there aren’t a lot of scripts that use this system yet— i just updated awake and @dan_derks is working on a few. (you can get updates through maiden’s project manager).

please let us know if you have any issues and we’ll get them fixed quickly.


Hate to say it, but I’m getting an error when trying to load a script right now (so far, every script I’ve tried):

lua: /home/we/norns/lua/core/clock.lua:179: attempt to call a nil value (field 'clock_link_set_quantum')
stack traceback:
        /home/we/norns/lua/core/clock.lua:179: in field 'set_quantum'
        /home/we/norns/lua/core/clock.lua:232: in field 'action'
        /home/we/norns/lua/core/params/number.lua:45: in function 'core/params/number.bang'
        /home/we/norns/lua/core/paramset.lua:415: in function 'core/paramset.bang'
        /home/we/norns/lua/core/clock.lua:265: in function 'core/clock.add_params'
        /home/we/norns/lua/core/script.lua:77: in function 'core/script.clear'
        /home/we/norns/lua/core/script.lua:156: in function 'core/script.load'
        /home/we/norns/lua/core/menu/preview.lua:21: in function 'core/menu/preview.key'
        /home/we/norns/lua/core/menu.lua:139: in function </home/we/norns/lua/core/menu.lua:116>
1 Like

will check! to others— hold off for a minute.

re-uploaded update file (they got mixed up). delete your version.txt and re-run.

Update seems to hang on “preparing…” - like above, i’d had the wrong update file before, so this is while updating to the correct one

if you had the wrong update file before it’s going to be a little messy because the bad update basically broke the update system.

do a manual update: ssh into the system first.

cd update
tar xzvf norns200424.tgz
cd 200424

then reboot

1 Like

OK— i believe it’s tested ok now (i hope!) thanks for your patience.

if you tired updating and failed, follow instructions above.


The manual update steps worked for me, I’m able to load and run Awake again. Thanks for the quick fix!


Yep, all better after a manual update. Thank you @tehn ! Now to read up on the new clock system.

thanks for your patience, i’m very sorry about that :sweat_smile:


First manual update = new experience.
Thank you for this!

1 Like

woo! thank you so much! was going to start playing with the clock today so this is great timing.

Over the moon about the new clock system! I’ve been tracking the changes in the clock beta and have updated Beets with today’s update. V1.0 is go!


The clock changes are absolutely fantastic, and open up norns+eurorack+iPad options I’ve been dreaming of for ages. A thousand thanks to all involved.


This is exciting! Does syncing 2 norns require a mediator like 2host? Looking forward to being able to share a clock with a friend’s norns when the global situation allows for face to face jamming again. :grin:

It’s got Ableton Link now! Just hook them up to the same network, enable it in params and they will sync automatically, wirelessly! Woohooo!


Thanks! I’m not an ableton user, so link is new to me, so cool that it will work wirelessly!


Thank you so much for this update! Global clocking definitely is a great addition!

Not sure if this should go here, Crow, or under the Animator script thread (so tagging @crim just incase) . But, after updating everything yesterday, Clocking Norns (Specifically the Animator script) from Crow’s clock input was much more inconsistent and couldn’t track as fast of a clock input as before. I could get Crow/Animator to follow clock speeds of up to 100 bpm after the update, but anything faster wasn’t acknowledged by crow. I tried different envelope shapes, Gates, and short Trigs to the Crow input with the same result.

Prior to the update, Crow input using Animator script was easily tracking high clock rates into the 200 bpm range.

So, I’m not sure if this is a Norns update issue related to the global clock implementation, or related to something in the Animator script update. I haven’t had a chance to test other scripts and externally clocking with crow, but can report back once I have.

Thanks again for all of the hard work and effort put in by everyone here creating these amazing tools.

hmm, so previously animator did this

clock.on_select_crow = function()
  crow.input[2].mode('change', 1, 0.5, 'rising')
  crow.input[2].change = animator.count

It looks like in the global clock module the setting is


The main difference being it is now input 1 (assuming you were using the correct input?), and the volts threshold is 2 instead of 1 (maybe this causes the issue?). I can test later to see if I can reproduce…

Would be good to know if you’re seeing the same things in other scripts using global clock (I think “less concepts”, “foulplay”, and “awake” use it off the top of my head)

I tried input 1 and was not able to get it to clock, but using input 2 on crow, it worked. I was using my Serge DUSG outputs (both slope out and gate out) which reach +5V (i’m pretty sure) so hopefully thats not the issue.

Will give those other scripts a whirl tonight. Thanks for looking into it.