Norns: update 201023 / 201029

Link in the first post appears incorrect for factory norns (part of the URL includes the previous release date). Found the image here: https://github.com/monome/norns-image/releases/download/201029/norns201029.zip

1 Like

ah, good catch – fixed!

unfortunately this bricked my shield norns

Uh-oh; I was going to update mine (which has been working fine with the recent update) until I saw this…

Follow-up: Just to note that I ran the update to 201029 on a Norns Shield and everything seems to be fine so far.

all looked fine - pulled the power when it got to ‘shutting down…’ but now won’t reboot - going for a fresh install

sorry to read this – was this after there was no green light activity for a bit? the full shut down is indicated by no green light activity and takes about ~30 seconds after that message appears (vs the typical ~10 seconds for sleep).

just updated a shield here, no troubles rebooting.

brian’s following up with steps to recover without reflashing.

1 Like

yes it seemed to have stopped doing anything. green light was still ON but it had been 30s.
too late! etcher is merrily etching…

1 Like

@leolodreamland please let me know if the new image works for you. it tested fine here, and i’m having a hard time figuring out why it would fail.

This happened to me as well with the 201023 update on my Norns Shield.
I had to reflash my SD card, but I had backups of my tapes and samples.
I just updated to 201029 using SYSTEM>UPDATE and all is well.

yes, it’s fine. and it still has my apps installed. this is good.

Ok this is weird, mine says up to date when I try and run the update

I ran 2310 ok,
I couldn’t record anything to tape since last update though?

Also it’s showing a .json file after every audio file

if you press k2 on the SELECT/SYSTEM/SLEEP screen, does it say 201029?

if not and if UPDATE says you’re up to date, hold k1 and press k3 on UPDATE to refresh and populate the 201029 release

1 Like

next person with a shield who updates: please open maiden when you run the update so you can capture the status of the update.

note that if your shield doesn’t boot, you can still access all of your files by inserting your sd card into your computer and looking at the rootfs drive under /home/we/

7 Likes

Thank you very much
Ok so this is weirder - went again to update with your instructions, previously it said it was 2310 but when I did you button combo it said 2310 available so I chose that and it updated. It hung on the reboot screen but thankfully has rebooted

Slight update - still can’t record to tape and then .json files are still visible

I haven’t got time right now but I’ll do it connected to maiden when I try the 2910

1 Like

Update worked here and dupe 16n issue seems resolved :+1:

3 Likes

??? I don’t get that one mr derks :slight_smile: emphasized text

1 Like

just, super confused about what’s happening with your shield – curious to see what maiden prints! thank you for the patience and good communication! apologies for my now deleted meta-meme!

1 Like

Just updated my shield and matron was saying update complete. All good in the hood on this end

1 Like

Please correct the link for the shield!

1 Like

I’m having a world of weird here

Ok so I seem to be in a loop of some kind - i updated again to 2310 and it came up with 0 fw in the screen where your ip and fw are and wouldn’t boot into any apps but did show the splash screeens and instructions for them

Sooo maiden it is - went to maiden and attempted the install and it’s maiden - it checks GitHub and keeps referring to /norns/releases/download/2.4.4/fates201023.sha256
Then another file with all the same but with tgz at the end


So presently I can now play all apps that I’ve tested, still showing .json files and I can’t record to tape (it will play the audio though)