Norns: update 201113

use SYSTEM > UPDATE when connected to wifi!

norns 2.4.5

  • NEW levels: allow +6db, show unity on mix menu @tehn
  • NEW params: remember last used pset @tehn
  • NEW params: enable mapping of binary types @infinitedigits
  • FIX softcut: don’t clamp record offset @zebra
  • FIX menu: playmode lock bug @tehn
  • FIX engine: deinit cleanup @tehn @zebra
  • FIX musicutil: revert rendering of sharps @tehn
  • FIX tape: create dir if user deleted it @zebra

extra gain

levels for output, input, monitor, engine, softcut, and tape now allow +6db gain.

note that it’s now easier to overload your outputs and also amplify unwanted noise, so be conscious of your gain structure. on the MIX page unity (0db) is indicated with a dash (and you can see the exact value on the PARAMS > LEVELS page… not that holding down K3 will give you fine control over E3 adjustments).

remember last paramset

the system now remembers the last used paramset for each script independently (stored in the scripts’ data folder). to use this functionality, the script needs to load the default paramset in init():

-- no args means read last-used pset
params:read()

-- the last-used number is saved in dust/data/(SCRIPT)/pset-last.txt

-- makes sense to put this at the end of your init!
function init()
  print("welcome")
  -- add params here!
  params:read()
end

“last used” means last paramset saved or loaded via the param menu.

deprecated

for scripting, mix is deprecated. please address parameters for mixer
(output_level, input_level, monitor_level, engine_level, softcut_level, tape_level), eg:

  • params:set('output_level', value)
  • params:delta('monitor_level', delta)
  • params:get('tape_level')

update

we’re now up to 201115 given a few hotfixes for this version. thank you for your patience.

39 Likes

20 characters of black norns!!! <3

5 Likes

getting a weird one in matron when trying to update:

ping: github.com: Temporary failure in name resolution
checking for update

lua: /home/we/norns/lua/core/menu/update.lua:24: attempt to concatenate a nil value (field 'version')
stack traceback:
        /home/we/norns/lua/core/menu/update.lua:24: in field 'callback'
        /home/we/norns/lua/core/norns.lua:189: in function </home/we/norns/lua/core/norns.lua:187>

tried restarting and got the same result. i can ping github.com just fine. it just hangs on the “checking for update…” screen.

going to update.lua and running that curl call from norns:

Linux norns 4.19.127-16-gb1425b1 #1 SMP PREEMPT Mon Oct 26 05:39:00 UTC 2020 armv7l
 ___ ___ ___ ___ ___
|   | . |  _|   |_ -|
|_|_|___|_| |_|_|___| monome.org/norns

127.0.0.1 ~ $ curl -s https://api.github.com/repos/monome/norns/releases/latest | grep "browser_download_url.*" | cut -d : -f 2,3 | tr -d
tr: missing operand
Try 'tr --help' for more information.

Did this update fix the encoder issues? right now my encoders are pretty wonky and Dan mentioned a update they will be fixing this.

So far my encoders are feeling great!

it didn’t make it in (i discussed this with @dan_derks but we didn’t make an issue so of course i forgot… but there is now an issue so it’ll be in the next update) — that said, if your encoders are bad, email help@monome.org

@tyleretters i’ve seen hung github requests before, and these typically resolve after rebooting. did you get it to work?

i’ve ran into a couple freezes since the update. first freeze was the boot up after update, screen frozen mid dust startup sequence. second freeze made it through the startup but froze here…

both freezes resisted the k3+k2+k1 reset, but allowed me to ssh in and reboot from there.

note: i was able to boot up and use norns for a bit in between the freezes.

note the second: both freezes happened when booting into softcut only scripts.

yes, thank you. i was mucking around with my /etc/hosts file thanks to the apple circus this week… i think that plus sshfs was the issue.

yikes, that looks like a mess. can you try re-running the update?

if your menu works, hold K1 while executing SYSTEM > UPDATE

if not, ssh in then:

cd update
wget https://github.com/monome/norns/releases/download/v2.4.5/norns201113.tgz
tar xzvf norns201113.tgz
cd 201113
./update.sh
sudo shutdown now

i’m double-checking the update files now…

edit: on one of my units i saw a weird refresh behavior so i just recompiled and updated the release files. seems fixed now.

for good measure, if you updated earlier, please re-run the update by holding K1 while selecting SYSTEM > UPDATE

@Justmat i love that you called the startup pattern ‘dust’— this is bizarre, but i never made that connection :sweat_smile:

7 Likes

Don’t have my norns with me this weekend but I’ll be applying this update on Monday evening. Thanks once more for all the work put into these updates :slight_smile:

fwiw my first update went fine once i got past that github issue. second update with k1 went ok until i rebooted. my dust animation froze and ssh’d in and stop/started norns. seems fine now.

LOL. i read that and was like, ‘oh of course it is’

2 Likes

I’ve always thought of it as “the dust blowing in” lol

2 Likes

I just ran the update on my Norns Shield, and now I can’t get it to boot up. The green light blinks twice and then the red light remains on but the screen shows nothing. Any ideas?

Using factory Norns. Getting a supercollider fail. Maiden shows .pmap not read when loading any sketch. Screen sticks on loading. Can back out but nothing loads anymore. Tried resetting and multiple system shut downs.

@michael_matos if supercollider fails nothing will load. can you please try re-running the update? hold K1 when executing SYSTEM > UPDATE

@Kaunsel that sounds like the update failed somehow. did the process complete? ie, were you prompted with the “shutting down” message at the end of the update? i’m going to re-test on my shield now.

i just retested on the shield and it worked fine. in the next update i’ll be adding better wording for the shutdown (ie, wait for the green light to stop blinking before powering down)… but what i’m guessing is some sort of corruption occurred. the fastest remedy is to just fully reflash your sdcard— be sure to back up any TAPE files first (you can read the sdcard upon inserting it into your computer).

there is a much more surgical recovery method, which i’ll write up instructions for.

1 Like

Updated stock Norns with cm3+ yesterday. The first attempt failed. The second attempt worked. I installed a lot of scripts on maiden last night and shut Norns down. This morning upon start up Norns is frozen on the startup dust screen. I’ve managed to ssh in in Terminal but I do not see a way to shut Norns down in the options in Terminal? Is there a way to? Thanks.

can you give details but what you mean by “first attempt failed”? how did it fail?

in terminal you can shutdown this way:

sudo shutdown now

can you launch maiden? try ;restart and let me know if you see errors

Hi @tehn,

The first attempt to update gave me, I believe, “download failed” on the screen? I can’t recall exactly but I think that’s what it said.

I’m getting this in Maiden with no luck connecting upon refresh. I can connect via the Norns server and through terminal though.

can you click the refresh icon next to “not connected to matron?”

did you typing ;reset?