Norns: update 201113

Okay sorry. Yes I did click the refresh button and that wasn’t changing anything. When I entered the ; refresh command it did connect and the Norns screen is now unfrozen.

Here is the print out: Sorry I don’t know how you guys put this in a post neatly.

Summary

*** WARNING *** The program ‘matron’ uses the Apple Bonjour compatibility layer of Avahi.
*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see http://0pointer.de/avahi-compat?s=libdns_sd&e=matron
OSC rx port: 8888
OSC crone port: 9999
OSC ext port: 57120
starting lua vm
running lua config file: dofile(’/home/we/norns/lua/core/config.lua’)
MATRON
norns version: 0.0.0
git hash: 0b40f12
running startup
start_audio():
norns.startup_status.ok
last file loaded: /home/we/dust/code/circles/circles.lua

script load: /home/we/dust/code/circles/circles.lua

cleanup

script clear

pset last used: 1
including /home/we/dust/code/circles//lib/math_helpers.lua
including /home/we/dust/code/circles//lib/libCircles.lua
including /home/we/dust/code/circles//lib/math_helpers.lua

script run

loading engine: PolyPerc

reading PMAP /home/we/dust/data/circles/circles.pmap
network connections:


1 jasper
Engine.register_commands; count: 7
___ engine commands ___
amp f
cutoff f
gain f
hz f
pan f
pw f
release f
___ polls ___
amp_in_l
amp_in_r
amp_out_l
amp_out_r
cpu_avg
cpu_peak
pitch_in_l
pitch_in_r

script init

pset >> read: /home/we/dust/data/circles/circles-01.pset
BeatClock using internal clock
BeatClock using internal clock
available engines (41):
Glut
Sway
Showers
Rudiments
Warb
PolySub
FM7
Shepard
Caliper
Grendy
Greyhole
KarplusRings
Ack
Grd
Phyllis
MGlut
Decimatec
MT7
SimplePassThru
Dronecaster
EasyGlut
Pedalboard
MollyThePoly
Decimator
R
PolyPerc
YggdrasilSynth
Benjolis
Timber
Passersby
Pools
Timber_Takt
Stack
SCgazer
TestSine
Manifold
PrimitiveString
None
HereThere
Haven
Lissadron

ok— what’s the state of everything now?

Everything seems normal. Awake is running fine. I haven’t shut Norns down yet. Do you recommend doing anything else before shutting it down again?

honestly it should be fine— i’m perplexed what got your system into a locked state, but i just pushed a minor fix which might explain it.

Okay. Thanks for the help. I’ll sleep Norns and see that it restarts as it should then.

Not sure if I’m missing an obvious step, but my error (factory norns):

SYSTEM > UPDATE
lua: 
stdin:1: attempt to compare two nil values
stack traceback:
    stdin:1: in main chunk

when you push K2 on the HOME menu screen, what version is shown to the right of SYSTEM?

201029 (and twenty characters)

try now— sorry— i was mid-releasing a hotfix.

we’re on 201115 now

Same error. Not sure if I’m missing a step - I’m simply typing SYSTEM > UPDATE into matron while on wifi.

On Norns, select the System option in the menu. then scroll down to Update and press key 3. No need to type anything in maiden :slight_smile:

3 Likes

gah, sorry, appears to be updating now. Thanks

(never have I ever touched that before :slight_smile:)

1 Like

So I experienced the same freeze when I did a reset on Norns. I ended up deleting all scripts in the code folder. Norns is shutting down and starting up fine now and scripts are reinstalled.

The nc01-drone script gave me an error last night when trying to upload it from maiden. Maiden said it was already installed after trying to install it. Maybe that caused some strangeness in the code folder? Anyway I think it was certainly an issue with the code/scripts folder.

hello appear every other time norns shield start freezes 201115, also shows the previous firmware version, and new problem on video

so I think successfully updated cause I see the new levels page, but my system says version 201113… if I go to the update page, it says update found 201115. should I update again? I have a factory norns.

1 Like

card flashed and now is working great. thanks!

Thanks. Tried that twice with the same results. Still getting a supercollider fail. What should be my next step?

there’s a (extremely minor) mistake in the update file, correcting now. you’re good.


@jasper_ryder i just experienced a freeze here. debugging now, thanks for your patience.

fyi i was able to ssh in and type systemctl restart norns-matron and it got back running, but something is obviously busted


@michael_matos do you recall what version you were on before updating?

2 Likes

@tehn I usually update 2 days after the last update. So it was the last update. My other Norns updated fine.

found the freeze bug (hard to replicate, augh).

updated the files. thank you for your patience everyone, i’m clearly not at full brain-power this sunday.

please re-run SYSTEM > UPDATE from the menu

it should properly display 201115 when complete.

7 Likes