Norns: update 201202

use SYSTEM > UPDATE

norns 2.4.7

  • NEW norns.fetch() for downloading git urls to dust @tehn
  • NEW screen: peek/poke @csboling
  • NEW screen: rotate/translate/save/restore/text_rotate @tyleretters
  • NEW screen: blend modes @Tyler
  • NEW util: radian-degree conversions @tyleretters
  • NEW hid: keyboard detection @zebra
  • NEW platform: detect norns/shield/other hardware, improve messages @tehn
  • FIX params: mapping control full ranges @synthetivv

most new scripting features. docs forthcoming— authors, feel free to post about your additions.

norns.fetch() is a great way to share for pre-release scripts. please use this instead of suggesting people download github-made zip files, which always need their folder renamed, resulting in much confusion

main point, however, was to identify if you’re on a shield, and to give a better “when/how to shut down” message. keep an eye on that not-red blinking light.

ps. new disk images tomorrow morning.

35 Likes

very excited about the new blend modes! will be great for a script i’m working on, thanks @Tyler

rotate text and other things!

rotate is an extremely powerful function. if you don’t clean up after yourself, you will rotate your entire norns system menu! see examples for how do do this in the example above. you must screen.save() and screen.restore() to reset. you’ll also probably want to combine this with screen.translate().

the two text rotate functions “clean up after themselves” meaning they take care of all that save/restore/translate stuff for you. basic usage is simply:

screen.text_rotate(x, y, "any text", degrees_to_rotate)

we also have rads = util.degs_to_rads(degs) and degs = util.rads_to_degs(rads) to make working with all your rotations easier.


@Justmat other @Tyler did the blend modes :slight_smile:

11 Likes

20 characters of whoops!

Did not know about norns.fetch() - brilliant, thanks!

1 Like

When I choose to update, I just get ‘checking for update’ in the menus. My Norns shield just stays there and doesn’t seem to find it.

I ran update.sh and got some error messages and now I can’t seem to restart it.

Had the same issue here on the first try.
While “checking for update” is displayed you should be able to use Encoder 1 to get back to the home menu to SLEEP and reboot

Second try worked after I made sure the wifi was all good.

Norns doesn’t start up again now is what I meant by ‘can’t reboot’ :cry:

I guess I’ll wait for the images? It seems to be bricked.

Being able to both translate and rotate the screen is very exciting, especially for animation! Is there a scale feature?

Sounds like a killer update, thanks all!

1 Like

:eyes: https://www.cairographics.org/manual/cairo-Transformations.html#cairo-scale

1 Like

i’d guess the download wasn’t complete or something
(@tehn we really gotta check hashes for these if we aren’t doing so already? nvmd, i forgot how it works)

if you can shell to norns then at least you haven’t lost your ~/dust, and if you want we can probably sort out a recovery procedure that doesn’t require reflashing… PM or email monome?)

1 Like

I’m reflashing the SD card to the previous update and starting over. I wasn’t able to shell to Norns unfortunately. Thankfully, I downloaded my tape folder recently and there wasn’t any custom code in dust.

After flashing, when I update it now shows statuses like ‘downloading’ and ‘unpacking’. None of that happened last time.

2 Likes

For anyone wondering, this fixes the problem Dan described here: the MIDI mapping screen implied that you could map the full range of a MIDI CC to a small part of the range of a control or taper param, e.g. you could control a filter cutoff from 2000 Hz to 20000 Hz, even if the param’s actual range went down to 20 Hz – but that wasn’t actually possible until now.

param mapping screen

The new version also shows actual param values for out (as shown above) instead of 0 or 1 for the min/max of the param range, and you can fine-tune the min/max by holding K3, like you can in the params edit menu.

8 Likes

can you describe what happened when it broke?

it sounds like there was a timeout with detecting the new version— which is likely a wifi/internet issue. if this happens in the future, try rebooting.

but what follows with the terminal business— did you shell in and run the norns update.sh manually?? from the norns folder? this is absolutely not good and should not be done (there are no instructions anywhere suggesting doing this, i hope). while this process should fail— i wouldn’t have expected it to brick your OS (though i haven’t looked, it very well may).

Yeah, based on what I’m seeing and reading here, there was some sort of issue with the internet connection and the update process. It was odd because I was able to connect to Norns via wifi and the system status showed wifi was working.

I did ssh into Norns and manually ran update.sh. The reason behind this is because when I had Norns in the past, that was the update process if I recall. Took a break from things and it seems they are a little different now, so I won’t dare do that again…eek. I’m in good shape though now after reflashing and running update via the Norns menu. It didn’t take me long to get up and running again and to my surprise, a lot of the scripts I use were part of the image. :+1:

Sorry to cloud the thread, but hopefully someone benefits from the odd things that happened and just restarts their Norns if updates don’t seem to start. :slight_smile:

glad it worked out and thanks for the heads up— it gives reason to clarify the purpose of some files in the repo, along with adding some timeouts if the wifi github query isn’t working.

Does this fix the jumpy encoders?

nothing in software is going to fully fix jumpy encoders. you probably need to replace the encoders

Ok. I’ll send it back cause right now it’s unusable.

This update on a DIY shield went well here. Got it trough on the second go. Thanks!