Norns: update 210411

use SYSTEM > UPDATE

210411

norns 2.4.11

  • ADD menu: SYSTEM > RESTART (like reset, but don’t erase state) @tehn
  • FIX softcut: set loop points and position at same time @zebra
  • FIX fileselect: allow symlinks (ie, to support usb disks) @csboling
  • FIX screenshot: antialias mode to GRAY to prevent color distortion @csboling
  • ADD params: get_range() to control type @Justmat
  • ADD lattice: hard reset with modified divisions @kasperbauer

maiden 1.1.1

  • ADD documentation link for catalog entries @ngwese
  • ADD improved UX with installing/updating scripts @ngwese
  • FIX supercollider repl eval @ngwese

doc links in maiden!

    {
      "project_name": "tambla",
      "project_url": "https://github.com/ngwese/tambla.git",
      "author": "ngwese",
      "description": "bending rhythmic arpeggio",
      "discussion_url": "https://llllllll.co/t/37965",
      "documentation_url": "https://norns.community/authors/ngwese/tambla",
      "tags": ["midi", "gen", "sky", "sequencer"]
    },

documentation_url will add a book icon which links to the provided url (whatever you want!). this is optional but we do encourage the additional direct link if you’d like to submit PRs for your projects in the catalog.

RESET vs RESTART

after some configuration/crash trouble, it is helpful to delete your system state and start clean with no script. but you don’t always want to do that (lose your fave list etc), so i added RESTART which “restarts” supercollider and matron, useful for when you’ve installed something new. (maiden now also reminds you to RESTART after installing something).

and

many fixes and nice helpful extensions, thank you all for contributing!

63 Likes

Thanks for this update with lots of important usability improvements.

It didn’t go as smoothly as the other times on my norns shield, though.
The system won’t boot after install.

I’m good to do a fresh install and a copy back a backup of my dust folder.

EDIT: It might very much be an isolated case. Don’t be afraid to apply, but be sure to have a backup just in case.

It worked without any problem with my Shield, for what it’s worth. Thanks for the great work everyone :+1:

1 Like

i’m assuming this was on a shield? this has been reported a few times and i cannot manage to replicate or confirm what may be going on. it did a full graceful shutdown? and you waited a good amount before powering down?

Yes, on a shield.

I did wait for the green led to stop blinking and them a few more seconds (about 10 I’d say).

Waiting not long enough could be the reason.

i’m realizing the language we use around this on-screen is gently murky – did the green LED go out completely? or did it stop blinking and enter its solid state? after updates, the solid state seems to last a lot longer than normal shutdown.

the green LED goes blinky, then solid, then out – safe shutdown is when it goes out completely.

1 Like

Screen Shot 2021-04-13 at 8.55.08 AM

i don’t know why, but this made my morning :smiley:

13 Likes

It seems it went out completely, but maybe was it making a “pause” before the last solid on state.

I might have been tricked by being too used to the standard blinking behavior when shutting down (in a non-update scenario).

A wav out of tape recorded on norns it seems corrupted when I drag it over to ableton.

It seems the same issue exposed here:

I’ve changed the extension to .aiff but the problem remains unsolved. What can I do?

that issue is quite old and does not apply. files produced by TAPE are 24-bit PCM, 48khz, stereo files in WAV format.

i would need a lot more details to know what is going on in your case.

  • is it reproduceable? (every file?)
  • how did you transfer the file?
  • can you inspect the file in some other way? (ffmpeg, sox, finder->properties, etc?)
  • in what way does it “seem corrupted?”
  • factory norns or shield?

here is the most recent issue we saw with TAPE output.

this issue essentially boils down to overruns due to slow writes to disk. if you are using a shield it could be a problem with a cheap SD card. (there were bugs in there too but they have been fixed for 2 years.)

if you have a new issue of course i would love to know about it, but in that case further details are particularly important.

2 Likes

Thanks for your help. I really appreciate it.

Yes, I can reproduce the files with VLC player and Audacity, not with Ableton neither Quicktime player. (I’m on macOS.)

I transfer the files with Samba.

Sorry, but I don’t use any of these tools. And finder → properties doesn’t show any relevant information like duration, sample rate, bit depth…

Well, like I said, Quicktime can’t play the file and Ableton doesn’t allow me to drag it on the timeline.

Factory Norns.

I should tell you that I forgot to play stop recording until minute 30. So it’s a big file. Don’t know if that matters.

Anyway, I could drag it into Audacity and from there export it to a new file that I can drag into Ableton. So issue is “solved”. I just hope that this was a sporadic problem.

Hm… maybe get ffmpeg via homebrew. Those are basically ports from other unixoid systems. I think I have a tape file that was created post update. I will check what file type it is. Not on my mac right now. Later today. Wanted to export that file anyway. Regarding the pops. How much space is left on your norns? Is it running the cm3 rpi module (less space) or cm3+ (In general: More space). Audacity should allow you to losslessly export the file as wav. Maybe it‘s the 48kHz sample rate or the bit depth of 24bits causing your import troubles.

Best,
Opty

PS: some tutorial gor ffmpeg insallation Installing ffmpeg on Mac OS X · fluent-ffmpeg/node-fluent-ffmpeg Wiki · GitHub

1 Like

not stopping the recording will almost certainly create a corrupted file. can you test again with a short clip where to stop recording?

2 Likes

Tested with a short clip properly stopped. No problem at all. It’s been my fault. Thanks.

1 Like