norns: update 210607

use SYSTEM > UPDATE while your norns is connected to the internet

norns 2.5.1 and norns 2.5.0 combined

  • NEW clock: overhauled clock system, uses jack time and improved sync @artfwo
  • NEW softcut: query position feature @zebra @tehn
  • NEW latest grid support (CDC) @zebra
  • FIX non-crow CDC devices not sent crow queries @tehn
  • FIX menu update bug due to jack change @tehn
  • FIX menu redraw bug @infinitedigits

clock

the big news: @artfwo deeply refined the clock system, which now uses jack to keep accurate time. various sync and link functions are improved. thank you to everyone on the norns discord who volunteered to test and provide feedback!

there are no breaking changes to the scripting API.

softcut

new command

  • softcut.query_position(voice) — triggers a callback reporting the current position of the voice
  • softcut.event_position(function) — sets the callback

use this to get an asynchronous position, in cases where using the position poll doesn’t make sense (ie, if you find yourself using the poll at extremely high rates)

grid

latest grid uses a cdc driver, so the device management has been revisited and updated


images

disk images now available for both norns and norns-shield

see help | monome/docs

59 Likes

:raising_hand_man:
ummm… excuse me but i have a question… here on this page, it says norns is anticipated to return in july/august: https://market.monome.org/
but here on the ‘future stock updates’ page: monome
it says august/september :sob:
which one is it? any news for more specifics on its return?.. i’ve been waiting patiently, even emailed you all, but got no answer :crying_cat_face:
i feel like the guy in this video:
The Simpsons - "When Do We Get The Freakin' Guns!?" - YouTube

(that probably makes you ‘chief wiggum’ :stuck_out_tongue_winking_eye: :policeman: )

“WHEN DO I GET THE FREAKIN’ NORNS!?!”

(apologies in advance if my humor goes over poorly… no worries if there’s no new news… just thought i’d ask, …in my own way :yum: :innocent: )

2 Likes

oh dang! i just saw that you bundled it up in your 256 message, which is auto-lumped into an “email these kind folks if we ever have 256 news”, apologies! never meant to ignore. folks should never feel shy about double-tapping us if their messages don’t get addressed – we aim for < 24 hour turnaround :slight_smile:

component shortages are a massive drag and keep us from being able to predict exact windows. shield will be back this month, though. we’ll continue to update the future and market pages + will be better about keeping those in sync, thank you for the bump!

brian’s emailin’ you back rn, tho :slight_smile:

7 Likes

ah no worries, i never doubted… just saw this thread as an opportunity to ask about it while portraying myself as a norns-craving psychopath :crazy_face:

and am happy to get Brian’s email just now(will reply asap).
Thanks again to both of you, and all else there helping to keep this awesomeness at full speed and integrity :trophy:
Much Appreciated :pray:

3 Likes

cool! looking forward to the new clock. I’m trying to update a shield and it is stuck on the “preparing” screen…unless it is normal for it to take a while (it has been about 5 minutes)

1 Like

I got the same here.

hmmm… my shield didn’t do this. you can cancel with K2. try restarting and try again. keep maiden open while doing the update which may provide some extra info.

1 Like

restarted, tried a few more times and no luck. The shield connects to maiden on restart but when I confirm to install the update it disconnects from maiden.

looking into it with a fresh shield. will get back to you.

@ohm to confirm, did you do any git updating since the previous SYSTEM UPDATE? or did you run the clock beta round one? which version are you updating from?

1 Like

ok i’ve confirmed it works fine with a fresh shield image.

to help debug, ssh into the device and run maiden-repl prior to attempting the update. this will give some debug information.

if you did in fact attempt the clock beta round 1— and didn’t do round 2, you may need to do a manual upgrade:

details
  • ssh in
  • cd norns
  • git pull
  • git submodule update --recursive
  • ./waf -j 2
  • sudo shutdown now

note that your version will not change, but you can now re-run SYSTEM > UPDATE

3 Likes

Confirming that did it - thanks!

1 Like

Thank you for the details on how to do the manual upgrade. I’m all good now.

2 Likes

Smooth update on Shield here and just in time as I got the shipping notification for my Grid today–woot!

3 Likes

Thanks again for this important milestone.

4 Likes

Amazing! Ive been waiting fr the Clock overhaul. Hoping this addresses some sync issues when clocking Norns with crow. Will be testing this out asap. Happy Days :hugs:

4 Likes

I was only able to spend a few minutes yesterday and to me the clock/sync seemed tighter than ever! Wohoooo!

4 Likes

also no problem installing on a shield - I had maiden debug open and everything looked good to me.

the clock is working so extremely well, thank you so so so much @artfwo. absolutely amazing work!

4 Likes

popping in to say I’m very excited to play with the new device detection stuff! glad that its going to be easier to make alternate grids now.

I have no idea why, but I noticed that the new firmware generates more background noise on norns shield than the old version (I still have the old SD card with version 201202). And also in the old one the noise was in mono, while the new one generates stereo noise. I recorded the examples. All the settings are absolutely identical, I checked.

202102: Dropbox - 202102 Noise.wav - Simplify your life

210607: Dropbox - 210607 Noise.wav - Simplify your life

i’m having an odd issue trying to update to 210607. not sure exactly which version i was running previously; i think the last time i updated was around a month ago. i updated seemingly successfully but i noticed when it said to wait until the non-red light stops blinking the green light had stayed on not blinking the entire time. i waited a minute with that light still on and after powering off + back on i get nothing from the norns. i tried re-flashing the drive and updating a second time, and the same thing happened once i got to the screen that says turn off when the non-red light stops blinking. light stays on, and then once i power off + back on i get nothing. any ideas as to what’s going on?