norns: update 210706

use SYSTEM > UPDATE

(multiple updates listed here due to hotfixes!)

crow 3.0, clock features, maiden update, and various bugfixes.

210706

norns 2.5.4

210701

maiden 1.1.2

  • NEW add ctl+enter (or cmd+enter) key binding to trigger editor selection evaluation @infinitedigits
  • NEW select current editor line for evaluation if no selection exists @infinitedigits
  • FIX disable auto correction/completion/capitalization in the REPL @xmacex

210630

norns 2.5.2


new clock feature brought to you by @artfwo (apologies, i initially marked this as a fix!)

clock offsets

now it’s possible to specify an offset for a sync position as follows:

 -- sync and resume at the next whole beat as usual
clock.sync(1)
-- sync and resume at the next whole beat with a half-beat delay
clock.sync(1, 0.5)
-- sync to the next 4th beat, but resume earlier by a quarter-beat 
clock.sync(4, -1/4)

-- create a swinging feel for a coroutine
-- by delaying even beats by half of the beat length
local beat = 1/4
local offset = beat / 2
local swing = 0

clock.run(function()
  while true do
    clock.sync(beat, offset * swing)
    -- do something
    swing = swing ~ 1
  end
end)

a bit of extra care should be taken with negative offsets, as they can lead to somewhat unexpected delays, e.g. clock.sync(2, -2.5) called at beat 0 will schedule resumption of the coroutine at beat 1.5, which is computed as 4 - 2.5, where 4 is the least possible beat divisible by the sync value of 2 which can also be scheduled in the future with an offset of -2.5 beats. hope this makes sense :slight_smile:

with positive offsets, sync will just be delayed by the time specified (in beats).

generally this allows relatively painless implementation of swinging rhythms in scripts and provides quite interesting results when different swinging patterns are used concurrently.

43 Likes

norns is a gift that continues to give. :smiling_face_with_three_hearts:

11 Likes

so many cool updates today!!

one question - does this latest norn release include the latest maiden 1.1.2?

1 Like

oh no i missed it! will post an new update tomorrow

5 Likes

top post updated— re-run SYSTEM > UPDATE to get the new maiden which has some added features.

7 Likes

Uuh yeah good updates for live coding, thank you @infinitedigits (end to copy-paste from buffer to REPL input maybe) and @tehn of course :robot:

3 Likes

hey yo! trying to update my official shield… shield is connected to wifi, confirmed working and the same network as my laptop. i can command k into the shield and access it that way but i can’t connect to maiden. tried to do the update but it just hangs on downloading forever. though this 5th and latest attempt to update eventually (after maybe 25 minutes) came back with an update failed message.

any suggestions for what to try next? thank you for your help!! hope you are well

norns 210706

some hotfixes! updated top post. crow users definitely get this.

@instantjuggler usually this means bad wifi connection, which is annoying. have you revisited this yet? try to connect to maiden prior to updating so you can see progress messages. try moving closer to your wifi router.(sorry for the dumb suggestions)

3 Likes

:bird: what an excellent ecosystem

trying to sort an issue with the new Bowering script.

when selected on norns, the norns screen displays none and is frozen - I have to wait for the battery to drain to get back to the home screen (happened on 210701 and 210706). I assumed the new bowery collection came w/ crow v3, but do I need to upload them myself? thanks!

Matron displays:

Summary
script load: /home/we/dust/code/bowering/bowering.lua
cleanup
script clear
including /home/we/dust/code/bowering/lib/boughs.lua
including /home/we/dust/code/bowering/lib/draw.lua
# script run
>> reading PMAP /home/we/dust/data/bowering/bowering.pmap
m.read: /home/we/dust/data/bowering/bowering.pmap not read.
Engine.register_commands; count: 0
___ engine commands ___
___ polls ___
amp_in_l
amp_in_r
amp_out_l
amp_out_r
cpu_avg
cpu_peak
pitch_in_l
pitch_in_r
# script init

while it displays none, have you tried either:

  • holding K1?
  • turning E1?
1 Like

Odd, but doing this seems to restore normal functionality - E1 now scrolls through bowery scripts, and a K1 press takes me back to the norns menu (previously, neither made any movement, hence the confusion).

EDIT: spoke too soon, norns froze on boids, and I wasn’t connected to Maiden :man_facepalming: so let me check back in a min.

2nd EDIT: um, it all seems fine after a reboot :man_shrugging:

thanks again!!

crow update forthcoming

thank you for the help!!! i tried the update a few different days… but i was always in the same venue and on the same wifi with no luck. however, upon your response here i tried the update now that i’m back home and it worked perfectly and easily! what threw me was that when i first tried, i could easily command k into the shield. so i figured that wifi was working like normal.

thanks so much for these updates(and for this OG norns, only played with it a month so far, but understanding the system and really loving it thanks to the folks on the discord @tehn @zebra @dan_derks @Quixotic7 @infinitedigits @license and many others)… special thanks to @artfwo for making such a great clock system, i arrived at this just in time(and artem’s the one who kept convincing me to come back to Lines years ago from meeting on the Facebook group)…
got the very basics of my first app up and running, so much more to learn(and even more to practice), but it’s quite a joy so far, especially with the clock system and the ability to implement swing :man_dancing: :dancer:

Thank You All! :pray:

24 Likes

20 characters of cool stuff, @rajaTheResidentAlien :slight_smile: Looking forward to playing with the app very much!

1 Like

ooo nice looking app. Please share when your ready :slight_smile:

1 Like

very very very cool stuff @rajaTheResidentAlien. can’t believe that’s your first app - its so fully realized and sounds beautiful. isn’t is just so cool to have an idea and make it reality?

5 Likes

@infinitedigits
absolutely!
was pure joy that i didn’t even start with any idea aside from just thinking to myself: if i can draw a circle on my grid using this system, it’ll teach me so much about how to think around the grid in general within this system… fitting a round peg into a grid of square holes so to speak. after drawing the circle, i then learned how to rotate a line of pixels around a center point, there’s where the main idea of the sequencer started, never realized that’s where i’d end up when i began.
excited now to dig into more depth, one of the most helpful things was seeing a video of tehn going over clocks with softcut, in particular, moments like where mozilla asks him to update the browser, or when he misspelled ‘screen’, still carrying a smile the whole time, keeping his enthusiasm in the moment and remaining engaged with others in the chat: this is the essence of “techno joy” and it’s so alive here in community(which is why i felt like posting this in the updates thread rather than ‘latest tracks’ since the growth of norns is so much about the community working together), now excited to continue studying your mx.samples, and also @tyleretters recent vod on how he created goldeneye… great to be alive amidst this huge ‘mosh pit’, where as we stumble through learning and creating, everyone’s there to catch us and help us roll with it :hugs: :v:

11 Likes

Hi! Reporting an issue I found with a script that used to work, I tried to search to see if this issue was reported, but couldn’t find it.

When using g:rotation(1), which seems to correspond to led (1,1) being on the top left when orienting the grid vertically with the usb port on the top, the bottom half of the grid will not respond to g:led commands, although the pads work as intended. I tested on a fresh script to isolate the issue and I could reproduce it:

g = grid.connect()

function init()
g:rotation(1)
end

function grid_redraw()
g:all(10)
g:refresh()
end

And then running grid_redraw(). Only the top 64 pads light up.

Has anybody experienced anything similar?

1 Like

Norns keeps looking for update but always fails here, maiden says the same thing. Anyone else getting this?