norns: update 210927

Looks like a great set up updates and fixes; nice work.

Updating has gone mostly fine so far; I had difficulty reconnecting the wifi, but powering off with sleep and restarting a couple of times as well just for good measure fixed that.

i added the tag here. at a quick glance, seems like this is the only one where the tag was mistakenly left off.

3 Likes

The mod system looks really cool :sunglasses:
Also like the audiofile preview :+1:
I love you people :heart_eyes::control_knobs::fire:

1 Like

I’m really excited about these (since I did them I should be haha)! What actually happened is softcut’s read_buffer_mono and read_buffer_stereo now have mix and preserve arguments, allowing you to read in audio from a file at something other than full volume and preserve some amount of what’s already present! We used Lua’s default arguments, so existing softcut code should need no change.

8 Likes

are live!

two sets of examples:

  • first one sets up a little scaffolding in the script and then encourages live-execution using the CMD-ENTER / CTL-ENTER maiden keyboard gesture contributed by @infinitedigits a while back. i think there’s a ton of potential in manipulating sequins on the fly via livecode :revolving_hearts:
  • second one shows how any datatype can be sequinsed!
15 Likes

for the sequins and lattice curious, i created this “eduscript”

10 Likes

this question may have already been answered; my apologies if im just not seeing it

how would i find more information about learning to build mods, or even just see an example. i feel like its right in front of me and im not seeing it, but contributing to this idea seems more up my alley than trying to keep up with everyone else in making an entire script… for now at least.

heres the mod code for my “make arc lfo available to any params mod” . the code lives in /lib, check the end of the file for the mod registration hook.

7 Likes

perfect! thank you. this is more than enough to help cure my headaches

1 Like

this is awesome, thanks for sharing. time to make hnds into a mod :smiley:

5 Likes

yeah!! I thought about adding more universal lfo control like hnds then realised, we can run both at the same time :wink: lfos for days.

1 Like

I haven’t had a moment to try this out, but – how does this have the arcs hook up to modify arbitrary script params if the mod runs before init(), but a script’s custom params aren’t registered until during init()?

It works by monkeypatching/wrapping the init() function. Whatever was the existing init function gets replaced wrapped in a new function which runs init() then runs the mod init.

2 Likes

oh wild! i saw script_pre_init in the docs and assumed it was fully before – i did not notice that you had access to the script’s init function for your monkeypatch:

okay that’s dope – i’ll port Crowify: easily map Crow inputs to Norns params to a mod in the next few weeks, then

6 Likes

Question about the “Update all” status messages in Maiden with this update. If no scripts need updating will there be a No updates: The latest version of "whatever" is already installed type message?

I just went to check for updates, selected update all and it seems like it is stuck on Updating all projects Please wait...

Maybe that just means nothing needs updating or is there a way I can check if git pull(?) is stuck somewhere?

That is an indication that maiden is having trouble contacting GitHub, or the WiFi signal could be weak, or potentially a large quantity of scripts are installed and one or more are taking a long time to download. As of now there isn’t any progressive feedback.

The script download/update mechanism itself hasn’t changed in this update.

1 Like

Ok, thank you so much for these tips. I haven’t downloaded any more scripts than what I had prior to this last update and my Wifi signal hasn’t been an issue either so perhaps it is Github. Gonna try on a different laptop and location just to be sure and report back.

EDIT: I discovered the issue. @tomw 's beacon script is where Update All is getting stuck. I removed the script from my Norns and Update All was able to finish. I re-installed beacon with no problem and the stuck Update All issue returned. I believe this script was just updated recently so not sure what is happening to break Update All

Hi! I write a comment for first time here!
I updated 2 days ago and I have a problem with maiden. Now it doesn’t work with anything. I tried with Mac, Windows, different browser but nothing. Cyberduck works just fine and also with SSH norns is connected. The only (big) problem is with Maiden. Any one has the some problem? Thanks for your amazing jobs! (and sorry for my English, not so good).

Assuming that you’ve tried all the following (and maiden still isn’t working):

  • Clearing the cache in your browser (then trying http://norns.local/)
  • Using the IP address: http://<ip_address_of_your_device>/

The next step I would recommend if you are comfortable with SSH is to use SSH to log into your device and run the following command systemctl status norns-maiden. Output from that command on a healthy device looks like:

● norns-maiden.service
   Loaded: loaded (/etc/systemd/system/norns-maiden.service; disabled; vendor preset: enabled)
   Active: active (running) since Thu 2021-10-14 23:06:15 PDT; 1 weeks 0 days ago
 Main PID: 347 (maiden)
   CGroup: /system.slice/norns-maiden.service
           └─347 /home/we/maiden/maiden server --debug --fd 3 --app ./app/build --data /home/we/dust --doc /home/we/norns/doc

…if it shows active (running) then that may indicate some problem with the browser.

…if it shows stopped or failed then my best guess would be that the maiden installation might have been broken somehow during the update process. Again if you are comfortable with using SSH I might suggest manually applying the update again using the manual update process.

2 Likes

FYI i had the same problem with Maiden after update. For me, disconnecting and then reconnecting WIFI on Norns solved it, in case you haven’t tried that already.