norns: update 210927

heres the mod code for my “make arc lfo available to any params mod” . the code lives in /lib, check the end of the file for the mod registration hook.

7 Likes

perfect! thank you. this is more than enough to help cure my headaches

1 Like

this is awesome, thanks for sharing. time to make hnds into a mod :smiley:

5 Likes

yeah!! I thought about adding more universal lfo control like hnds then realised, we can run both at the same time :wink: lfos for days.

1 Like

I haven’t had a moment to try this out, but – how does this have the arcs hook up to modify arbitrary script params if the mod runs before init(), but a script’s custom params aren’t registered until during init()?

It works by monkeypatching/wrapping the init() function. Whatever was the existing init function gets replaced wrapped in a new function which runs init() then runs the mod init.

2 Likes

oh wild! i saw script_pre_init in the docs and assumed it was fully before – i did not notice that you had access to the script’s init function for your monkeypatch:

okay that’s dope – i’ll port Crowify: easily map Crow inputs to Norns params to a mod in the next few weeks, then

6 Likes

Question about the “Update all” status messages in Maiden with this update. If no scripts need updating will there be a No updates: The latest version of "whatever" is already installed type message?

I just went to check for updates, selected update all and it seems like it is stuck on Updating all projects Please wait...

Maybe that just means nothing needs updating or is there a way I can check if git pull(?) is stuck somewhere?

That is an indication that maiden is having trouble contacting GitHub, or the WiFi signal could be weak, or potentially a large quantity of scripts are installed and one or more are taking a long time to download. As of now there isn’t any progressive feedback.

The script download/update mechanism itself hasn’t changed in this update.

1 Like

Ok, thank you so much for these tips. I haven’t downloaded any more scripts than what I had prior to this last update and my Wifi signal hasn’t been an issue either so perhaps it is Github. Gonna try on a different laptop and location just to be sure and report back.

EDIT: I discovered the issue. @tomw 's beacon script is where Update All is getting stuck. I removed the script from my Norns and Update All was able to finish. I re-installed beacon with no problem and the stuck Update All issue returned. I believe this script was just updated recently so not sure what is happening to break Update All

Hi! I write a comment for first time here!
I updated 2 days ago and I have a problem with maiden. Now it doesn’t work with anything. I tried with Mac, Windows, different browser but nothing. Cyberduck works just fine and also with SSH norns is connected. The only (big) problem is with Maiden. Any one has the some problem? Thanks for your amazing jobs! (and sorry for my English, not so good).

Assuming that you’ve tried all the following (and maiden still isn’t working):

  • Clearing the cache in your browser (then trying http://norns.local/)
  • Using the IP address: http://<ip_address_of_your_device>/

The next step I would recommend if you are comfortable with SSH is to use SSH to log into your device and run the following command systemctl status norns-maiden. Output from that command on a healthy device looks like:

● norns-maiden.service
   Loaded: loaded (/etc/systemd/system/norns-maiden.service; disabled; vendor preset: enabled)
   Active: active (running) since Thu 2021-10-14 23:06:15 PDT; 1 weeks 0 days ago
 Main PID: 347 (maiden)
   CGroup: /system.slice/norns-maiden.service
           └─347 /home/we/maiden/maiden server --debug --fd 3 --app ./app/build --data /home/we/dust --doc /home/we/norns/doc

…if it shows active (running) then that may indicate some problem with the browser.

…if it shows stopped or failed then my best guess would be that the maiden installation might have been broken somehow during the update process. Again if you are comfortable with using SSH I might suggest manually applying the update again using the manual update process.

2 Likes

FYI i had the same problem with Maiden after update. For me, disconnecting and then reconnecting WIFI on Norns solved it, in case you haven’t tried that already.

Thanks for this information - that said I’m completely baffled as to why the update process could cause this behavior.

here’s a video for how to nuke norns and get a clean install:

4 Likes

Hi!
Thanks for reply.
I did all things you wrote but maiden doesn’t work.
I’m not comfortable with using SSH, I’m a poor musician! But I tried your suggestion and it is active so I think something was wrong in update. It’s very hard for me the manual update. I’m waiting next update for using maiden again, I don’t want to format Shield’s card.

Would a forced update (holding k1 while in the update menu) possibly help here by rerunning the latest update for those uncomfortable with a manual update over ssh?

Ran the update on my shield last night and now I’ve got no wifi and midi devices don’t populate in the list.

Wifi: Says “unavailable” on the main screen and under add it says “none.”
Midi: Devices power up, but under devices>midi I get “none” when I try to add one.

Ideas?

:UPDATE: I reflashed the sd from scratch and all is working as expected. :ok_hand:

Having some trouble installing this update on my factory norns, have tried a few times thru system > update, and get an ‘update failed’ message on norns. Maiden says -

checksum validation…
sha256sum:
WARNING: 1 computed checksum did NOT match
update failed.

EDIT: nevermind, 4th times the charm I guess :slight_smile: