norns: update 230405 (hotfix 230526)

use SYSTEM > UPDATE while connected to the internet via wifi

norns 2.7.4


just encountered a strange issue after updating: I was running cheat codes with pad-to-note setup to sequence jf & w/syn with banks b and c and trying to jump around the live buffer with bank a, with my modular out going into norns inputs, monitoring with the norns headphone output. Sequencing was working great, and sound was coming through norns to the headphones, but the cheat codes live buffer wasn’t picking up anything when I set it to record. The softcut adc input was turned up, so I checked levels, and this was the really weird part: even though I was hearing sound coming out of norns’s headphone output, nothing was showing up on the input or output meters. If anyone’s able to reproduce this issue after updating or offer any ideas as to a fix, I’d be very thankful! I can also share logs if that’d be helpful

this will sound weird, but is it possible you had stuff plugged into the norns outputs instead of the inputs? this will cause whatever youre sending to also show up on the headphone ouputs, but of course it’s not really being captured.

(with the lack of labelling i actually find myself doing this not super infrequently on stock norns.)


oh my, this was it! Thanks for thinking of that. I was way overthinking it and lost sight of what was right in front of me. Sorry for the false alarm


I gave it a spin yesterday and was working like a charm! I was having some odd freezes which I speculate my mac and matron where causing. So far yesterday I had a decently lengthed session with no lock ups.




Anyone else having any issues with Arcify?

When I have the mod turned on, I can’t navigate to the mixer screen.

Only started happening post update.

@Agraham1987 :wink: Just bustin’ your chops.


I was wondering about a little issue I’m having.
When I’ve used my Norns after the update (using for a while running CC2 and Rebound mainly and whilst plugged into power) the battery runs down to 0%.
My reading next to the battery is at 8mA - I’ve tried various sockets etc and it’s not going any higher than that.
Before the update I’m not entirely sure what the reading was but whilst plugged to power Norns never ran down from 100%.
Any idea what might be causing this?

1 Like

I also noticed that after I updated my battery life just started dropping while plugged in. I hadn’t paid attention to it before so not sure if that is new behavior or not.

Whats your mA at?
Mines now reading 0mA and Norns is sitting at around 1%.
Getting multiple low battery notifications as well.

Unplugged 2021(USB-C) grid and the mA goes up to around 100mA.
Once grid is plugged back in the mA heads straight back down to 0/1mA.
Certainly wasn’t happening before update so I’m guessing its a bug of sorts.
I’m going to leave Norns alone and plugged in for while without the grid attached to see if it charges up - fingers crossed.

are you all using the supplied power supply? testing here with a grid plugged in and i’m not seeing any current draw while plugged in.

mine sits at 120 mA @ 100% while plugged in. (current draw is indicated by a negative mA number.)

1 Like

I do have the supplied power supply and have tried one other but the problem still remains.
It’s when the grid is plugged in, the mA reduces rapidly and Norns doesn’t hold it’s charge even though mA isn’t dropping into the minus.

if norns is losing power while there is a positive number, that means charging, then maybe there is a battery issue?

Absolutely, but it it has only happened since running the new update…

updated here to 230405. not using the given power supply, but using another usb-2-walloutlet style power supply(belonged to a ‘blink’ camera), while plugged in, my battery’s sitting at
0 mA @ 100% (battery doesn’t drain while plugged in… (is ‘0mA’ normal? [edit: i’m thinking so because i’ve used it heavily last few nights while plugged in, so it must be fully charged by now]))

Here’s a vid to show what’s happening in terms of battery draw.
Sorry for the poor quality, had to compress to get it to the right size.
Hope it gives a little more insight into the problem.
(I left my Norns alone for while, switched off, with the grid detached and it got up to 100% again)

i think maybe there’s no problem then(?)
also, you originally wrote it was ‘8mA’ but the vid shows it intermittently going to ‘-8mA’…

if norns is losing power while there is a positive number, that means charging, then maybe there is a battery issue?

:point_up: just to be clear, @Justmat wrote that meaning ‘positive number’ for current implies ‘charging’, therefore if charge is being lost while it’s positive maybe some issue…then again, positive, i thought, just meant there’s more ‘charge’ than ‘draw’ occurring, whereas negative means there’s more ‘draw’ than ‘charge’ occurring(and the display can also be inexact because its polling an average over a general capacitor-style ‘slew’)… but either way… seems the opposite of what the video is showing?(the video is showing intermittent display of a negative number for current/mA while plugged in, with no loss of power from ‘100%’, which seems normal, maybe there’s just an intermittent heavier draw every now and then?)

also, so far, doesn’t seem specific to this update(maybe if @Zeke_B can provide more detail on what they saw)?

1 Like

Sorry I haven’t come back to this thread—crazy day. I will try to boot up and get a pic of what I was referring to.

1 Like

found a bug:

Problem → engaging with the ‘Battery Warning’ field, mistakenly by using K3, will cause norns menu-navigation to be trapped within this screen of the settings menu from then on

Steps To Repro:

  1. Navigate to the ‘home’/main menu of norns, then go into System>Settings
  2. Scroll down using enc2 to highlight the “Battery Warning” field
  3. Press k3

Norns is trapped on this screen of the settings menu and pressing k2 will no longer allow you to back out like normal(and though enc3 works to select other items in this menu including the ‘RESET’ function, activating ‘RESET’ from here using k3 is not possible - had to use the hard-reset button under my stock norns to test this out… edit: oops - i just remembered i could’ve also used “;restart” from within maiden - for anyone else trying to confirm/verify).

Expected Results:
since this field is just a simple toggle ‘ON/OFF’, pressing k3 here could flip the state of this field(?), but in any case, pressing k2 should allow us to back out of this menu/area/screen(as well as the other usual functionalities working here: i.e. k3 should work on the ‘RESET’ part of this menu screen), after trying k3 on the ‘Battery Warning’ field.

Additional Details:
-fiddled with k1, during this problem, and the font changed to the font of my app, but didn’t actually go into my app(so maybe that’s the same issue where all the buttons become unresponsive after pressing k3 on the ‘Battery Warning’ field?)
-it’s possible with this bug in play to navigate into the ‘Password’ section[edit: password can be changed by accident](and backing out of ‘Password’ section strangely involves pressing either k2 or k3, and then turning enc2… but then after you back out of password, you’re still stuck in the ‘Settings’ menu)
-this is on Norns update 230405(w/ nothing but power and a Panda Wireless PAU06 wifi usb stick plugged in)

:heart: Hope it helps. :sake: :heart:

EDIT: FIXED (resolved on github, fix should be in the next update)