Norns: updates



Would you mind elaborating?


That might be a clumsily worded statement. See these posts above


And to clarify I don’t mind if a batch of scripts is loaded at update periodically. I’ll just delete folders and scripts I don’t use (ala Teletype).

But it would not be ideal if the system demands that I download all to get just one new script that i need.


Ah, ok.

Yeah, I admit I wasn’t personally all that excited about those ideas either. But I do think some additions to maiden to make norns more git-aware could be of help?


I mentioned this in the ecosystems thread as well, but might be worth adding here.

The way that something like Node.js handles libraries seems like a reasonable reference point for this. Or even the way something like Atom (the text editor) handles plugins.

Each “library” (aka Norns script/app) is owned by its creator and in their own git repo. They all follow the same structure. There is a UI (or command or something) to add libraries either via direct github URL or through a central repository search. It’s up to me which ones I choose to install, and I can get them from the official repo (aka Dust) or from anyone’s github that I choose myself.



My norns, arrived today!
The postal service in Brazil is very bad!

Well, before using it properly, I’ve tried already updating it for the latest firmware. But it was not working. It was giving the same error that it gave to few people (“no updates found”).

And it was not becoming clear to me what I was doing wrong, even following the same steps as those who succeeded. But now I just got it!

What worked for me was, click the big “DOWNLOAD” with the right button and ask for “downloaded linked file as”.

Doing this way Safari does not automatically compress the file, which causes the folder name to be renamed. The correct folder name when the download is done this way is “norns180707.tgz”.

In my case I did the direct download to my flashdrive, and neither needed to unpack, the norns read and unpacked it alone. Then I turned off by “SLEEP” mode. I turn it on again and it started the update. The it asked to turn it off again, I turned off by “SLEEP” mode again. When I turn It on again, it was updated correctly!

Sorry if it was repetitive. But I think it might help somebody in the future. A very simple download but it was giving a bit of a headache here and delaying the fun!

Now I will enjoy my norns! :v:


hello everyone! finally here! a result of much discussion and many contributions.




now dsp is multi-core (!)

thanks to @zebra, norns uses supernova instead of scsynth. sc “groups” can now be spread in parallel over many processors, and we’ve updated the engines that can take advantage of this for much more CPU headroom (preventing CPU crunch noise etc)

softcut is softer and more

again @zebra, improved playback quality and now more channels. mlr is at 6, and i fixed the record start/stop clicking (!) and a few other minor improvements.

midi/grid management

finally! with much input and collaboration, we have a very intuitive and dynamic way of scripting for midi and grids. i’m starting on the study right away. there is now a device/port selector, seen in SYSTEM > DEVICES


a bunch of new contributions, thank you!

little stuff

tons of little fixes all over the place. full list of updates on github.


we have a lot lined up for the next update. if you’d like to take a look: (summary: projects, huge tape overhaul, globals management, bugfixes)

and of course we have some bigger ideas as well. i’m excited to witness the unfolding.

thank you for your continued support and collaboration!

Norns: studies

for those of you who can’t wait for the study, here’s how the new midi/grid stuff works:

local o = midi.connect() -- defaults to port 1 (which is set in SYSTEM > DEVICES)
-- process incoming midi: convert to message table and print
o.event = function(data) 
-- helper send functions:
o.note_off(80) -- optional off vel
-- raw bytes:
-- or message table:
o.send{type="note_on", note=80, vel=100}

-- select different port
local second_midi = midi.connect(2),100)

-- grids
gr = grid.connect(1) -- get grid port 1 (defined in menu)
gr.event = function(x,y,z) print("hello!!!") end

Norns: help

quick fix — minor bug found by @Justmat and i’m uploading a new tgz


Mind-reader! Thanks for the quick example and update; can’t wait to dig in.



This is great. If I’m keeping up-to-date using git pull on the norns and dust repository, what do I need to do to be up-to-date on norns-image?


this update contains a bunch of packages (.deb files) for supernova. the norns-image changes are rolled into the script.

even if you’re tracking with git, i’d suggest running this update, then re-clone your repos if you’re on your own fork


Thanks! (20 characters)


Not sure what Im doing wrong but Norns wont see the update file on the Thumbdrive. Anyone experiencing the same? Tired all USB’s sockets and 2 different drives.


make sure it’s the .tgz file and not one that got auto-expanded by your browser/download


yeah, I did it exactly the same way for 707, which worked a treat.


be sure to remove the other update files from the thumb drive. i just noticed it gets confused if multiple updates are present on the disk.


When I try to update I get a no updates found error message, and the log shows: bad update file. I don’t know if this is relevant but my norns also always shows disk free:0

Any suggestions?
edit: yeah, sounds like problem above. prior update not recognized, tried with a couple drives.


hmmm was freshly formatted. Ive checked 6 drives now… ha, had a few hanging around. Ive also tried the old updates to see if Norns sees them. But still sees nothing at all. Tried with Power supply / without. Drive inserted while on / while switched off… Standing on my head etc. Strangely still nothing


Hey, when you hit the ‘update’ do you get the ‘searching for updates’ dialog? or does it instantly display ‘no updates found’ ? Previously Norns would search for the updates but now it seems like the USB is not being seen at all. I do get light indication on the drives however.


@doublecoolbossman disk space free = 0 is bad. probably filled up with tape files.

connect to your norns via FTP and delete some files after backing them up to your computer. set up a hotspot, connect your ftp client to with user we pw sleep and navigate to /home/we/dust/audio

@yelsnit is your disk full also?