Norns: updates

note— this is mainly a functional release— not much new to play with (though the param set slots are very useful musically)

fun stuff coming soon. (and study 1 tomorrow)

7 Likes

Re: Update procedure - does the update file go in the root directory of the USB drive, or in the root directory of the files that Norns has put there?

1 Like

put the .tgz file in the root of the USB drive.

i’ll update the docs!

Great! Successful update over here.

One clarification for the docs: “reboot the machine” could be confusing, as the UI term “sleep” doesn’t emphasize that the device reboots, while the hard reset button on the bottom does. However, just putting the device to sleep and waking it back up worked for me.

EDIT: Holy smokes. 100 parameter set slots per app. Here I was just having fun with 1.

4 Likes

Successful update here as well! Thanks @tehn, @zebra and the rest of the team for the hard work. Norns has been a total game changer for me in the short time I’ve had it.

3 Likes

2 posts were merged into an existing topic: Norns: scripting

Successful update.
Brought it to work.
Ready to study.
norns is … disruptive.

2 Likes

Can’t wait to update later today!

I wonder if earthsea will remember the patterns in save slots?

only data listed in the parameter menu is saved.

saving pattern/etc data will be a separate operation… i’m looking at implementing a bunch of this sort of thing soon.

5 Likes

Oh, amazing!
Thank you.

FYI this sort of stuff is insanely easy to implement (especially compared to making updates to the modular).

right now the problem is time :slight_smile:

must focus on studies now in order to demonstrate how easy it really is…

6 Likes

not able to update and i’m not sure why.

here is a screenshot of my USB drive which is formatted to MA-DOS(FAT32).

plug that into norns while it’s off > boot up norns > update > “no updates”

am i missing something?

you seem to have downloaded the source code. the github interface is confusing because it lists a “download source” link just below the link you want

click the “norns180603.tgz” link as shown below

1 Like

ok i got it! i was clicking that link but it was downloading as a .tar file - just realized i needed to right click download file instead to get the .tgz file

Actually, this is a good point that’s worth highlighting in case other people have this issue, or have it intermittently - what’s happened is that you’ve actually downloaded the tgz as intended… but because clicking it tried to get it to ‘open’ it in your OS, or perhaps because you have auto-decompress on (it is in Safari by default I think), the tgz decompressed… into a tar file. If this doesn’t happen for anybody, it’s because they’ve got “auto decompress files” turned off. (I found this particularly annoying with tgz files.)

2 Likes

Okay, so I’m having the same problem, but it’s for sure the .tgz file I’m putting in the root folder. No update being detected by Norns. Any ideas?

I’m using Chrome to download the file, and it’s not unzipping on its own. I’m not unzipping it, either. (We usually at least go on a date first.)

Edit: I should note that I’ve been using this same USB stick for other Norns duties up until now with no problems. I don’t currently have another. I don’t know if the USB could even be a factor because I was born yesterday.

Edit 2: Norns log says “bad update file”. Reformatted the USB to FAT and tried again. Same result.

“bad update file” means the something went wrong.

you have norns180603.tgz in the root of your USB drive? it’s not 180603.tgz right? (i am sorry for the dumb question)

let’s also check your file. unzip norns180603.tgz and inside should be:

  • 180603.tgz
  • 180603.md5

is that what you see? (again, just put norns180603.tgz on the root of the USB drive, no need to unzip for the update, it handles this itself)

To work around the limitations of the Github Release page design perhaps we could make the file name something like “norns180603.update.tgz” ?

i’ll just make a big “DOWNLOAD” link

4 Likes

Yes, it’s norns180603.tgz and not 180603.tgz, but thank you for confirming. And yes, both the .tgz and .md5 files are inside.

I’m guessing it’s something to do with the USB drive that I pulled from the depths of my desk. I’ll find another and report back.