Norns: updates

norns

#183

see above: Norns: updates


#184

thanks for the update @tehn

trying normal USB update procedure with no luck. norns hangs on “checking for updates” will try to update Norns by sftp


#185

20 chars Thank you!!


#186

Worked perfectly for me! Excited about the grid/midi fix


#187

@sno with some USB keys it’s a long wait for some reason. try connecting first to maiden (hotspot mode) so you can see if there are any errors while this is happening.


#188

from maiden upon update attempt via USB key :

1

matron

sc

Selected interface ‘wlan0’

wpa_state=SCANNING

ip_address=172.24.1.1

p2p_device_address=40:a5:ef:0e:d7:c7

address=40:a5:ef:0e:d7:c7

uuid=8cc06114-0964-5106-8808-b934fa7397c9

ls:

cannot access ‘/media/usb0/norns*.tgz’

: No such file or directory

ls:

cannot access ‘/home/we/update/norns*.tgz’

: No such file or directory


#189

The file still has the .tgz extension and hasn’t been unzipped right?


#190

that’s what I’m seeing here:

the USB key has the .tgz extension:

I’m also stuck trying to enter the password sleep, doesn’t appear to accept any characters after the key symbol


#191

sorry for the confusing post, I have been trying and failing with both the USB key update and sftp method for updating


#192

this seems right to me (also your ssh command seems to be fine), I’m not sure what’s up :confused:


#193

update successfully via sftp @tehn did not see your reply, sorry… thank you so much for the fast update!

I did the following steps @kali_yuga

  • turn on hotspot mode
  • connect with SFTP, copy norns180904.tgz to /home/we/update/
    (I deleted what was in this folder before)
  • connect command prompt using ssh we@172.24.1.1
  • insert pw sleep
  • then these commands:

cd update
tar xzvf norns180904.tgz
tar xzvf 180904.tgz
> cd 180904
./update.sh

  • then sleep using the menu

norns now shows UPDATE 180904


#194

I think your file should be called norns180904.tgz (maybe best to download again?)
Entering a password in the terminal won’t show anything on screen, but it is being sent.


#195

thank you!! that was the problem… everytime I downloaded the update I got a .tar that I unzipped and used the .tgz file in that folder

the solution was to download again but right clicking and selecting Download Linked File As…

many many thanks to everyone for your help!


#196

thank you for this bug report. i need to figure out a way to make sure browsers/os’s don’t auto-extract the file.


#197

crypt or password the tgz file and include that pw in the update script string?


#198

I don’t think there’s any way to prevent this aside from what @kali_yuga explained.


#199

this is a safari problem, not a github/script problem.

solution: safari preferences -> general -> disable open "safe" files after downloading.

if this was being hosted on your own server, not github, you could try forcing the file’s mimetype to be sent as application/octet-stream via .htaccess (apache) or equivalent.


#200

silly hack: give it an arbitrary extension? 180904.norns


#201

@markeats i like your style


#202

Just installed the refresh, the only weird thing that happened is that the grid needed to be plugged into the left-most USB slot (the one closest to the display) in order to function reliably. Never thought I’d have so much fun with a bouncing ball.