Norns: updates



My Norns is really picky about which USB ports I use for things. The wifi will only work in the left most. A USB drive will only work in the left most two. Grid seems to work in all except the right most. …


Haven’t updated with the latest fixes, but I figure these might be related.


we’re dealing with some linux kernel driver issues with USB hubs/etc… thank you for your patience.

@karst i think there are some nomenclature issues that need to be cleared up. there’s physical usb ports, but then midi virtual ports (SYSTEM > DEVICES) which can get assigned freely. apologies for lagging docs!


I’m experiencing some temporal disturbances while attempting to update norns to 180904 via sftp.

I tried to install norns180904.tgz via USB procedure and got the NO SCRIPT error. So I then connected via sftp and followed sno’s steps. I get as far as:

tar xzvf norns180904.tgz

which then throws this date/timestamp error:

tar: 180904.tgz: time stamp 2018-09-05 05:28:07 is 3336404.734120383 s in the future

So… now what?


that’s a new one.

while you’re connected via hotspot open a terminal and type:

ssh we@

pw: sleep

then type:

date -s '2018-09-06 12:34:56'

then try the update again


Thanks for the superfast response, @tehn. I was still connected to norns for a bit, so I hadn’t seen it for a few minutes.

I tried setting norns date as you specified and got this new error:

date: cannot set date: Operation not permitted


20 characters of sudo?

sudo date -s '2018-09-06 12:34:56'


ha - I figured as such!

I’ve superusered the date change and have run the remaining update steps as per sno. What’s interesting is that norns now takes a minute or two to traverse menu-levels, but with some patience, I was able to ascend one level to select sleep. Upon reboot, however, the NO SCRIPT error still shows and the navigation remains slow.

So I enabled the hotspot again, ssh’d into it and then exited the session. The dir’s no longer lag, but the NO SCRIPT error still remains. I tried running the update process a second time, but still see the NO SCRIPT error.

If anyone has any further steps, I’m all ears.


NO SCRIPT just means you need to load something. Apparently this is normal if the unit has restarted in a funky state or via comandline reboot (so it doesn’t end up in a perpetual loop of loading a bad script for example)

Try to load a script either from the menu or via Maiden.


Oh. :flushed:

Aaaaand we’re good to go. Thanks, Steven.

And I’ll just say I appreciate everyone’s patience with my n00b ways.


I’m so happy with this feature.


i need to make this more clear in the docs (and perhaps with the error message)

NO SCRIPT isn’t really an error. it just means nothing is loaded. this will happen if you hard-shutdown norns (with a the bottom button) or crash it somehow. which prevents loading the last script which may have crashed your machine.


for those tracking with this thread: Norns: update 181002


fixes, mlr feature, osc param mapping:


fixes, new dust: Norns: update 181023


manual update method

so…i just attempted to do this now…
updating from file 180906 to 181023
iMac OS Mojave

was connected through a USB hub but removed that and connected NORNS directly to the back of the iMac

TERMINAL would NOT see USB drive…
Moved USB drive from USB port 1 closest to the power connection to the 4th USB port furthest from the power connection.

just discovered this bit of info on another page for TERMINAL which would be step 9:

rm -rf /home/we/update/*
sudo shutdown now

maybe that would have helped but NORNS had crashed anyhow…or it seemed that way.

and…i left out all the cursing in the above procedure.
feel free to use all of your curse words…you may need them.
and quit out of TERMINAL.

sad that MLR is only 4 tracks now instead of 6.


(hey spike!!)

mlr will be increase to 7 tracks once i implement mute groups. had to take it back down to 4 as we were seeing CPU issues. thanks for your patience!


many cpu fixes! mlr clip saving!

Norns: update 181101


Oh man so glad its going to go back to more than 4! I actually didn’t update yet because I was loving having 6 tracks so much.


I’m at the point where I’m visiting lines multiple times a day just looking for Gigunda, the Giant 2.0 Update.