Norns: updates

Is there a rough date to expect the v2 update? This month? First quarter?

2 Likes

i’m working on the beta installer today. (emphasis on BETA, as i’m also cleaning up docs and most scripts need updating prior to this being useful to anyone not writing scripts).

22 Likes

Any chance of you recalling how you fixed the issue? My norns is doing the exact same thing :sob:

EDIT ~ Resolved. Didn’t realize you had to use the mini-USB port for serial tty, bless the documentation :raised_hands: ran the terminal code @tehn mentioned and it worked like a charm

1 Like

Hi there. I just tried updating my Norns for the first time. I’ve just been using it stock and I’ve had a bunch of fun. I tried using the usb stick method as well as the wifi method and both have not worked.

First I tried the usb method with a fresh, fat 32 usb drive. I downloaded the .TGZ and put it on the drive. I input the drive into Norns, turned it on, went system>update and clicked the right encoder button. Nothing happens. There is no indication that it is working and after thirty minutes it just goes to sleep on it’s own. When I reboot it shows the update I was trying to install 042219, but everything just crashes and I get a ton of errors.

I then tried to use the wifi hotspot method and Cyberduck on a mac and PuTTY on a PC both will time out when trying to connect to my norns in hotspot mode.

I then read on the forums that maybe I have to unpack the .tgz, even though the instructions for updating do not say this. So I did that, retried the process with the usb, which is freshly formatted in FAT 32, and still not working.

Any help would be appreciated. I don’t consider myself a Luddite, but I’m certainly starting to feel like one.

it sounds like you jumped straight to 190422 instead of starting with 190405 for your v2 upgrade.

you can recover this way: Norns: update fail recovery

2 Likes

Oh hey Tehn, thanks for responding. Let me try that! cheers I hope this works.

I’ve got some troubles understanding the level_slew parameter. Shouldn’t it create fades in and outs when a clip is launched or stopped?

It affects the -60db convergence time for exponential smoothers on mix / routing level parameters. So, nothing to do with clip launching

1 Like

pulled in the latest changes from today, but not having success with the post_filter commands in a quick test. init() setup includes:

  local p = softcut.params()
  for i = 2,4 do
    params:add(p[i].rate)
    params:add(p[i].post_filter_fc)
    params:add(p[i].post_filter_lp)
    params:add(p[i].post_filter_dry)
    params:add(p[i].post_filter_br)
    params:add(p[i].post_filter_rq)
  end

changes to rate have audible effect on their playheads (I’m basically recording input to buffer 1, played back with playheads 2-4), but changes to post_filter commands don’t…am I totally missing obvious?

did you run

./waf

???

hardware restart did it. weiiiiiiird, but dang these filters are dope! thanks for rubber ducking that with me.

1 Like

remember

;restart

in maiden it’s golden

3 Likes