Norns: updates

norns

#21

Yes, it’s norns180603.tgz and not 180603.tgz, but thank you for confirming. And yes, both the .tgz and .md5 files are inside.

I’m guessing it’s something to do with the USB drive that I pulled from the depths of my desk. I’ll find another and report back.


#22

Flawless upgrade process. Working through new stuff tonight.


#23

worked great for me too.


#24

looks like i sorta bricked mine with the latest update.

it did find the file successfully, i proceeded to do the update, it said “wait” or something like that and then went back to the main screen after 2-3 seconds. i assumed the update was done and rebooted it using the reset button instead of going via “sleep” (should’ve read this thread first!). now when i turn it on no lights on the screen. the LED on the back is on (yellow).

i haven’t done any firmware mods yet, so it had the factory firmware before the update.


#25

It seems odd that the update went back to the main menu so quickly. Regardless I can imagine that if the device was reset right after the update ran (instead of sleep) it is possible not all the files got flushed to disk.

The most expedient solution may well be to see if @tehn can post the current release image (for the internal file system) and just reflash your device. If you are really in a pinch I can DM you a link to what I think the release image is but it might not be fully up to date.


#26

yeah i’ll bet that hard-reset left (part of) the update in RAM


#27

@ngwese @scanner_darkly
i just bricked mine as well after updating, doing exactly what scanner darkly did…
emailed tehn…
boo.


#28

when i reset it, i see the light goes white/yellow, but no action on the screen, just blank permanently, no matter what i do. wish i had read this entire thread before i had updated and seen @scanner_darkly’s post…

EDIT:
@ngwese how do i flash norns from image?


#29

@jonsimon @scanner_darkly no worries this should be easy to fix.

let’s first try to manually re-run the update. you’ll need to serial-connect. here’s how you do it with macos (let me know if you need other instructions):

  • open a terminal, with norns on and usb connected to computer
  • screen /dev/tty.usbTAB 115200 where TAB is push TAB. the final command will look like screen /dev/tty.usbserial-A324Y43 115200 or something
  • it should connect. hit enter, you’ll get a login prompt.
  • user: we password sleep
  • you’re logged in.
  • cd update
  • cd 180603
  • ./update.sh
  • sudo shutdown now

if any of these steps gives an error post here.

there’s a more full-reset solution but try this first. (also i’ll be out for a few hours but will be back later today— have to go on a factory visit)


#30

THAT WORKS yayayaYAY.
thanks buddy.
~js <3


#31

I’m not sure if it was like this before the update, but Key 1 seems too picky now. I have to give it a very quick poke to change views. Otherwise, it gets registered as a push+hold for the current application.


#32

thanks tehn! i’m on windows, quickly tried using PuTTy but no luck so far, will try again tonight or tomorrow. also to confirm - is it the usb connection on the back or do i need to open norns and use the other usb port?

in the update instructions might be worth changing “reboot” to “restart by making it sleep and turning it on again” or something like that. also, if this was caused by the update still being in progress, what is the best way to confirm it’s completed? it just went back to the main menu and was responsive, so looked like it was done.


#33

Seems like making this a system setting would be a good idea. It probably comes down to preference.


#34

version number shown next to UPDATE in system menu

use USB mini port (power) on norns connected to computer


#35

so if the version number shows the new one does that mean the update was fully completed? in my scenario since the menu was already active while it was still in progress, would i just go back to the main page and then back to UPDATE to check when it’s done?


#36

@tehn will have to verify, but as i recall version.txt (which is read for version #) is written nearly last in the update script, so you should be good. that said, you could also double-check by unzipping your update zip and looking at update.sh.

if you're curious, here's where norns calls out to update.sh...

https://github.com/monome/norns/blob/cc7ab2409f64f96a91a8ec8bb1b728c59a0076b5/lua/update.lua#L59


#37

if the version is correct, you’re good. version is only “read” at matron bootup.


#38

does it boot up matron at the end of update, or does it happen after a sleep cycle? because if it only does it after a sleep cycle the question is then, how do i know when i can sleep cycle it, since there is no indication it’s still doing the upgrade?

start upgrade -> it says “wait” -> it goes back to tthe main menu but is still upgrading -> how do i know it can now be restarted?

sorry, i think i’m missing something super obvious.


#39

i realize i don’t know what image you’re updating from, but looking at how update happens now, you shouldn’t need to manually sleep:

(this may not answer your question today but at least moving forward, you won’t need to wonder!)


#40

thank you, that clarifies it! basically assume the upgrade is still running until it goes to sleep.