Norns: updates

norns

#81

Trying to update norns, but i am also getting the “No updates found”. Reformatting the usb HD did not help. On the system page it does say disk free: 17M. Could that be the problem? How can I make more space on norns?


#82

If you do “download as” it won’t unpack it and it loads just fine


#83

I think the .tgz update file is ~40mb, so the available space left on your Norns might not be enough. I’d recommend backing up your tape recordings to your USB drive (“sync to USB”), and then connecting Norns to a WiFi network in order to delete audio files directly from Maiden.

The main Norns doc, with sections on sync/network, should be handy here.


#84

Thanks, Cyberduck saved the day!


#86

I just updated to the current 180707 version and am getting an AUDIO ENGINE error message. I haven’t played with any of the code yet. Does anyone have suggestions?

EDIT : oopsies…looks like this issue is discussed in the Norns help thread


#87

Question about updates and development: if we’re already regularly doing git pulls on norns, norns-image, dust, and maiden (and building matron and maiden), is it a good idea to apply an update just by pulling/building and then running any fixup commands in the update’s update.sh (like copying the service files and re-running norns/sc/install.sh)?

Or would it be safer if we pushed any work to forks and ran the standard update process that erases and re-copies norns, norns-image, and maiden?


#88

yes, you’ve got the right idea re: pulling and running fixup scripts.

no need to run the “standard” updates if you’re doing this. though we will likely do a kernel update soon and sill need to figure out how we deliver this.


#89

Updated the unit after getting it back from you Brian. Getting the same issue described above - “NONE (error: AUDIO ENGINE)” .
Reboot, hard-reboot,
Tried syncing from USB without success it just stops the sync straight after I selected it.


#90

some folks have reported this, due to duplication of Crone. do these steps help?


#91

when I follow these steps in either matron or sc tab I get
“lua: attempt to call a string value
stack traceback” on every command by Matron while in the sc tab I get the message “library has not been compiled successfully” if I enter the steps described there instead.

Not sure what any of it is supposed to do as I haven’t gotten in to the norns studies yet.

I also haven’t had any luck grabbing a previous release.

update: absolutely nothing happens when I try to run the script(s) in the upper letterbox.


#92

To clarify - you won’t be able to fix this from Maiden (i.e. matron/sc in the web browser).

You would need to SSH to the norns from a terminal. See here under “other access”.

Alternately you could use an SFTP program like Cyberduck to access the norns file directory and delete the Crone Engine file at /home/we/.local/share/SuperCollider/Extensions/dust/sc//CroneGenEngine.sc then reboot the norns.


#93

Okay so I followed the steps, but this time in the terminal window on a mac. I deleted the duplicates, restarted the unit. Unfortunately this didn’t fix it - instead now I get this message:

we@norns:~/norns$ ./stop.sh
scsynth: no process found
we@norns:~/norns$ ./crone.sh
attempting to bind socket at url ws://*:5556
compiling class library...
        Found 594 primitives.
        Compiling directory '/usr/share/SuperCollider/SCClassLibrary'
        Compiling directory '/usr/share/SuperCollider/Extensions'
        Compiling directory '/home/we/.local/share/SuperCollider/Extensions'
ERROR: Superclass 'CroneGenEngine' of class 'Engine_Gong' is not defined in any file.
/home/we/.local/share/SuperCollider/Extensions/dust/sc/Engine_Gong.sc
ERROR: Superclass 'CroneGenEngine' of class 'Engine_Shift' is not defined in any file.
/home/we/.local/share/SuperCollider/Extensions/dust/sc/Engine_Shift.sc
ERROR: Superclass 'CroneGenEngine' of class 'Engine_Bob' is not defined in any file.
/home/we/.local/share/SuperCollider/Extensions/dust/sc/Engine_Bob.sc
ERROR: Class extension for nonexistent class 'HistoryGui'
     In file:'deprecated/3.9/HistoryGui.sc'
ERROR: There is a discrepancy.
numClassDeps 1417   gNumClasses 2828

#94

Try ”cd ~/norns/sc” and ”./install.sh”.


#95

Tried this and when I reboot the unit I get
[ OK ] Stopped Dispatch Password Requests to Console Directory Watch.
Stopping Restore / save the current clock…
[ OK ] Closed Syslog Socket.
[ OK ] Stopped Load/Save Random Seed.
[ OK ] Stopped Restore / save the current clock.
[ OK ] Stopped Update UTMP about System Boot/Shutdown.
[ OK ] Stopped Raise network interfaces.
[ OK ] Stopped Network Time Synchronization.
[ OK ] Stopped Create Volatile Files and Directories.
[ OK ] Stopped Apply Kernel Variables.
[ OK ] Stopped Load Kernel Modules.
[ OK ] Stopped target Local File Systems.
Unmounting /run/user/1000…
Unmounting /boot…
[ OK ] Unmounted /boot.
[ OK ] Stopped File System Check on /dev/disk/by-partuuid/51739c87-01.
[ OK ] Removed slice system-systemd\x2dfsck.slice.
[ OK ] Unmounted /run/user/1000.
[ OK ] Reached target Unmount All Filesystems.
[ OK ] Stopped target Local File Systems (Pre).
[ OK ] Stopped Create Static Device Nodes in /dev.
[ OK ] Stopped Remount Root and Kernel File Systems.
[ OK ] Reached target Shutdown.

But nothing seem to have happened. Still “error: audio engine”


#96

@Joakim If possible, create a issue on this in the ”monome/norns” github repo and report the output of ”crone.sh” after running ”stop.sh”.


#97

20 characters of done


#98

I’ve been noticing some extraordinary new script demonstrations of late - will the team continue to include new “Staff Approved” scripts with the updates? Or do I need to become proficient in rummaging around GitHub to pick them up?

I guess this goes to the larger question of how scripts are judged to be “ready for distribution”. Thanks for your guidance.


#99

I’ve been wondering about this as well. Has there been talk of a sort of “package” management strategy at all?

I’ve created a number of simple scripts, and while I’m not convinced they would be worth making part of an official release, they might have value for others outside of my specific use-cases.


#100

my understanding is that if it’s in dust it will be in updates.

a bit over here…

ideas welcome!


#101

Thanks! I had missed this in the flurry of norns threads :sweat_smile: I’ll take a read to see where we’ve landed.