Norns: updates

norns

#163

I have not experienced any of these issues but getSynchronous use in CroneAudioContext may be the root cause:

(error is thrown in the CroneAudioContext:buildVuBlob method)

This should work with get too - right?

I’m not sure this is related to @carltesta’s script.


#164

On second thought, the CroneAudioContext:buildVuBlob error may actually be a secondary issue caused by something else crashing the server. Hmm… :thinking: Perhaps it’s Buffer:zero() as @zebra says. Can check this later at device.


#165

OSX 10.13.6
How do I get a command prompt for ssh? - sorry this is a little above my head.
Ive tried the manual update method terminal returns no found directory or file. This is the same with all USB sticks I try.

I think I need to go back and read through all the docs on Norns. Maybe I do that first rather than take up more of your time.


#166

on the mac, run Terminal.app to get a command prompt. let me know if any of the commands fail. try despite the menu system saying not found for the USB disks.


#167

the screen IS wonky…

seriously though, whats happening exactly?


#168

what do you mean by wonky? i just ran the script for the first time, so i’m not sure how things may have changed?


#169

A full screen of changeable parameters is shown but I can only change two - I will revisit tonight and send detailed notes. Sadly my tape is mostly empty and it didn’t have fun playing a readme file - I’m sorry for the bad feedback. The edit parameters screen seems skewed, as if an error occurred.


#170

oh - to be clear that’s not really an edit screen. you’d still want parameters for that. the “tv guide” is more to show what the current settings are without going back to parameters. volume/speed/pitch can be edited while in the app with the latter two displaying in the guide, so that’s probably throwing you off.


#171

Exactly that - thank you for explaining it.

I’m encounter so many odd breakdowns and burps in Norns that I never know what is intended and what’s designed. I will make a few more tapes to give it something fun to chew on.

FYI - I also noticed the number on the upper right increments but I can’t “go back” - that’s also by design?


#172

yep, that’s by design. I also kept the editable items at a minimum - for a less random experience I’d recommend easygrain.

as far as the app playing the readme, I’ve noticed that anytime a non-working file (I encounter empty files that aren’t listed in maiden) comes up, it stays on the previous recording from tape. I could probably add a check to clean that up but I haven’t noticed it hurting anything.


#173

I’ve some Problems after the installation of the latest 180828 Update

The Update itself runs without a problem, but after the reboot the very first line shows
NONE (error: NO SCRIPT)

Furthermore, if I try to load a script (e.g. MLR) the first line shows:
NONE (error: load fail)

None of the Scripts is working anymore @tehn any ideas?

Edit: Even the sleep mode is not workin anymore. Norns stays at the “sleep” screen

UPDATE: the situation is getting worse. After trying the manual update method which was posted by @tehn, my norns does not show anything in the display. After the boot (I assume, the LED switches a couple of times from orange to white and back) the LED stays at orange. No Display, and no connection via
screen /dev/tty.usbserial…
:fearful:

UPDATE 2:
norns is alive :slight_smile:
I don’t know what the bottom line was. But after connection norns via serial connection and manual down-/ and upgrading the Software, it works again.


split this topic #174

A post was merged into an existing topic: Norns: help


#175

i’m sorry for the trouble and glad it’s working!

we’re working on overhauling the upgrade process to make it more robust. thank you all for your patience.


#176

Got round to trying again today, unfortunately with similar results. Again, probably me. I did the following:

This following is with hotspot connected and norns connected via USB to the Laptop.

Ive ran terminal, login is fine then once I copy:

cd norns; ./stop.sh; cd ~
sudo cp /media/usb0/norns180828.tgz ~/update/
cd update; tar xzvf norns180828.tgz; tar xzvf 180828.tgz
cd 180828; ./update.sh

I get:

we@norns:~$ sudo cp /media/usb0/norns180828.tgz ~/update/
cp: cannot stat '/media/usb0/norns180828.tgz': No such file or directory
we@norns:~$ cd update; tar xzvf norns180828.tgz; tar xzvf 180828.tgz
tar (child): norns180828.tgz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
tar (child): 180828.tgz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
we@norns:~/update$ cd 180828; ./update.sh

I attempted to check the error message in Matron but cannot retrieve it as Norns crashes soon as update is attempted and therefore disconnects from Matron.

In the meantime I have also attempted to do:

mkdir /home/we/update

And get:

mkdir: cannot create directory ‘/home/we/update’: File exists

However in Maiden there is no Home/we/update - at least not that I can see

Incidentally, on two of my computers the updater file won’t download at all. Just hangs midway through. Probs not related, maybe worth mentioning.

Additionally when I connect via wifi or hotspot Norns now crashes every time at some point after that seems random.

I keep running the update from Norns (just in case in works) and get the following from Matron:

ls: cannot access '/home/we/update/norns*.tgz'
: No such file or directory

Other weirdness that occurs is that on startup the hotspot says connected but isn’t. I need to connect via wifi to then reconnect the hotspot. During this time Norns is not visible as a hotspot.

Any ideas? …
p.s. Sorry for the essay


#177

just to say, i also had a difficult time downloading the update on my computer… had to try maybe 10 or 11 times before it actually got all the way done and didn’t hang…


#178

i’m not exactly sure of all the steps you’re taking here, but the commands you ran are for running the update from an attached USB drive.

So in this case, was a USB drive with the update file plugged into norns?

FWIW - Maiden will not show the update directory. This will only be visible from the Terminal (try typing ls -la /home/we/ to get a directory listing in Terminal). This apparently already exists, so should not be a worry.

(If you’re familiar with using FTP) Another approach would be to copy the file to the norns update directory via sFTP with an application like Cyberduck.


#179

Yeah thanks,
All was conducted with Local network and Norns connected also via cable to Laptop and USB drive inserted.

Ill try FTP. see if that works.


#180

@tehn
thanks for your help, worked!


#181

180904

get it here: https://github.com/monome/norns/releases/latest

norns 1.0.3

  • FIX midi/grid management system behavior
  • FIX tape playback (@jah)

image

  • FIX USB limited to USB1.1 to prevent kernel bug which caused grids/midi to misbehave

dust


see update instructions

fyi: known bugs


we’re debugging some USB disconnect issues with grids. there may be some instabilities with hotswapping until we get it fixed, but this fix corrects grid freakouts with midi connected.

also there’s a new menu item SYSTEM > DEVICES which lets you select devices for port assignment. by default scripts use port 1 for both grid and midi.

thanks for @jah for fixing the tape, which broke with a supercollider update


#182

I’m still failing to update via USB key. Is it possible to update Norns by sftp?

many thanks in advance for help with this

also thanks to @jlmitch5 for the sftp guide, so helpful