Norns wifi difficulties

there may be some info on this buried in the massive norns thread… but… i have an enormous amount of difficulty connecting norns to my wifi network and then to maiden.

every time i want to go to maiden i have to create and add my wifi network all over again… as a result i have like a dozen versions of my network saved in norns.

it usually takes me 10+ minutes of fiddling… adding, deleting, connecting, etc to get Maiden finally loaded as my norns STATUS usually just says "activating."this morning i’ve been trying for a while but can’t get it to connect at all… so giving up. it’s quite frustrating.

is there any trick to getting norns/wifi/maiden to be easy? anything i’m doing wrong? tips/tricks?

thanks…

hey taylor! hope all’s well :slight_smile:

wifi issues are supremely frustrating, sorry to hear about the troubles!

typically, I’ve seen initial connectivity symptoms related to a few different potential causes:

  • your network might be out of range of the nub’s reach – the stock nub is not very powerful. in these cases, we recommend a high gain antenna replacement.
    • when you are able to connect, what db reading do you have on the norns WIFI menu? in my experience, anything -60db or lower typically won’t perform well at all. sometimes, the stock nub has dropped for me when only 50 feet away from a router :confused:
  • the nub itself might generally be functioning poorly – if you plug it into a computer, does it work as expected? are you able to use it connect another computer to the same wifi network alright?
  • i’d recommend deleting all of the redundant networks and starting fresh. it might be best to directly connect to the Pi’s graphical network config menu. you have a stock norns, so you can connect it to another computer via the charge cable by following these steps.

if none of that works, we’d love to do some direct data collection about your particular setup – router make, network configuration, etc. wifi issues have been really really hard to diagnose, as they can be a mix of environmental, non-norns hardware, and norns system issues. please reach out to help@monome.org with further details.

edit: also, @ngwese has been digging into this a bit lately, as well, and might have further insight.

let us know how it goes!

1 Like

@taylor12k - some additional information which would help is to know:

  • Is this a shield w/ the built-in Raspberry Pi 3B/3B+ wifi (or norns with stock wifi nub)?
  • Is the wifi nub connected when norns is powered on or plugged in later?
  • What other USB devices do you typically have plugged in when powering on (if any)?
  • Does the wifi network you are trying to connect to have a name which contains characters other than letters or numbers?
  • What is the make/model of you wifi access point (base station)?
  • If you have multiple wifi access points are they setup as a mesh?
  • How far away are you when you try to connect to the network?
  • Do your wifi access points have 2.4GHz radios enabled?
  • Is you wifi access point set to use “WPA2 Personal” authentication?

The high gain wifi antenna which @dan_derks mentioned is actively used by several folks. Alternatively if you really want that small size wifi nub the most reliable option I’ve found is this pricey one from think penguin - when using wifi this is the interface I generally use.

Alternatively if you are close to a wired ethernet switch then this is a solid option for OG norns hardware USB 3.0 Gigabit Ethernet Adapter - 95% of the time I’m hardwired.

4 Likes

I can also vouch for that ethernet adapter option, works flawlessly and I can just share my wifi connection from my laptop. don’t think i’m ever going back to using the wifi nub.

1 Like

Hey Taylor, can confirm this solved my exact problem you’re describing: https://www.amazon.com/Panda-Wireless-PAU06-300Mbps-Adapter/dp/B00JDVRCI

thanks for all the tips everyone!

i think i’ll try dan’s software fixes first… then look into ethernet options… tho my laptop doesn’t have ethernet and the studio computer’s ethernet is taken up by another device.

i suppose the Panda antenna is a good option as well… tho i like the current dongle because it’s so tiny i can just keep it in all the time and not ruin the monomer design vibe too much! :slight_smile:

but i’ll try all this stuff and see where it gets me, and report back…

thanks again!

I can vouch for having the same problem. Personally I have not found a solution yet, despite having purchased new WiFi dongles. The best solution I have found was to connect to Norns via the usb and then use terminal to install and update scripts. @dan_derks responded to one of my earlier posts about similar issues with detailed description about how to do this. I’d link to it myself except that I’m on my mobile device so not too easy for me to do that. Maybe there can be an update on the Norns page about how to install and update scripts via terminal for those of us who keep on having issues with maiden and WiFi?

hi dan

i forgot what it was… but i think it was like -36db? maybe it was -46?

and i was about 10 feet or less from a router… well, at least a router EXTENDER (eero mesh network)

It is good to know that this is a wifi mesh network. I don’t have a mesh network to test against and my limited exposure to them helping friends and family hasn’t been particularly positive. The chipset/driver for the stock wifi nub has not proven to be that robust - I can imagine moving between different APs broadcasting the same SSID could be problematic. I’ll do some research.

At the risk of getting slightly off topic… Just to ensure there is no confusion maiden only installs scripts downloaded over a network connection.

Successfully installing scripts using the maiden cli tool (even when using the USB serial connection) means that norns has successfully connected to WiFi. If maiden can’t be reached via a browser after a successful install that makes me think the problem is the likely something quirky with the browser or computer the browser is running on.

There is theoretically a chance for shield owners that multiple network interfaces will have been created which could mean the reported IP address on the display is wrong. I’ve been trying to find a situation where this would happen in practice but no luck so far.

1 Like

got the panda antenna today and it works like a charm. i had to find and connect to my network once again but upon rebooting a couple hours later it found the network and connected to Maiden without a problem.

the only downside is the antenna triples the size of the norns now :slight_smile: but i’ll just plug it in when i need it which won’t be too often.

also, as an FYI, i took the norns with the default wifi dongle and sat next to my router and the dB level read -68 … which doesn’t sound too great.

4 Likes

I’m curious. What specifications should I look for when buying a USB WiFi dongle? Will any work or does it have to be compatible with Norns in some way? I know the linked Panda will work but I might want to hunt down something cheaper if possible. Thx.

Edit, decided not to be cheap and ordered the Panda device linked above.

woop, didn’t see this the other day, apologies! in short, if the dongle is advertised as working with Linux, it should work with norns. but yeah, the Panda one is the best bet if you’re looking for a reliable replacement for the stock one.

1 Like

I had lots of frustration trying to use the little wifi nub. I got the Panda antenna and have not had any problems since. It has been rock-solid.

1 Like

Ditto on the Panda antenna. I was having major issues recently, got the Panda antenna, and haven’t had a problem since.

And I actually quite like the bulky aesthetic.

can you expand on how this works ? do you just use two USB/ethernet adapters + ethernet cable ?

Do you use a Mac? I was using the Internet Sharing option built into MacOS. I use an ethernet usb adaptor plugged into norns and an ethernet cable. The adapter is the one first posted here. I use a mid-2012 Macbook Pro which still has an ethernet port but i’ve also used my work computer with an Anker usb hub which has an ethernet port. Once this has been setup, it should pop up on the wifi connections in Norns as “Wired Connection”. I, however, don’t use this anymore as I mucked around with the network settings and, well, I shouldn’t have as I know nothing about networks. Now i sit close enough to my wifi router so i just plug norns into an ethernet port on that.

nice ! I am on a mac - I wonder if this method would work wirelessly as well (I’ve used internet sharing before, but not with norns). studio is semi-far from my router so the laptop connects fine but norns has plenty of trouble.

It might! i never tried though. Using ethernet has been so much more reliable for me than wifi that i don’t mind the additional cable dangling off my desk

Just getting my Norns set up for the first time and I’m dealing with some WiFi connection issues. I’m also on a Pi4.

First off, my network shows 5 times on the list. When I select one of them and enter my password, my screen returns to this:

Status: activating
Network:
IP:
Signal: dBm

It stays on this screen with no changes.

I have removed and re-added multiple times but still no luck. I’ve also moved the Norns closer to the router with no luck.

Any ideas on what I could try next?

try this help | monome/docs

2 Likes