Norns wifi issue

Shortly after I received my norns last week I connected it to my wifi without issue (even connected to maiden from my LT). Today however wifi shows as “unavailable”. Needless to say that wifi is available. I’ve reset norns, tried the dongle on different USB ports, and tested it successfully on my LT but on norns,no luck.

Any suggestions?

hey hey! sorry to hear about the trouble. could you share results from step 4 and onward?: https://monome.org/docs/norns/help/#wifi-troubleshooting

Hey Dan. Thanks for replying so quickly and for your assistance! (Really enjoying cheat_codes BTW.)

I’ve connected the mini USB to my Windows PC and have connected to it using UART Terminal (baud 115200, bits 8, parity none, stop bits 1, flow control none) however entering nmtui does not bring up the graphical interface. Any suggestions?

1 Like

thanks so much for the kindness! :slight_smile:

ah, windows gets out of my depth – are you using PuTty and a COM port? I should also add those to the docs, apologies!

I can use putty. Let me try that. brb

Ok. I’m using putty. (Let me know if you’d like me to send you the how-to-connect steps). Using nmtui I see the wifi connection that I set up a few days ago and all of the settings look good.

Not sure what to do next. Perhaps I should delete the connection and re-add it?

1 Like

please!

give it a go, yes – a restart afterwards might help as well.

Well no love. I deleted the connection that I had set up, reset norns, added it back again through the terminal session however the norns screen still shows wifi status as “unavailable” and trying to Add the connection from norns shows “none”.

What is also strange is that when I try to Activate the connection from the terminal session, the connection I’ve just created does not show up in the list (even though if I go Back and Edit a connection I see the one I’ve just added. (see attached image)

image

Ok. I solved my problem. After all of this troubleshooting I noticed that neither my grid, nor my my arcs were lit up in cheat_codes. I reset. No love. I reasoned that something had gone wrong with the entire USB bus and this would have caused my wifi issue. Pressed the reset button on the bottom, powered on and presto. Wifi, grid, arcs all working again.

2 Likes

oh! wild, sorry to hear about the trouble but glad it was addressable – did the K3-K2-K1combo not register?

:grimacing: I tried K1-3 but I must have pressed them in the wrong order. (I know I wasn’t supposed to use the reset button but I thought this just might be one of those moments when it was called for.)

2 Likes

This has happened to me once before too, and the bottom white button also fixed it for me :+1:

2 Likes

K1+K2+K3 combo is a soft reset of the application stack.

so is the reset command.

SLEEP is a hard (but safe) shutdown. this is what you want to try next.

(i’d actually recommend using SLEEP at the end of any norns session.)

white button is like performing SLEEP, but unsafely, may damage filesystem, and should only be used if both the menu and K1+K2+K3 are unresponsive.

4 Likes

Interesting. The issue repeated itself again today. Wifi, grid, and arc not working. This time I tried @zebra 's approach of sleeping the unit and no go. For kicks I also tried the K combo but that didn’t help. I also tried the reset button while the unit was asleep without luck. Finally I pressed the reset with the power on and everything came back.

To provide some background for anyone looking to debug this, I keep my unit in sleep mode when not in use. I leave the arc, grid and wifi connected and I leave norns connected to power using the supplied PSU and USB cable. I also have INs and OUTs connected.