norns wifi troubleshooting

I might have busted sth, its a pretty full case yes (see shield case thread)

Thanks for the advices. I wonder if Norns USB to MAC while the Mac uses (USB!)-Hotspot(from IOS) will work. Illtry asap

One more observation i forgot to mention. The OFF switch is not clickable, prior to the error it reacted to on/off iirc

Nope did not work via usb.

So ethernet to usb i suppose

Reheating the solder points on the shield didnt fix it either. Probably pi wifi gone bad.
For the ethernet method do i need anything special or will it just appear as wifi on norns and act the same?

I have a Norns wifi issue now. I just moved and set up a new network with my old apple AirPort Extreme. Norns sees the network in the add screen but when I enter the password it jumps to the ip screen and says unavailable and the network doesn’t appear in the list of saved networks. I brought Norns to work and it connects fine and is updated.

So it seems there’s an issue with the vintage AirPort Extreme?

Mh t‘is getting frustating. No sucsess with an ethernet cable between the pi/norns shield and a mac.
Cant update, cant acsess files or maiden.

For some reason its hard to imagine why the pi wifi should stop working out of nothing.

Funny thing is, the mac network shows ethernet as connected. Turns off when norns is turned off but norns cant update and i cant reach norns.local

Couple of questions:

  • Do you have a norns or a shield?
  • If a shield are you using a Raspberry PI 3B or 3b+?
  • How far are you from the AirPort Extreme when you are trying to connect?

I may have just found an old AirPort Express that I can test with (likely next week)

  • What type of Mac are you using (desktop, laptop, what year)?
  • When connecting directly to you Mac have you enabled “Internet Sharing” as discussed in this post?
    Norns: help
1 Like

It’s a stock monome Norns. It has no issues with any other wifi networks except the old apple router so far.

Distance from router is very close. 3 feet about.

1 Like

Was a old 2009 macbook. Sold that one by now and only have windows 10 for the moment.
Doesnt make things easier. Managed to have my internet set as shared with „ethernet 2“ wich is the pi/norns. But theres no access, no maiden, norns has no IP etc.

Is there anyway to update via sd card without loosing files and scripts? I wish there was a simple oldschool method for situations like this. A usb connection with full access would make a lot of sense imho.

There’s an unpopulated UART header - that’s about as old school as you can get. See https://monome.org/docs/norns/maiden/#other-access for more info

1 Like

Win seems out of luck if i get it right.

just put the sd card in another computer, mount the drive, and put the new update file (download it from github) /home/we/update and then follow the manual-update-instructions in the docs.

i wouldn’t recommend the UART access mentioned above— it’s complicated

1 Like

Cool but what about my sample folders that i importet so fluid with mac finder?

And how to update scripts/use maiden?

i thought you were just trying to update your os, apologies.

i hesitate to say this, but you’re dealing with a lot of pi and networking problems that are not specific to the norns as far as i can tell. have you spend some time googling to see if there is any further info regarding pi + old routers or sharing internet with win10?

Yup tried. I understand your point. If there is a way to re-send my sample folders + scripts with your method anew, i am all in but i dont see it.

Another update. I found an Apple Time Capsule today (2009 version) second hand. Set up the the home wifi network with it and Norns will not connect to it. It just will not add the network. If anyone here is using an apple router and it’s working with Norns maybe I could go over some settings with you? Thanks.

Do you have any control over whether the Time Capsule is using the 2.4Ghz band versus the 5Ghz band? If so try enabling the 2.4Ghz band only.

I hope to be able to do some testing in about 2-3 days.

I tried the manual access method via terminal on a Mac but the TAB key does nothing so I can’t complete the command.

is there a way to keep or re-add the files/samples when doing a fresh SD etching?

If you have an existing SD card and are looking to get your existing files off before re-flashing the SD card you may find one of the utilities to read ext3 / ext4 filesystems from a macOS or Windows 10 machine useful. My recollection is that the RaspberryPi and norns os image consists of two separate partitions. The first is an fat32 formatted filesystem; which the device boots from, is directly readable under Windows and macOS but that isn’t where the sample files are. The second (main) partition that is either ext3 or ext4 formatted and cannot be read from Windows or macOS without installing additional software. This larger second partition is where all the files that you are after live - specifically below the /home/we/dust/ folder.

caveat: I have not tried any of these tools myself
Windows 10 - there appear to be a number of tools for reading ext file outlined in this article.
macOS - using a something like ext4fuse mentioned on the “Add Ext4 Support to macOS” section.

Once you have the files you are concerned about copied off of the SD card then you can re-flash it using etcher as referenced in the shield setting-up documentation.

From there it would probably be a good idea to:

  • work through the WIFI / networking problems with the new clean image
  • go through the normal WIFI / network based update process to pull down the latest norns software and reboot
  • then copy the files pulled off the old image back onto the norns shield using either smb or ftp as outlined in the manage section of the norns documentation.
1 Like

Thanks, i will have to go through this as i tried another pi (3b) and the same issue was consistent, no ethernet either. So pretty sure somehow my firmware got bugged up for some reason.

If for some crazy unluckyness the new image will still have no wifi, will i be able to place the files back in same way as copied for backup?

new WiFi issue happening since updating to: 200712

booted up norns with “none” at startup.

no WiFi

looked a little further and realized no devices either…in fact…no USB whatsoever.
:open_mouth:
tried RESTART a couple of times and then a SLEEP and everything finally came back to life.

any clue at what’s happening?

also…i realized at one point that i had forgotten to turn on the Powerstrip and norns was running on it’s battery for a few mins.

this is occurring on all three norns.

thanks for any help!
:space_invader:

this sounds like a USB hub shutdown as a result of not enough current— i suspect you may have a bunch of USB devices plugged in? this could happen if the norns is powered up without a wall connector.

also heads up, if you’re not actively using the wifi, i’d take the nub out. saves power, keeps the system more stable.

1 Like