Offworld-1: USB power utility


#1

you can now order them, assembled and enclosed, direct from https://market.monome.org/products/offworld-1

this little dongle allows you to power a device (ie grid) from an external source (ie iphone charger) while passing the data lines to a host (ie module)

it’s also 100% open source: https://github.com/monome/offworld-1

if someone wants to build and sell these themselves, please do!


104 hp inspiration
Ansible + Grid: Not working correctly (solved)
Eurorack cases/racks. Ask questions, share experiences
#2

Just put together a little 3D printed case for the Offworld-1. It is intentionally a tight fit, but it worked for all three of my OSH Park builds (100% BOM Parts).

Find all of the the open-source files up on GitHub (STL and OpenSCAD):


Offworld-2: USB power utility
#3

Just a little something I noticed: When I plug the offworld-1 and a Korg SQ1 into the same USB hub (not connected to a computer or any other devices, just power), the grid causes the SQ1’s clock to skip beats and stutter.

This is no big deal and I’m not sure if something like the offworld is even meant to be powered via a hub. Just wanted to mention it if someone is planning to use this combination.


#4

i feel like a case like this 3d printed one should come standard. my offworld-1 (with the plexi shield) got very easily crushed in my backpack (although i was an idiot for sticking it in my backpack like that).

on that note… where can i source replacement usb plugs to resolder, since these ones are now toast?


#5

i really want to come up with a 1u pulp logic style tile that i can keep in my rack. one less moving piece to lose/break.


#6

It is open source, which I think is a pretty good deal.

I’m going to have a look for appropriate USB sockets to attempt something similar. As I see it just now the depth of the panel itself is the stumbling block. The micro USB sockets are tiny.

One solution i was looking at was trying to source male to female right angle sockets.

What seems (possibly) simpler is to mount offworld1 at 90 degrees with the micro sockets on the panel then wire the usb socket to a new female socket mounted next to the micros.

If anyone sees any probs please chime in :smile:

POST LUNCH EDIT:
https://uk.rs-online.com/web/p/products/7378782/ looks suitable for the “A” side.

However, the mini side requires https://uk.rs-online.com/web/p/mini-usb-connectors/6741350/ due to pin placement.

The vertically oriented micro B sockets don’t look like they would be sturdy enough if one was to soler them straight to the board without the shoulder tabs.
https://uk.rs-online.com/web/p/mini-usb-connectors/1512720/


#7

old thread i know, but in that situation i would make sure the power supply can deliver enough current. budget like 600ma for the grid.

this thread seems like a fine place for a reminder: undersupplying digital devices is more harmful than one might realize. for example, flash memory corruption can and will happen. bear in mind when splitting the power chain with passive hubs.


#8

all the info is online


#9

doh… sorry i missed that.


#10

Thanks. I actually used a powered hub. It might still have too little power. Not completely sure about that, although it should deliver 2200ma.


#11

I have ordered offworld1 boards from OSHPARK. free shipping to EU! and 3 boards (minimum order) for $5.95.

If I don’t fry any I’d be happy to send spare onto anyone intersted. Let me know (UK preferred as postage would be minimal).


#12

Wow, I’m in Sweden but would be very interested in this particular offer. If I’m getting it right this replicates what the ext5v did when I had a White Whale? Which I sold along with the ext5v as I got Ansible? Before Teletype would be able to connect directly to a grid, but needs an ext5v or offworld as Teletype wasn’t designed to provide power like that? :crazy_face:

edit: been lost since 2015
http://archive.monome.org/community/discussion/18219/danger-monome-modules-can-blow-up-your-eurorack-power-supply/p2.html


#13

@steveoath I’m also in Sweden and would be interested in taking a board off your hands, too. Maybe you could send both of them to one of us, and we can sort something out from here. Provided that works for everyone?

@accountboy - Jag är Sthlm, var nånstans är du?


#14

@scrag - Stockholm också!


#15

Wow, I didn’t realise these are so sought after!!!

I plan on building my own when the boards come. And can send on any spares with the usb sockets (unassembled) as I imagine that I’ll be ordering in bulk anyway.

I have a few people who have shown interest, so I will get back to them when the boards come.

I would suggest, if you are looking to order some I found oshpark really good. Worked out as about £4 posted to the UK. So it may be more economical to go through them as I suspect posting a single board from UK would be >£2.


#16

I put one of these together this evening. There were no shorts or obvious errors with my build…it’s a very simple build. However, when I plugged my Grid into it, and then into my Ansible, it was not recognized. After this, I plugged it directly into my Ansible, which was previously working, with no response. I also plugged it through a Switch to my Teletype. Again, this was previously working but now I get no response.

It is also not recognized by my laptop, though to be fair I had not tried that prior, so it’s not a good test.

In all cases, I get the 4 4 3 2 led flash in the upper left upon powering, but no activity after that.

is it possible I could have caused damage from using Offworld-1?


#17

@xenus_dad

i can’t imagine how any damage could have occurred. did you try a different USB cable? if still not working, e-mail info@monome.org and we’ll set up a repair


#18

Shameful… With a different cable it works fine. I blame the later evening and a bit of whiskey.

Apologies for the noise, and thanks for the response!


#19

I’ve soldered one of these together in a pretty rushed/average manner and had a relatively large break between when I soldered it and when I was able to test. Tried with multiple cables and power sources with no success. Does anyone have any tips for getting in there with a multimeter to check whether the problem is with my soldering or not?


#20

i’d suggest just fully reheating every solder joint. there aren’t very many of them.

also swap out your USB cables, that might be the problem