oooooo

Hey people, I have a simple question,
Is there a way to copy a buffer to a different track, to treat the same sample in different ways? Thx

3 Likes

this is not possible right now. It would be great if you or someone wants to add that. it should be really easy to add - you can use this softcut function to copy one loop to another loop. the buffer numbers and start/end points are listed here. I’m not exactly sure how it would happen, there are two scenarios I can envision - would it copy one loop into another loop but keep the resulting loop the same size and everything? or would it copy a loop exactly so that all the parameters of the pasted loop have the parameters of the copied loop? (the former is much easier, the latter needs some extra code). whoever wants to add this can choose their version, I would accept any PR :slight_smile:

6 Likes

I’m recently experiencing a ‘load fail’ error with OOOOOO, which according to matron is due to a lack of Sequins. As a part-time user and after having scanned the commity and help pages, I have no idea how to find and install Sequins.
OOOOOO used to work fine, so did the Sequins requirement get added in a recent update?
I should also add that I have updated the system and restarted, all to no avail.

yes - you can either downgrade oooooo (download and unzip this: Release v1.9.1 · schollz/oooooo · GitHub) or upgrade your norns system (norns: update 220321).

1 Like

cool, thanks. so let me clarify (and i should probably have done this in some kind of noobs thread, maybe) - installing an update from the device menu is not the same as upgrading the system with a release such as you linked to. correct?

1 Like

the linked update 220321 is a normal system update that can be applied from the system menu. but it follows and depends on 220306 which is a total system upgrade and requires re-flashing the filesystem. this is annoying but happens only when we need to change or upgrade major system components (once every 2-3 years so far.) when a release requires this, it is labelled as a new image.

TL/DR: you must re-flash your norns/pi with the 220306 image before applying the 220321 update.

7 Likes

update: i figured it out by messing with the rate adjust % in the parameters > edit menu for each loop. still not sure how it changed in the first place. i do notice that the value changes in strange decimal intervals when turning the knobs on my shield however. how can i manually enter these values in maiden?

hello! i used oooooo all day yesterday and was able to adjust rate by single digits however today while using it i can only change in half values from 100 (400%, 200%, 100%, 50%, 25%). wondering how i can go back to fine tuning the rate parameter. tried resetting norns and restarting script. might be a simple fix but i can’t figure it out. thanks!

@infinitedigits

While there is currently the warble option in oooooo I’d love to control the saturation, wow & flutter etc within oooooo.

Would it be possible to combine tapedeck and oooooo into one script?

1 Like

yes totally possible. I’ll have a go at it. actually writing a new script now and I already integrated tapedeck into it too so I know how it’ll go.

9 Likes

just wanna bump…did you get any help on this?

I don’t know if I’m more excited that it’s possible, or the new script from you. Thank You!

2 Likes

Planning on buying another Norns soon mostly just because i miss this script. Sometimes u never know what u got til it’s gone :smiling_face_with_tear:

one thing I was curious about is it possible to use like a faderbox to control volume on individual loops.

I saw that with grid there’s some form of volume control but would be possible with a fader based midi controller?

1 Like

checking now and yes, you can map a MID controller to track volumes (and almost everything!)
:star_struck:

4 Likes

Seems the filter on OOOOOO doesn’t work no more, probably after the latest update.
It’s maybe linked to the noise issue which some people experienced after the latest image update, I thought that maybe the filter it’s been bypassed until the fix, but the fix it’s been released on March :sweat_smile:, so I’m probably 100% wrong.

Any advice?

probably 100% right. This commit was made to bypass the lp filters and there hasn’t been a commit to undo this.

It’s an easy fix, which simply requires changing two numbers:

softcut.post_filter_dry(i, 1.0)
softcut.post_filter_lp(i, 0.0)

to

softcut.post_filter_dry(i, 0.0)
softcut.post_filter_lp(i, 1.0)
2 Likes

Oh thx a lot for this! I missed it for some reason…

3 Likes

yep! I removed the filter when a previous version of the norns os had a little glitch. that’s been fixed for awhile but I wanted to give time for folks to update. its been time enough so I just reverted it so the lpf should work fine again.

10 Likes

So you know how when you start recording, then press K3 again to stop recording and automatically size your loop to that length?

Is there a way to map that process to an external midi button? In the mapping menu there is a param for a recording trig, but when you press it twice it doesn’t automatically resize the loop, but instead uses its predefined length.

1 Like

yes! to two buttons.

  1. map PARAMS > loop X > “recording trig” to a button
  2. map PARAMS > loop X > “play trig” to a button

press the button mapped to the “recording trig” and then when you want press the button mapped to the “play trig” and it will resize the loop and stop recording.

2 Likes

I’ve been using oooooo intensely to prepare some sonic landscapes for a documentary soundtrack. I’m noticing a click + fade in when pressing K3 to resume after pausing a loop. The same click+fade in happens when pressing shift+K3 for recording. I updated Norns recently with the last version. Is there anything I’m missing or I can do to fix the clicks and fade in? Thanks in advance for the kind help

1 Like