oooooo

kind of wondering…
how similar or divergent is oooooo to the SOMA Cosmos?

1 Like

looks very similar! one divergence maybe is that Cosmos is stereo by default? oooooo can record in stereo but only three loops (each loop is mono) by hard panning them and setting the input type to 5 and syncing each pair of loops (this is done automatically by selecting PARAMS> choose mode > stereo looping). its another matter though of having the lfos in sync (just set the lfos to the same parameter will do it, but there is no setting to do that automatically).

the description they give is something to play with in oooooo:

by a mathematical shift based on the relationships between large prime numbers (the size of all delay lines are different primes), an asynchronous operation of the LFO, and modulation with a slowly changing chaotic signal

you can certainly set the loop sizes to be different prime numbers, and modulate the LFOs by midimapping the lfo offset. having the LFOs be a bunch of random numbers is pretty good though to keep things moving randomly.

of course the biggest divergence is the interaction itself. sometimes its just really nice to interact with a footpedal like the cosmos instead of turning knobs. sometimes its nice just to turn knobs. in oooooo you could certainly map things to a footpedal though if you wanted…

6 Likes

This is undoubtedly one of my favourite scripts since getting my norns recently.

Something I’ve been doing all the time lately is running a synth engine or sampler and recording little musical phrases of various lengths into tape. Then I open them as loops in oooooo and go wild. Instant early-eno vibes… when things interlock and form their own melodies and harmonies with one another… ahh it’s so lovely. Here’s a piece I made with that method today… I believe there was a pass where things went through barcode as well. Thank you thank you @infinitedigits for your remarkable work building these artistic tools.

14 Likes

Having an issue with this script since the new firmware update.
As soon as recording is engaged/triggered, I get a huge blast of sustained noise (the output is maxed out) which can only be stopped by restarting Norns.
Using a Norns Shield with the 4270 chip.

2 Likes

alright, sorry, thank you. this is a really weird problem that has snuck into softcut binaries recently (it plagued attempts to add the rec_once behavior,) and surfaces in unpredictable circumstances. (i’ve never personally reproduced it at all.) i am working on it but cant say when it will be solved. same surfaced issue in acrostic was worked around by changing some intialization command ordering.

[ed] pardon me, it was just bypassing the filter that avoided the spike/blast

weirdly, i’ve double checked that filter state is cleared. hm. will keep at it.


actually it would be a huge help to me if anyone experiencing the issue could see if it goes away on entering into the REPL:

for i=1,4 do softcut.post_filter_lp(i,0) end
3 Likes

Is there any specific location I should put it?
I assume in the “function init ()” section somewhere. Apologies - not done any coding in a long, long time.

That’s the REPL, sorry for the image, I didn’t know how to explain it better than that…

1 Like

Many thanks!

Okay, entering it after the noise kicks in does nothing to stop it.
edit for clarification:

  • Entering it prior to script loading doesn’t stop the noise.
  • Entering it after script is loaded but prior to recording stops the noise** but prevents any audio being recorded on loops 1-3. Loops 4-6 CAN record audio. Interestingly, if I have recorded audio into those loops, I can then record audio into loops 2 and 3, but 1 remains impossible to put audio into.
    ** Selecting the “A” option (all loops) and hitting record will always cause the noise.
  • Entering it once the noise has started has no effect. The noise is present until Norns is restarted. Turning “out” to zero mutes the noise, but any out value >0 results in the noise returning at 100% volume.
1 Like

my bad, i meant i=1,6 i forgot ooo uses all 6 voices

thank you for doing that experiment. if it occurs to try it with this correct index when noise is happening, that would still be interesting. (sorry to spam this thread, oh well.) if you just want the script to work without noise (but also without filtering) than an analogous change can be made to ooo source, setting filter mode levels to zero and dry level to 1, here:

1 Like

Oh I’m more than happy to test out whatever.
Will run the tests again tonight and report back.

I think we are on the way to a proper fix. Something about the new system configuration has made it more likely for nan and inf to enter our audio pipeline

(Ed woop, fix link
[don't merge] zap gremlins on SVF input, clamp FC by catfact · Pull Request #64 · monome/softcut-lib · GitHub)

This is the experimental/wip fix. Will have something more properly put together asap. If you/anyone want to test early it involves just updating the softcut submodule and rebuilding norns. (the change imposes extra CPU load, so this will not be the final fix.)

6 Likes

I tried with the i=1,6 replacement - no change. I also did it pre/post loading and post noise, to no avail.
It seems like the noise burst is some form of feedback - I let it do its thing for about a minute and it eventually subsided.

yes that is consistent with what i am seeing and the good news is that it seems totally fixable. (the explosion is nan/inf coming apparently from JACK, and it recirculates in the filter for a greater or lesser duration depending on how many samples of crap arrived)

thanks for looking

2 Likes

There’s an interesting feature in the SOMA Cosmos where the delay lines cross-feedback between delay lines. See Loopop’s excellent overview. Soma Labs COSMOS Review // 8 performance tips and ideas // Full tutorial - YouTube

1 Like

just add some parameters i guess

1 Like

Please, is there a way to fix the noise burst introduced with norns 220306, or does it make more sense to wait until a new norns software fixes this?

you disable the filters by changing these lines:

oooooo/oooooo.lua at main · schollz/oooooo · GitHub
to

      softcut.post_filter_dry(i,1.0)
      softcut.post_filter_lp(i,0.0)

and
oooooo/oooooo.lua at main · schollz/oooooo · GitHub

to

      softcut.pre_filter_dry(i,1.0)
      softcut.pre_filter_lp(i,0.0)

(@infinitedigits pre-filter setting is a bit weird anyway and will cause early clipping in the buffer)


system-level fix is coming soon, i just need to figure out the most efficient+effective place to apply it

3 Likes

pushed a fix now @wolfgangschaltung ! the noise is not that nice but amusingly I was playing with oooooo today with a new doohickey I soldered together and I somehow got the noise burst at the same time my doohickey exploded. (just a coincidence!! the norns has nothing to do with the explosion, just contributing some timely noise )

(doohickey was easily repaired and now functioning again and no damage to anything). (please withold comments about my bad soldering, this is my first time with smds).

6 Likes

@zebra and @infinitedigits thank you both for the fix, really appreciated! :pray:

Talking about conincidences: I had just finished changing the lines per @zebra’s instructions, and after that compared my changes to what I saw on github…without knowing that @infinitedigits had just updated github…I was going like “am I crazy? I can’t see the code difference anymore, did I just dream I changed the code…what’s happening here?!?” :smiley:

2 Likes

maybe not the right place to ask but since this has been discussed on this thread I’m asking here. @zebra am I understanding it correctly that the current workaround to this issue is to disable all filters until there is a fix? I’m experiencing the same thing on a script I’m working on and was wondering how to proceed. thanks!

just re-read your post above and see that at system level fix is coming soon. again, a great thank you for all your hard work on softcut.

@infinitedigits thanks for the hint. looked up you code changes and I see if I something similar will work on my script.

1 Like