Hi all - i’m brand new to Norns and am really excited about getting ooooo to work, but thus far I have been unsuccessful. I’m not sure if the issue is with my setup, or my hardware etc.
I have norns shield set up with my Prophet Rev2 into the input, and the output leads to my Daw/speakers. I can hear the synth playing through the norns, but when I start recording on ooooo I don’t get any sound. I’ve tried to test my instrument input with other scripts and it appears to be OK. Any suggestions welcome!

1 Like

low hanging fruit: have you messed with the faders on the system mixer page?


I’ve played around with them to see if they would help anything, but haven’t had any luck.

1 Like

do other softcut-based scripts work? (otis? cranes? mlr?)

if you open maiden while running, do you see any errors or weird output (if so please paste it here)?

can you clarify this? do you mean that you don’t get any sound during recording? or that once you recorded you don’t hear anything playing back?

can you try recording, saving the loops, and then doing a save PARAMS > save/load and then opening the saved loops in a DAW (audacity or something) to see if it is indeed empty? the loops themselves will be saved into /home/we/dust/data/oooooo/<name>.

thanks @zebra !

Can anyone tell me what “rand pars” is? Is it a randomization applied to all params? That’s what it seems like.

Bingo (and 20 chars of course)


Can anyone think of a way (maybe a script mod?) to only use a single MIDI footswitch to record on all loops? My use case is that I want to record on the ‘active’ loop that I am currently showing in Norns. Currently, MIDI mapping supports a separate CC per loop but I’d like to only use a single switch for recording.

Hey people, I have a simple question,
Is there a way to copy a buffer to a different track, to treat the same sample in different ways? Thx


this is not possible right now. It would be great if you or someone wants to add that. it should be really easy to add - you can use this softcut function to copy one loop to another loop. the buffer numbers and start/end points are listed here. I’m not exactly sure how it would happen, there are two scenarios I can envision - would it copy one loop into another loop but keep the resulting loop the same size and everything? or would it copy a loop exactly so that all the parameters of the pasted loop have the parameters of the copied loop? (the former is much easier, the latter needs some extra code). whoever wants to add this can choose their version, I would accept any PR :slight_smile:


I’m recently experiencing a ‘load fail’ error with OOOOOO, which according to matron is due to a lack of Sequins. As a part-time user and after having scanned the commity and help pages, I have no idea how to find and install Sequins.
OOOOOO used to work fine, so did the Sequins requirement get added in a recent update?
I should also add that I have updated the system and restarted, all to no avail.

yes - you can either downgrade oooooo (download and unzip this: Release v1.9.1 · schollz/oooooo · GitHub) or upgrade your norns system (norns: update 220321).

1 Like

cool, thanks. so let me clarify (and i should probably have done this in some kind of noobs thread, maybe) - installing an update from the device menu is not the same as upgrading the system with a release such as you linked to. correct?

1 Like

the linked update 220321 is a normal system update that can be applied from the system menu. but it follows and depends on 220306 which is a total system upgrade and requires re-flashing the filesystem. this is annoying but happens only when we need to change or upgrade major system components (once every 2-3 years so far.) when a release requires this, it is labelled as a new image.

TL/DR: you must re-flash your norns/pi with the 220306 image before applying the 220321 update.


update: i figured it out by messing with the rate adjust % in the parameters > edit menu for each loop. still not sure how it changed in the first place. i do notice that the value changes in strange decimal intervals when turning the knobs on my shield however. how can i manually enter these values in maiden?

hello! i used oooooo all day yesterday and was able to adjust rate by single digits however today while using it i can only change in half values from 100 (400%, 200%, 100%, 50%, 25%). wondering how i can go back to fine tuning the rate parameter. tried resetting norns and restarting script. might be a simple fix but i can’t figure it out. thanks!


While there is currently the warble option in oooooo I’d love to control the saturation, wow & flutter etc within oooooo.

Would it be possible to combine tapedeck and oooooo into one script?

1 Like

yes totally possible. I’ll have a go at it. actually writing a new script now and I already integrated tapedeck into it too so I know how it’ll go.


just wanna bump…did you get any help on this?

I don’t know if I’m more excited that it’s possible, or the new script from you. Thank You!


Planning on buying another Norns soon mostly just because i miss this script. Sometimes u never know what u got til it’s gone :smiling_face_with_tear:

one thing I was curious about is it possible to use like a faderbox to control volume on individual loops.

I saw that with grid there’s some form of volume control but would be possible with a fader based midi controller?

1 Like

checking now and yes, you can map a MID controller to track volumes (and almost everything!)