Seems the filter on OOOOOO doesn’t work no more, probably after the latest update.
It’s maybe linked to the noise issue which some people experienced after the latest image update, I thought that maybe the filter it’s been bypassed until the fix, but the fix it’s been released on March :sweat_smile:, so I’m probably 100% wrong.

Any advice?

probably 100% right. This commit was made to bypass the lp filters and there hasn’t been a commit to undo this.

It’s an easy fix, which simply requires changing two numbers:

softcut.post_filter_dry(i, 1.0)
softcut.post_filter_lp(i, 0.0)


softcut.post_filter_dry(i, 0.0)
softcut.post_filter_lp(i, 1.0)

Oh thx a lot for this! I missed it for some reason…


yep! I removed the filter when a previous version of the norns os had a little glitch. that’s been fixed for awhile but I wanted to give time for folks to update. its been time enough so I just reverted it so the lpf should work fine again.


So you know how when you start recording, then press K3 again to stop recording and automatically size your loop to that length?

Is there a way to map that process to an external midi button? In the mapping menu there is a param for a recording trig, but when you press it twice it doesn’t automatically resize the loop, but instead uses its predefined length.

1 Like

yes! to two buttons.

  1. map PARAMS > loop X > “recording trig” to a button
  2. map PARAMS > loop X > “play trig” to a button

press the button mapped to the “recording trig” and then when you want press the button mapped to the “play trig” and it will resize the loop and stop recording.


I’ve been using oooooo intensely to prepare some sonic landscapes for a documentary soundtrack. I’m noticing a click + fade in when pressing K3 to resume after pausing a loop. The same click+fade in happens when pressing shift+K3 for recording. I updated Norns recently with the last version. Is there anything I’m missing or I can do to fix the clicks and fade in? Thanks in advance for the kind help

1 Like

For the latest Intervallo I’ve used a track done in oooooo. It’s mostly basic async looping with me playing a bit with the rate.


I love what you did with the rate. also the video syncing is incredible!! beautiful work, thank you for sharing.

1 Like

Thanks a lot!
I have to admit that the video syncing was 80% chance hahaha. Apart from the reverse part, which I did on purpose. I did a rough cut just randomly throwing clips on the timeline and the played it back and was “oh well that looks like I did it on purpose” hahaha


I`m having a problem, may its a bug: when randomizing paramenters from the A(ll) page then it turns all loops to lowest octave in Mellotronish mode

1 Like

yeah that sounds like a bug! can you see if it fixes it for you if you comment out this line?

1 Like

yes! that make it works fine

Is there a way to avoid the ‘click’ sound when pausing-playing loops?
Is there a way to avoid the latency from pressing play until obtaining the sound from the loop?
In ‘A’ mode, what does the permanent ‘pause’ symbol in the top right corner mean? I find it always there, even when play mode is on.
Thanks in advance. I’m enjoying the script a lot, but I still found little mysteries to solve.

I released an oooooo tutorial today. I can’t believe I never tried to chord sequencer until working on this. Thanks @infinitedigits for your help, especially with how to pronounce “oooooo” lol


@PeterBark thank you for creating these tutorials. I keep saying this but its constantly true: its such a gift your giving us! I struggle to explain the things and I’ve found your videos so illuminating and instructive and thorough. and your music creations are just pure delight.


Thank you so much for the kind words! I’m happy to be contributing something back to the community, and glad that people are finding the videos helpful!


Hi norns newbie , sorry if this is the wrong place for this? :frowning:

I’ve been playing with the oooooo script and loving it, but for some reason it now wont load, I’ve tried turning the norns off again, restarting, did a fresh install and tried connection to maiden to see what’s going on, however I’m not 100% sure of what i need to do to get this working again, hope one of you more seasoned users maybe able to cast some light for me?



# script load: /home/we/dust/code/oooooo/oooooo.lua

# cleanup

# script clear

including /home/we/dust/code/oooooo/lib/grido.lua

including /home/we/dust/code/oooooo/lib/json.lua

including /home/we/dust/code/oooooo/lib/glyphs.lua

including /home/we/dust/code/oooooo/lib/json.lua

including /home/we/dust/code/oooooo/lib/monosong.lua

including /home/we/dust/code/oooooo/lib/table_addons.lua

including /home/we/dust/code/oooooo/lib/lattice.lua

### SCRIPT ERROR: load fail

/home/we/dust/code/oooooo/lib/monosong.lua:4: module 'sequins' not found:

no field package.preload['sequins']

no file '/home/we/norns/lua/sequins.lua'

no file '/home/we/norns/lua/core/sequins.lua'

no file '/home/we/norns/lua/core/params/sequins.lua'

no file '/home/we/norns/lua/lib/sequins.lua'

no file '/home/we/norns/lua/softcut/sequins.lua'

no file '/home/we/dust/code/sequins.lua'

no file '/usr/local/share/lua/5.3/sequins.lua'

no file '/usr/local/share/lua/5.3/sequins/init.lua'

no file '/usr/local/lib/lua/5.3/sequins.lua'

no file '/usr/local/lib/lua/5.3/sequins/init.lua'

no file '/usr/share/lua/5.3/sequins.lua'

no file '/usr/share/lua/5.3/sequins/init.lua'

no file './sequins.lua'

no file './sequins/init.lua'

no file '/usr/local/lib/lua/5.3/'

no file '/usr/lib/arm-linux-gnueabihf/lua/5.3/'

no file '/usr/lib/lua/5.3/'

no file '/usr/local/lib/lua/5.3/'

no file './'

stack traceback:

/home/we/norns/lua/core/norns.lua:144: in function </home/we/norns/lua/core/norns.lua:144>

[C]: in function 'require'

/home/we/dust/code/oooooo/lib/monosong.lua:4: in main chunk

[C]: in function 'dofile'

/home/we/norns/lua/core/startup.lua:43: in function 'include'

/home/we/dust/code/oooooo/oooooo.lua:29: in main chunk

[C]: in function 'dofile'

/home/we/norns/lua/core/script.lua:186: in function </home/we/norns/lua/core/script.lua:186>

[C]: in function 'xpcall'

/home/we/norns/lua/core/norns.lua:145: in field 'try'

/home/we/norns/lua/core/script.lua:186: in function 'core/script.load'

/home/we/norns/lua/core/menu/preview.lua:23: in function 'core/menu/preview.key'

/home/we/norns/lua/core/menu.lua:140: in function </home/we/norns/lua/core/menu.lua:117>

# script clear

lua: /home/we/norns/lua/core/clock.lua:71: bad argument #1 to 'resume' (thread expected)

stack traceback:

[C]: in function 'coroutine.resume'

/home/we/norns/lua/core/clock.lua:71: in function 'core/clock.resume

hihi! hope all’s well otherwise :slight_smile:

this notice about sequins means that your norns isn’t up to date for the version of the script you’re running. here’s a message from zack about this sort of thing up-thread:

i’d recommend going the update route, since it includes files and features other scripts you might use will rely on. let us know if you run into any other trouble!


Hi Dan

Thanks for taking the time to reply.

All good here, hope all is well with you too?

I will definitely look at a fresh install but need to read up on that process a little more first before attempting that.

If i did want to use the older version of the script, is it as simple as unzipping the files into the present oooooo folder location on the norns and overwrite the files that are already installed?

Sorry if that seems an obvious question just finding my way with this little by little

1 Like