Orac, Sidekick, Pure Data and SC for Norns

I just installed Orac/Sidekick on my DIY (2022) Norns Shield, and have a couple issues I am hoping someone can help me with.

The first is when I try to run the norns shield “fix” is says:

“cannot remove ‘/etc/systemd/system/multi-user.target.wants/norns-jack.service’: No such file or directory”

Secondly, when I switch on Sidekick, the text on the screen looks “blurry” (oddly enough, if I try to take a picture, the text looks clear on my camera) this is also evident in Orac, but when I saw back to Norns it is fine. I have tried rebooting but that didn’t help. Thank you in advance for any help with these issues.

2 Likes

I have also noticed this since updating to the new norns image, 220306.

1 Like

Okay, so at least it is not just me. Hopefully someone can come along and let us know what is going on, or a fix will be implemented :slight_smile: At least it is still usable, just weird looking lol.

1 Like

Im not entirely surprised…
the install was dependent on how Norns is using Linux, if they changed the way Linux was configured (which they obviously have) then this will need updating.

as for blurry, it’s probably just using different fonts to Norms…
as obviously the hardware, and the way it interacts with it is identical.

so its likely just fonts used - Im pretty sure, I used the same fonts as Norns, but that was way back… so very likely the newer versions of Norns/Norns image is using different font, which just looks sharper.

status… I’m not really using Norns, so not really being monitoring whats going on

also, my Fates image is not working - entirely my fault, I basically needed the rPI4 for another project, and so blitz the image, as I wasn’t using it for Norns.

So… at the moment, Im kind of waiting to see if the Fates image by @okyeron is going to be updated to the latest Norns Image.
(in fairness it may be @okyeron has done this already… and if not, no rush mate… !)

6 Likes

He has now :slight_smile:

Having said that, I just installed Orac on my Fates (latest image version) and it looks and seems to work fine so far.

2 Likes

Does your 4th encoder works in Orac?
I’ve tried changing the config.txt file following these instructions but with no success:

Yes, worked fine straightaway, I think. I’m back in Norns working on my script though, so can’t check right now. The 4th encoder worked out of the box in Norns.

Getting my norns shield soon and have access to a both a RPi 3 B (1gb ram) and a RPi 4 B (8gb ram). Is there any benefit to using the 4 considering that I plan to use Orac with a fair amount of polyphony and signal processing in the mix or is it just overkill?

Hello guys, I just installed orac and sidekick on my Norns Shield but I can’t find the sidekick folder location (it is not in dust), can you help me?

I´m having the same problem of blurry font, here I described the problem:
norns: new image 220306 - #312 by Klinik and follow up.

So text its blurred only when using Sidekick with norns shield. Text fine using fates!
Any clue?? @okyeron
Thanks!!

@smebronoie Sidekick folder is at /norns/we/sidekick you can access by sftp

2 Likes

There are some rendering issues with sidekick, like draw a diagonal line, then draw a blank line to delete, and it leaves behind the anti-alias edge pixels. I think you just have to find work-arounds, i.e. choose another font.

Maybe you can help me - what does one do when midi devices don’t connect? Alsa says the device is recognized, and I can connect the midi keyboard to pure data through aconnect. But orac is supposed to auto-connect isn’t it? Is there a way to do this with amidiauto? How do I get orac to connect without setting up an SSH connection?!

edit. amidiminder might work - I installed it and it half works right now (some device connect, others don’t). I’m working on a terminal tedium - something I want to work stand-alone without having to SSH in every time I plug a midi device in.

amidiminder

My installation froze at some point. I went to restart my norns and it froze with screen reading “jack fail”
My norns shield fails to restart now.

I may need some help. Gonna try flashing the SD and reinstalling norns.

EDIT: I just read in the wiki about the fix for Shield. I could have run the fix before restarting my norns. Oh well I wanted to know more about flashing the sd. Here goes nothing.

Hey all. After attempting to install sidekick on my shield? I got en error message while doing the ssh and my Norns screen read “jack fail.” After reflashing the SD I get the same error on startup.

Is my unit bricked?

EDIT: tried to reflash a couple more times on different cards and same result. super bummed as I was loving this platform and only had it a couple months. Hopefully somebody can’t help me solve this. Anyone in Australia do shield builds that might be able to assist?

EDIT: @tehn I read through the github discourses that referred to this issue and from my admittedly limited understanding i believe my unit is bricked. I have not checked my pi board yet but thats up next. Ill get to it later. today.

I cant begin to express how foolish I feel having tried to perform this install without having read all the wiki. Live and learn.

SOLVED: Happy to report Im up and running again. I, in fact, had flashed the wrong .IMG version when trying to recover from “JACK FAIL” In the end, Im glad I had to go through the process.

UPDATE: A bit of trial and error and I got this working as well as norns mother. Was both a bit of a ball ache AND fun bashing about at the same time. THANKS!

Hi all, I have been out of the loop for a while now (life got busy) but just circled back to this topic to see if a solution had been found. Am I correct in assuming if I flash Fates (assuming that is possible) I will have clear text with Sidekick/Orac? Thanks in advance :slight_smile:

1 Like

Mine is clear again, it’s working fine now (though Sidekick and beyond were formerly blurred after an update). I can’t recall what I did to fix that many months ago - it was quite possibly by simply re-flashing the disk image.

I’m fairly positive that’s what I ended up doing, since I remember that I was able to get everything working normally again after all, with the exception of Eyesy (visualizer)… which may have just been some user error during installation.

Edit: After re-flashing factory Norns on the other hand, I’m finding that Sidekick still appears blurred.

Edit Again: Now - after uninstalling Eyesy from my Fates (due to an issue I was having with entering Sidekick), I can no longer enter the Sidekick menu at all. Fates just hangs when I try the button combo… :frowning: