Orac, Sidekick, Pure Data and SC for Norns

that worked for me!
Orac is working fine. just going to try the PD stuff next

1 Like

I just tried the PD patches and neither seem to work (this is on p3+)
It just stays at the ‘Lauch… SimplePd’ page, nothing i press makes it do anything
5secs of 3 buttons does return me to the sidekick menu

this is awsome everything works now. i am using a tft screen which is 320 x 240 so everything is a bit small where would i look to change this and recompile

.
thanks again

3 Likes

See top posts, I list the repos

What you should be able to do is :
Just change NuiLite to have a scale factor set during initDisplay
The just recompile nuilite
Then copy libnuilite.so to where orac/mec and sidekick are installed. (In use/local)

This way you don’t have to rebuild everything and start copying every about :slight_smile:

Later I could add scale to the nuilite api to make it part of programming api

Btw @okyeron, @jedgar
The maiden restart is also done in 0.91

@TheTechnobear will OTC run on fates? Would love to experiment with some visuals!

1 Like

I plan to get OTC running on the organelle-m. ( yet another project on my list!)

Once I’ve done that it would be fairly straightforward (*) for me to get OTC working on Diy Norns & fates.

can’t be done on factory norns as it doesn’t have a hdmi :frowning: don’t think there’s is a solution to that ? ( usb display?)

Anyway, unfortunately needs to work it’s way up my todo list.
————

(*) The core of install will be similar for organelle-m with regards to setup/packages.
But I need to interface to the NuiLite for the norns display, buttons encoder - either by adding a python binding or an OSC interface into sidekick.
Both options are quite attractive for app developers who want an alternative to C++ / PureData

3 Likes

hi, would it be ok for you too see if the pd patches run on your p3+?
Cheers :slight_smile:

As above you need to copy the new libnuilite.so into the patch directory - I’ll update patchstorage when I get time.

oops, sorry, didn’t see that comment :zipper_mouth_face:

no, worries :slight_smile:

ok, Ive updated the demos on patchstorage.

also now polypd defaults to some better values at start up…
this was required for 3-enc norns, since you have no ability to change volume (as its on enc-4)


can anyone let me know if they still have issues - otherwise, I can put my Fates back together with the rPI4

OK - I went through and installed the new files, and it’s working with my 3b+! I have 4 encoders, but it boots into the 3 encoder mode… I have never had anything running that I could test my 4th encoder with… and I added it after I built my fates. Should I pull it apart and check the soldering, or is there something in software I could try?

by default the FATES image support 3-encoders, you need some magic incantations to get the 4th encoder working :slight_smile:

something like:

sudo dtc -W no-unit_address_vs_reg -@ -I dts -O dtb -o /boot/overlays/fates-buttons-4encoders.dtbo /home/we/fates/overlays/fates1.7-buttons-4encoders-overlay.dts

then edit /boot/config.txt ? (to switch to using this dtbo)

but @okyeron can confirm with the current rPI3 image whats needed

no need to recompile the dts file.

just change /boot/config.txt

comment out the first one, uncomment the second

# Buttons and encoders
dtoverlay=fates-buttons-encoders

# Alternate overlay for 4 encoders
#dtoverlay=fates-buttons-4encoders

I’ll need to check the image - perhaps change it to 4 encoder as default

1 Like

Will this result in the FATES running 3 encoders on the Norns and 4 for Orac?

Well that totally did it!

1 Like

Working my way through the youtube tutorial. Fates is up and running, and I’m trying to edit the pure-data. I’m using windows 10 with powershell - I ran ssh -Y we@norns.local, stopped sidekick, and tried to run /usr/local/sidekick/sidekick while holding the button, and get

Sidekick launch
launch : SimplePd
xprop: unable to open display ‘’
pd running : cd “./patches/SimplePd”; pd -nogui -rt -audiobuf 4 -alsamidi main.pd &
opened alsa client 128 in:1 out:1
using framebuffer /dev/fb1
Connection failed (Invalid argument)

No pure-data mirrored on my desktop “as if by magic”. Probably because I’m using windows - any ideas what to try?

Norns will ignore the 4th encoder.

1 Like

so windows does not include an xserver, you’ll need to install one - something like xming, vcxsrv, cygwin x

however, its a very long time since I last did that (as I use a mac for development), so its probably worth asking on a new topic, on whats available for free and is easy to install. e.g. perhaps the windows 10 ubuntu subsystem can be used these days?

an alternative is we setup a VNC server on norns, we did this on the Organelle, and users really loved it - as vnc is a lot simpler for users to setup on the desktops esp. on windows :slight_smile:

A quick note - I learned the other day that the norns hardware (or the system image) has the raspi-config systemd unit masked. Not sure this will matter or not for VNC setup

hey @okyeron @TheTechnobear this is great.

I wonder if it could work with a ssd1306 oled display, but anyway that would require tweaks on the FATES board, and maybe a totally different ui display pd lib. I don’t think it would just work with NuiLite?

It’s just that I think this would be nicer with a smaller case/screen. Seems like a waste of space such big screen, at least running ORAC.

Cheers!