Orac, Sidekick, Pure Data and SC for Norns

The Fates PCB is wired specifically for the Newhaven ssd1322 oled display. YOu could probably look at the pin-out and free-wire the ssd1306, but ¯_(ツ)_/¯

also - i have no idea if the ssd1306 is already in the linux kernel or if you’d have to manually compile it in - which is what I had to do for the ssd1322.

otherwise - if the oled can be a framebuffer device, it should just work

Steven - VNC can be enabled through raspi-config interfaces menu. I followed the directions below to update VNC (which may be resident on the pi from the get-go). Also, there is a ubuntu bash app in the Windows app store. I get the same error when trying to run sidekick to edit a patch, but at least I have VNC viewer installed and nominally connected to the pi/norns/orac/fates beast

starting sidekick
using framebuffer /dev/fb1
load startup patch: SimplePd
launch : SimplePd
xprop: unable to open display ‘’
pd running : cd “./patches/SimplePd”; pd -nogui -rt -audiobuf 4 -alsamidi main.pd &
opened alsa client 128 in:1 out:1
using framebuffer /dev/fb1
Connection failed (Invalid argument)

Have done the new install on my Pi3b+ and it works great! Fourth encoder works as well. Don’t have a midi device where I am to get too deep in it. Will also need to take a look at some documentation and get more comfortable with it (have only spent a few minutes with an Organelle or Orac before). But really excited to explore further! This will open a TON of possibilities with a second or third FATES :wink:

1 Like

sure, I kind of imagined it was specifically wired for it. I’m not good at electronics. I’ve thought you were connecting the oled to the i2c pins and that’s all. No linux drivers required, only i2c communication using the raspberry gpio ports

Yes but no. The OLED on fates is SPI rather than i2c. But yes - it’s just those SPI pins on the pi GPIOs (and a bunch of ground connections on the newhaven display board)

I originally made this work with an sh1106 display and I have some notes for that linux setup here

1 Like

ok, so all you really need to do is:

sudo apt-get install realvnc-vnc-server

then you can create a small bash script
~/sidekick/System/startvnc.sh

and just place in it

vncserver

this will mean that you can start in manually in sidekick (only when you need it)

(this will also work on std norns, as we are not using raspi-config)

next…

you need a (use realvnc) vnc client on mac/pc
start it , and connect to norns.local:5901

then in the terminal window from the vnc client window

sudo systemctl stop sidekick
cd sidekick
/usr/local/sidekick/sidekick 

now when you start a pd patch it will appear on your vnc display

BUT there is an issue … you cannot move windows…
because you dont have a windows manager, so we need a fairly lightweight one
back to norns

sudo apt-get install jwm

viola, we now have a vnc server, client that you can use PD with


all above tested and working on my Fates :slight_smile:

4 Likes

Thanks for the info and the fix, adding those lines to the start and stop scripts worked perfectly.
No worries/hurries about the poly pd thing! Other than that, yes norns, Sidekick, Orac, and Pd are working great and happily coexisting. I’m on a Pi4 w three encoders.

1 Like

Thanks for all the help Mark. I have VNC working - I’m using a viewer from VNC connect. Seems like everything is working. Any idea how to change the terminal screen resolution? Might require paying for the viewer…

Having some trouble installing. After running the below command, terminal is telling me that I have unmet dependencies but Im not quite sure why because I put the files into the Norns directory.

sudo apt-get install -y ./*deb

Reading package lists... Done

Building dependency tree

Reading state information... Done

Note, selecting 'mec' instead of './mec.deb'

Note, selecting 'orac' instead of './orac.deb'

Note, selecting 'sidekick' instead of './sidekick.deb'

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:
The following packages have unmet dependencies:
 mec : Depends: libcairo2 (>= 1.16.0-4) but 1.14.8-1+rpi1 is to be installed
 orac : Depends: puredata (>= 0.49.0-3) but it is not going to be installed
 sidekick : Depends: libcairo2 (>= 1.16.0-4) but 1.14.8-1+rpi1 is to be installed
E: Unable to correct problems, you have held broken packages.

Looks like you did not do update first, as it’s not finding latest packages.
(or no internet connection?)

Try this, then run again

sudo apt update

(could you post the results of this)

p.s. is this on a diy norns or factory?

@okyeron is the factory norns on stretch or buster? are there plans to move it to buster?


EDIT:
ok, so Ive got a very old rPI setup that uses stretch and I get this message too on it.

Im going to hazard a guess that Norns is on Raspbian Stretch, and that @Prnts is running on factory norns.

the issue is Raspbian Stretch repositories are no longer getting software update.
for example Pure Data is still on 0.47 - Orac requires at least 0.49

(libcairo is not really an issue, I code probably build with 0.14 on stretch… but its not ideal!)

I could build and ship the missing packages (Pd 49), but thats a bit of a pain, and im not sure something I really want to do (ship 3rd party products) … Id prefer we were all on the latest raspbian distribution (buster)

I could try to do the upgrade procedure for my ‘stretch’ based norns install to take it too buster,
see if anything breaks (seem unlikely) - but not sure how many ‘factory’ norns users would want to do that.


EDIT2: hmm, a bit more thinking a dist upgrade is not a good option…its too radical a change, and could cause other issues.

I think only solution would be :

  • release a PD 49 package for stretch (approach i took on organelle)
  • downgrade requirement of libcario to 1.14 , which Im pretty sure is a non-issue… just needs testing

its not preference , and involves work for me - but if i have to do it, i will… as i want all users, regardless of norns ‘version’ to have the opportunity to use Orac/Sidekick/Pd

but, Ive posted on DIY shield thread, to see what their plans are for stretch/buster, to see where they are headed, as I believe rPI4 support by the DIY Shield requires monome to move to buster?!

I believe its in everyones interests (users and developers alike) that we aim to be compatible across these various versions of norns. this will help avoid confusion for end-users, give access to existing norns users to widest choice, and allow potential buyers of norns to select the version that best suits their requirements (budgets/form factor etc)

1 Like

You are correct I am on a factory Norns. I did run sudo apt update before trying to install

hi there this is fantastic. is there a way to make the pure data patches text larger on my diy norns. i have looked at the mother patch but that just seems to adjust position of txt not size. is that covered by the NuiPd? :confused:
recompiled after changing nuiDevice to fil my display, and repaced NuiPd linux in the patch folder. :slight_smile:

1 Like

here are the results

Get:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]     
Get:2 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Get:3 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages [11.7 MB]
Get:4 https://package.monome.org stretch InRelease [3,174 B]                   
Get:5 http://archive.raspberrypi.org/debian stretch/main armhf Packages [221 kB]
Get:6 https://package.monome.org stretch/main armhf Packages [21.5 kB]         
Get:7 http://archive.raspberrypi.org/debian stretch/ui armhf Packages [45.0 kB]
Get:8 http://raspbian.raspberrypi.org/raspbian stretch/contrib armhf Packages [56.9 kB]
Get:9 http://raspbian.raspberrypi.org/raspbian stretch/non-free armhf Packages [95.5 kB]
Fetched 12.1 MB in 1min 8s (178 kB/s)                                          
Reading package lists... Done
Building dependency tree       
Reading state information... Done
134 packages can be upgraded. Run 'apt list --upgradable' to see them.

ok, @Prnts and other factory norns owners… a special release just for you :slight_smile:

EDIT: this is no longer relevant as Factory Norns is now part of the normal installation, so all can install as detailed in the top post

Experimental Release for Factory Norns (only)

The factory norns is based on an earlier version of raspbian (stretch) which includes an old version of pure data - so we need need a slightly different installation technique to that described in the video.

so I have a new install procedure that will become the ‘standard’ install route for future releases for all platforms. here is an early release of that just for you :slight_smile:

(thank you to @Oxbown for the suggestion to use a remote debian repo)

Install procedure

you will need to have your norns connected to your local wifi network, and it needs to have access to the internet.

a) login to norns

ssh we@norns.local
(password : sleep) 

b) cut n’ past the following line to norns

sudo curl https://thetechnobear.github.io/apt-norns/install.sh | sh

c) reboot norns

pd demos

pd demos updated for factory norns
(in the next release, these will be moved to patchstorage so it will be the same for all norns variations)


feedback

please as Ive not tested this on a factory norns, let me know how it goes… does it work?

if you have any errors during any stage, let me know, and we can see if we need to tweak things.

Monome (factory) Norns feedback…

as you may be able to tell from the other post, Im needing to jump thru a couple of hoops to get this working on the factory norns - and to be frank, its also is a bit of a pain for my build process.

BUT, I really want Orac/Sidekick and Pure Data (Nui) to be available to ALL norns users regardless of the chosen variant … so its something Im ‘happy’ to do.

however, Im wondering how many factory norns owners are that interested?
as so far its mainly been DIY Norns owners that have installed, though I admit its very early days since only released 2 days ago.

but perhaps DIY owners are a bit more ‘experimental’ or happy to try something different out, perhaps because they are clearer on how to ‘fix things’ if it breaks?

So Im interested in reasons factory owners might not be trying it out, Id love to hear from you.
possible reasons, Im guessing… but some thoughts going thru my mind… (of course add your own!)

  • It doesn’t do add anything I’m interested in, Norns software is enough for me.
  • I’ve not had time to try it out
  • I don’t want to destabilise my norns - perhaps might break it
  • I don’t want to install anything thats not release by monome, Id like to ‘keep it clean’
  • I’d like to see others installing/testing it, and I’ll come back to it once it feels ‘safer’ - I’m no guinea pig
  • Looks too complex to install/use
  • I don’t understand what it does and/or why it might be useful to me

I’m hoping if I get some feedback, then either I can help on some of these points,
or perhaps we find out that the DIY side is more ‘experimental’ , and is where support should be focused (at least for now).
and given the price of Fates/DIY Shield it may be that factory owners might prefer to buy/setup a separate DIY for this kind of experimentation, and keep their monome norns ‘clean’.

thoughts?


p.s. sorry, I keep switching between ‘monome norns’ and ‘factory norns’
Im not really sure how to clearly distinguish this yet… (given the DIY shield will also be a monome norns)
… anyway, thats a topic for a different day :wink:

6 Likes

Interested, but up to my eyeballs at work and had neither the time or energy to try installing.

1 Like

yeah… know that feeling … time and energy is such a precious commodity.

1 Like

Factory norns here, I plan on trying this out today. Just haven’t had the time. :slight_smile:

4 Likes

Have a factory Norns. Would love to run pure data generated noises and drones etc on it. Im not in a rush to get this set up and right now its looking a little on the complicated side for me so I am hoping someone else can help test it.
very appreciative of your work.

1 Like

is anyone else getting high cpu usage using orac. it seems to be/usr/local/MEC/mec-app nui_kontrol.json