Orca - Livecoding Tool

I was not able to accomplish it on 32bit Windows and ended up using a 32 bit linux linux distro on my handheld rugged pc. The tradeoff was losing a few special buttons, but running orca and a synth got dramatically simpler.


That’s awesome, I never expect the ven diagram of Yves Tumor and Orca, but this is perfect!

1 Like

@neauoire Can I send a $ command to change the tempo in the uxn version?

Hiya, what distro and desktop enviro did you use and were you able to calibrate the touchscreen in Linux? All the linux distros I tried (no matter how lightweight) seemed sluggish compared to Win7 on my CF-U1 and Xinput just wouldn’t calibrate, despite various tutorials I found online. Ultimately though I am more at home with Windows.

i used antix, the full versions. i believe it ships with its own window manager. the touch screen got “close enough” for me, but i’d be lying if i said it wasn’t a bit off.

1 Like

Not at the moment but I can definitely add it :slight_smile: The thing with orca-uxn is that the bpm is not very granular, it can only ever be a ratio of 1/60th of a second.


That’d be incredible. I looked at beetbug, and found the byte with the tempo, but the only language I know how to code in, is orca, hahaha. <3 I’m working on a pretty extensive orca project, and changing tempi would be amazing. Does it have any other self commands at the moment? I’m trying to squeeze as much out of it as I can.



Pull and build and you’ll have $spd: command, it’s not bpm: because like I explained earlier the Uxn version only has ratios of 1/60th.

It doesn’t, but I could add more if you like. Anything special request?


You’re a peach! That’s so nice! c: c: c:
Can you do color? Otherwise, stop, write and select would also be fancy ~ ~ ~ <3
Hmm, speaking of which, what’s the idea of play? If it’s not running, then how would you trigger the command in other places than the command line?


im having the same problem :confused:

Did you refresh the MIDI devices and select loopback as your MIDI output in Orca? Also, did you click Monitor “in” on your MIDI channels in Ableton?

EDIT: As Electret said

On it :slight_smile:

Orca can listen to stdin, so you could pass commands that way too.

1 Like

Thank you for this! A perfect side tab for avoiding work.

I don’t think you can possibly understand how excited I am about this… It’s going to be SO BEAUTIFUL. <3

1 Like

I’d like to share with you all the teaser for an album that I’m super excited for


That’s some beautiful, all-in Orca’ing right there. Kudos to Xsodect!

@neauoire By the way, and sorry for being a noob. I’m getting errors when trying to build orca. Do you know what’s happening here? Using MSYS2:


Assembling src/orca.tal
./build.sh: line 27: uxncli: command not found

Also, when using the command from sourcehub I get:

bin/uxnasm.exe orca-toy/src/orca.tal bin/orca.rom && uxnemu bin/orca.rom
Include missing: src/library.tal
Invalid include: ~src/library.tal
Invalid token: ~src/library.tal
Assembly: Failed to assemble rom.

Thanks in advance!

Oh yes, so when you build uxnemu, you should see a bin/ folder with uxncli and uxnem inside. Those are the binaries that you want to use when assembling tal files. I’m not sure how MSYS2 works, but if you can make some program accessible from anywhere, on unix systems, you’d do something like:

export PATH=$PATH:$HOME/some_folder

If you can’t do that on MSYS2, you could write the full path each time, like:

../uxn/bin/uxnasm orca.tal bin/orca.rom

Hmmm. After defining the export path, I still get:

It might be a problem with MSYS2. The export function seems to works fine.

I’ll see if I can get multiboot working on this machine. If so, then I’ll try doing in in Arch instead. My computer doesn’t support VM’s, so it can be a bit fiddly to work with.

Oh, don’t try to assemble from src/, try from orca-toy/.

1 Like

And then don’t assemble to bin/orca.rom, just assemble to orca.rom.
This is my first rodeo. But here we go! Thanks for the help. <3