Orca

https://www.instagram.com/p/CLiO7sHBhsC/?igshid=vnnxlaowr99z I’ve been playing around today with animating the grid with Orca.

4 Likes

same here - is there a fix on the way? i’m on the most recent version from maiden …

EDIT: could fix it myself by adding + 1: Orca - Livecoding Tool - #1373 by Frederickk

v1.4.7

Hi all, there’s a new update for Orca available via Maiden. Thanks to @vicimity and @glia for their help and contributions!

There are still some outstanding issues being worked on (namely the params bug found by @acampbellpayne). Here’s a run down of fixes/updates.

  • Fixed iterate and counter behaviour to be 1-indexed @vicimity
  • Fixed delete, to erase entire selected area @vicimity
  • Fixed insert key to not paste @vicimity
  • Merged Arc read operator ( @glia
  • Changed encoder behaviour so that value is set on release
  • Added CONTRIBUTING.md
  • Updated README.md

TODOs

16 Likes

here we go, just got this keyboard this afternoon - feeling excited to finally dip into orcλ~ηorηs:)

first few laps of clarity

8 Likes

I was able to get this working by adding the offset to the knob value on this line in _cc.lua.

self.midi_out_device:cc(knob + 14, val, channel)

1 Like

Great, this seems like a way towards a solution! I didn’t find the line you recommended tinkering with at _in_cc.lua. Perhaps the recent update changed things? But I found a match in _cc.lua and I made the addition there. Unfortunately this didn’t solve issues for me. After adding +14 banging !1z0 produced ch:1, val1:49, val2:0 (before ch:1, val1:35, val2:0). Also other issues, like “only odd numbers produce CC values” remain. By adding *3 self.midi_out_device:cc(knob, val *3, channel) I was able to set the val2 range between min:23 max:125 (0-127 would be optimal of course).

Just got my shield up and running today and jumped right in to ORCA. I was scratching my head about the softcut operator. I can’t say I fully understand it yet but I am creating some wild and unpredictable stuff that’s making very pleased.

5 Likes

not sure if this is a softcut or orca glitch, but I was getting no audio from softcut until I went into the menu and fiddled the “input engine” parameter (it was set as 0db, not -inf)

orca beat driving grid visuals :smiley:
very funny stuff
https://www.instagram.com/p/CG0cbhUqeSH/

2 Likes

Oh the joys of esoteric programming languages – well said! I’m so happy Orca exists :slight_smile:

1 Like

this is a system issue, i made a ticket here

@cwil are you on the newest update? i can’t replicate this, and believe it was previously a problem that’s now fixed.

1 Like

I should have specified before that I’m on fates hardware, sorry. Oddly the system>update option just stays on the “checking for updates” screen indefinitely… The menu says I’m on 210301, that looks like the previous release? Not sure what to try about the update, but when I booted up orca today softcut worked right away.

That’s expected behavior with the bug - after you goose the setting, the new value will be correctly persisted. Initial value/UI mismatch only evident after RESET or otherwise wiping system state

I couldn’t replicate a mismatch after RESET

@tehn i know, but you are running main. i’m talking about the bug before the fix. i think the fix was PR #1300 but am not really sure ATM.

i will take a moment and bisect if it would help resolve confusion

[ed] ok i am still not sure but brief examination reveals that these parameters were pretty borked in v2.4.1 and seemingly fixed by v2.4.9

i am still not convinced there isn’t some edge case. for example its important to test with a script that uses softcut, but doesn’t set eng_cut and adc_cut (as most do, including eg. halfsecond)

anyways that’s probably enough of this on the orca thread. the TL/DR is that this is not an orca problem, and is also not a problem in latest norns version as far as we know.

2 Likes

I was able to fix this by moving this line to this line. this is how the ‘vanilla’ (old) version of the _midi.lua file had it, assumedly it doesn’t shut the notes off if you group it at the top. heads up @Frederickk.

1 Like

Cool. I’ll check it out and test. Thanks for the heads up

1 Like

Very dumb question, but when I plugged in my computer keyboard to my norns running orca, it wouldnt let me type in it? is there a reason for this?

I would check SYSTEM>DEVICES>HID and make sure your keyboard is selected in slot 1