Organelle and Monome

Thanks I’ll try the rotationmessage!

Did you try the grid basic poly patch to compare the monome to the wooden keys?

Hi everyone,

This topic is probably not new. But after reading several things about the integration of monome and organelle it’s still not very clear to me.

Does a mlr patch exist, that allows a monome 64 to talk to the organelle? Other sequence patches are also welcome. I m very curious.

Thanks for your patience :slight_smile:
Grts

1 Like

@RenMegane go here and read that topic, you’ll find code for a kind of mlr patch for the organelle and monome grid.

1 Like

@RenMegane minimal assembly required in pure data… but everything you need to get started towards a customizable mlr system on organelle is here:

http://www.josephbranciforte.com/pd.html

any questions, let me know.

5 Likes

Thanks @josephbranciforte
gonna have a serious look at it .

There’s a new port of meadowphysics specifically for the modular environment Orac (thread link, patch storage link). I haven’t tried it yet, but in theory it’s very exciting because you could get quite deep with just an Organelle and a Grids now (meadowphysics sitting anywhere in one or more chains of multiple instruments/effects)

The author junklight is working on porting kria to Orac as well, and is waiting for Orac 1.1 (with its forthcoming modulation busses) to port white whale.

7 Likes

more fun with monome controlling organelle asynchronous looper patch.

also got the korg nanokontrol involved as a mixer (individual loop level & pan position) as well as loop launch/start.

13 Likes

another recently completed organelle/monome experiment… simple semi-probabilistic drum machine.

the potential for combining these two is pretty staggering. still just barely scratching the surface with pure data, and already some fairly usable tools emerging.

12 Likes

I’m having a problem connecting my monome (64 grid 40h model) to my organelle. It’s so close to working that I’m hoping it should be a simple fix but I just cannot figure it out. I think the source of the problem is that the ‘serialosc’ object creates okay but when I open it, it is missing some objects such as ‘pipelist’, prepend’ and ‘unpackOSC’, which all seem to be OSC objects I thought would be installed with the serialOSC installer package. Does anyone have any idea why these are missing and how I can get it working?

Couple of other things that might be useful to know:

  • The PD extended folder is on my organelle USB
  • I’ve been testing the ‘serialosc’ object directly on the organelle via tigerVNC
  • The serialosc object and monome work 100% as expected on my MacBook using PD extended which suggests it’s not a hardware issue
  • The ‘grid’ object outputs correct button press data when the monome is connected to the organelle but does not work with LED messages (I’m guessing this is because grid was made to work with 128 and not 64 grids). Additionally when running the serialOSC install the LED’s light up as expected upon completion. This suggests the physical monome to organelle connection is fine

This all makes me think that the issue must be the missing objects in the serialosc object? I would really appreciate if anyone has any ideas to get it working? Or even a working version of serialosc and/or the missing objects compiled for organelle?

Really appreciate the help! Keen to get this working as I’ve been building a sequencer for monome/organelle/CVpal which I’m hoping should be really interesting to use.

Also, heads up that I’ve cross posted this on the Critter and Guitari forum so apologies if you see it twice!

This is fantastic and exciting. But this thread has gone quiet. I’m thinking of diving in but I’m not sure I’m up to deep coding. I’m not a coder (only experience is building website in flash then html2, and teletype). Any new developments? I know a new orac version is coming soon, but not sure how soon…

3 Likes

I ported Kria to lua (& it will be updated to Norns 2.0 soon) next step is lua/grid external for PD which will mean it’ll work on organelle (which I also use) - someone has ported meadowphyics to lua as well which should also run. All my development was interrupted - cardiac arrest/heart bypass/moving house/redundancy (fun fun fun) but all on track again now so hopefully fairly soon

5 Likes

Yikes!
Glad things have improved, and thanks so much for all this, from all the non/elementary coders!

1 Like

Does anyone know what ‘import OSC mrpeach’ does inside the serialosc object? It’s the only part of the patch I can’t get working but I’m not sure how much it actually impacts functionality since I seem to be able to get key press data out and send LED messages in successfully.

Hi, did anyone succeed in having a grid working with a new Organelle M ?
I’ve installed using this which has been working on my Organelle 1 but not with the M.

Hi!

I got it working on the new Organelle M.

I had to manually install all the files trough ssh that are mentioned on the on the Serial Osc Installer folder, to the correspondent folders on my organelle.

This post is helpfull:

The file is the install.sh
#!/bin/sh

LOC="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )" # script working dir
BIN=/usr/local/bin
LIB=/usr/local/lib

sleep 0.5

echo "Enabling r/w"
mount / -o remount,rw

sleep 1

echo "Preparing"
systemctl disable serialosc.service
rm /etc/systemd/system/serialosc.service
${LOC}/killserialosc.sh

sleep 1

echo "Copying Libs"
cp -r ${LOC}/lib/monome /usr/local/lib/

sleep 1

echo "Copying Shared Objs"
cp ${LOC}/lib/libmonome.so /usr/local/lib/

sleep 1

echo "Linking Shared Objs"
ln -s ${LIB}/libmonome.so ${LIB}/libmonome.so.1
ln -s ${LIB}/libmonome.so ${LIB}/libmonome.so.1.4.0

sleep 1

echo "Setting Paths"
# libmonome looks for libs in in /usr/local/lib/, so add it to our libpath
echo "${LIB}" > /etc/ld.so.conf.d/usrlocal.conf
ldconfig

sleep 1

echo "Copying Binaries"
cp ${LOC}/monomeserial ${BIN}/
cp ${LOC}/serialoscd ${BIN}/
cp ${LOC}/serialosc-detector ${BIN}/
cp ${LOC}/serialosc-device ${BIN}/

#sleep 1

echo "Adding Services"
cp ${LOC}/serialosc.service /etc/systemd/system/
chmod 644 /etc/systemd/system/serialosc.service
systemctl enable --now serialosc.service

# create startup script. serialosc hangs when starting directly as a ExecStart
# echo "serialoscd" > ${BIN}/start-serialoscd
# chmod u+x ${BIN}/start-serialoscd

sleep 1

echo "Disabling r/w"
mount / -o remount,ro
1 Like

Thank you very much.
I’ll try but I suck very much at doing anything in Linux.

No worries, i dont know much about linux either!
I can look up my terminal log and paste it here, i think i saved it in case i needed to re-do the whole process :slight_smile:
Will upload assap

1 Like

Hiya,

Here is the log from my Terminal after installing, i just converted the instructions on the install.sh file into the terminal trough commands,

Hope it helps

My terminal log
music@organellem:~ $ sudo bash
root@organellem:/home/music# cp -r /sdcard/Patches/Monome/SerialOSC-Installer/lib/monome /usr/local/lib 

root@organellem:/home/music# cp /sdcard/Patches/Monome/SerialOSC-Installer/lib/libmonome.so /usr/local/lib/

root@organellem:/home/music# ln -s /usr/local/lib/libmonome.so /usr/local/lib/libmonome.so.1

root@organellem:/home/music# ln -s /usr/local/lib/libmonome.so /usr/local/lib/libmonome.so.1.4.0

root@organellem:/home/music# echo "/usr/local/lib" > /etc/ld.so.conf.d/usrlocal.conf

root@organellem:/home/music# ldconfig

root@organellem:/home/music# cp /sdcard/Patches/Monome/SerialOSC-Installer/monomeserial /usr/local/bin

root@organellem:/home/music# cp /sdcard/Patches/Monome/SerialOSC-Installer/serialoscd /usr/local/bin

root@organellem:/home/music# cp /sdcard/Patches/Monome/SerialOSC-Installer/serialosc-detector /usr/local/bin

root@organellem:/home/music# cp /sdcard/Patches/Monome/SerialOSC-Installer/serialosc-device /usr/local/bin

root@organellem:/home/music# cp /sdcard/Patches/Monome/SerialOSC-Installer/serialosc.service /etc/systemd/system/

root@organellem:/home/music# chmod 644 /etc/systemd/system/serialosc.service

root@organellem:/home/music# systemctl enable --now serialosc.service

Created symlink /etc/systemd/system/multi-user.target.wants/serialosc.service → /etc/systemd/system/serialosc.service.

root@organellem:/home/music# mount / -o remount,ro

root@organellem:/home/music# 
1 Like

Thanks a lot, I’ll try tomorrow hopefully.

This is what I’ve got after creating the same folder structure as yours and pasting the first line :

root@organellem:/home/music# cp -r /sdcard/Patches/Monome/SerialOSC-Installer/lib/monome /usr/local/lib
cp: cannot create directory ‘/usr/local/lib/monome’: Read-only file system