Otis

Just sat down with otis. Turning monitor down works for me. I hear none of my direct input, until the tape rolls back around.

I remember having the same problem you did, and tweaking the sc engine / input levels as advised by @Justmat finally made it work out, but I agree it’s not an ideal “normal” behaviors.

Ah sorry didn’t see your post @Justmat maybe you’ve updated it since the last time I used it and we talked about that ?

I guess messing with softcut in orca broke something.

I’m having the same problem as @kveye here, didn’t messed with softcut in orca or any other script, it’s “default” behavior for me. Can’t find a way to silence input level and only hear the loops, it would make it easier for small setups as for now I’m forced to use an external mixer to mute my inputs.

I thiiiink with the way that the routing works, the only way to block out the dry signal is to bypass the fx engine + turn monitor down. to my knowledge there’s no way to send the engine output only to softcut.

1 Like

How complicated (and meaningful maybe there’s another better way to add this functionality through monitor level) would it be to implement a dry/wet parameter ?

Is it normal for engine signal to contain input signal?

Here is my settings.

monitor = -inf
sc input level = 0.0
sc engine level = 1.0

for me this is no dry input coming through. I hear the loop only. is this not how it’s working for other people?

This would be super easy to add to the engine. I’ll have more time to work on it later.

I can’t check right now but from memory that ended up working out fine for me. It’s a bit convoluted and unclear though (and also it meant you couldn’t use the bit crushing right ?) so a simple dry/wet parameter would be fantastic.

1 Like

I just checked and with these settings i definitely have the constant dry signal of the input coming through (even wit mon = -inf, no rvrb or comp or sends to sc).

I’m using Otis with a faderfox UC-4 and mapped Loop 1 & 2 level, and 1 & 2 dry signal to faders.
Another thing i don’t understand is : If I loop some sounds on Loop 2, i can only hear the loop while having “2 vol” up, and “2 dry signal” up too. If i lower “2 dry signal”, the loop is getting quiter until it disappears.
I would have thought “2 vol” would relate to the volume of the loop, and “2 dry” to the dry signal of of input 2. (It responds the same on chan. 1).

It might be a user error but I took some time to find a way through this without succes for now :thinking:

so there might be some confusion on what some of the params are for. all of the 1/2 params are just for the softcut loops.

1/2 vol are for the loop volumes.
1/2 dry signal are related to the softcut filter settings for the loops.

  • 1/2 filter cutoff - cutoff freq
  • 1/2 low pass - volume of low passed audio to loop
  • 1/2 high pass - volume of high passed audio to loop
  • 1/2 filter q - filter q/resonance
  • 1/2 dry signal - volume of unfiltered audio to loop

dry should be 1 and the high/low pass 0 to have unfiltered loops.

none of these should affect monitor volume.

are you saying- i hear the loop play my dry audio after the tape rolls back around (this is the way it works for me, no monitoring but the loop is still recording) or- i hear the dry signal before it’s looped, i.e. monitored input signal pre loop?

1 Like

Thanks a lot, I was indeed confused about theses, that makes sense now :slight_smile:

What i’m saying is the second option : I always hear the dry signal before looping, even while having monitor level to -inf.

I just tried it one more time :
– Power on norns
– Lower monitor level to - inf
– Launch Otis, i hear the dry signal + the loops, since it starts with record engaged for both loops, I stop rec and clear both buffers.
– Dry input signal is still here (pre-loop) although monitor level is still set to - inf (sc input level at 0.0 and sc engine level at 1.0).

Im using Otis on a Fates if that could help someway (?) but never got through this kind of trouble before…

I’ll get some norns time after breakfast. :slight_smile: Hopefully we’ll get you sorted out. Some of this definitely needs to be simplified.

1 Like

Thanks a lot, i’m already enjoying your script a lot when using it with a Dogslit and a Fourses, and it forced me to build a tiny stereo mixer to mute my inputs. Only trouble is it’s passive and I loose too much volume with it. If we find a solution it will be a perfect match :slight_smile:

1 Like

there’s def something going on. working it out now. it doesn’t happen in bounds, which makes me think it’s something with the engine.

Thank you for looking into it, let me know if I can help with testing or anything else :slight_smile:

1 Like

definitely seems to be some confusion about meanings of “dry,” “wet,” “monitor” etc.

“monitor” level in norns system is a dry ADC->DAC path, with stereo/mono switch, totally independent of the engine.

likewise of course there is built-in ADC->softcut path.

Decimator engine additionally adds ADC->decimation->DAC and ADC->decimation->softcut.

so there are a lot of paths to keep track of. (and we have not added the softcut->engine path which has been requested.)

that’s accurate.

if “dry/wet” here means, “decimated -> DAC / decimated -> softcut”, then it would require modifying crone behavior. supercollider->softcut level is effectively a post-fader send after supercollider level.

here:

instead of applying the smoothed “engine” level in the initial copy to the EXT bus, it would need to copy to the EXT bus, send EXT bus to softcut, then apply the “engine” level (aka “dry engine” i guess.)

1 Like

thank you for the detailed information!

if i am understanding correctly, i need to use the ADC->decimation->softcut path and zero out the adc -> engine -> dac path to bring the monitor controls back to “expected behavior”.

expected behavior being, with monitoring set to -inf there is no input signal present at the outputs, input is still recorded by softcut assuming rec is engaged. is this correct?

1 Like

Sounds correct. For reference OOOOOO script does this in the expected way :slight_smile:

the difference being, oooooo doesn’t use an engine. so there’s no need to handle an engine -> dac path in oooooo.