Pixels - 1.5 - Mute Groups!

This is fun! Any plans to add output to JF?

Sorry! No plans at the moment. I’m not sure what just friends is or how to implement it at this point.

What would it do?

I have no idea either! Haven’t done any programming myself. Just Friends is a eurorack module you can control via i2c via crow/norns.

@distropolis Such a clever idea- really enjoying it. Thankyou for sharing.

5 Likes

Great! Sometimes I scroll a single pixel around like this and get some harp-like sounds. Sometimes I just hit play (k3) and let it play in the background for waaayy too long.

Thanks for posting!

1 Like

Pixels updated to 1.1.

MORE synth engines! Take control of your pixels!

See above for more info …

(and thanks again to @zebra for all of the work on The Bangs engine!)

DON’T FORGET TO SLEEP YOUR NORNS AFTER UPDATE/INSTALL.

SLEEP …

SLEEP.

12 Likes

really loving the added synth engines, adds another dimension to an already great script! thanks for all your hard work

1 Like

Thanks! The synth engines are from @zebra’s work on the flexible The Bangs engine.

1 Like

I have been looking forward to trying this out and just received my norns shield today. This is so much fun to play with!! Thank you for putting it together and sharing it with us. (Pixels is the second script I have played with after Awake, and I haven’t moved on yet.)

4 Likes

@distropolis
hey ya!
so i finally had a chance to go for a drive with Pixels last night!
so fracken amazing!

but…i ran into a few issues.
i was running it on two norns.

after about 10-15 mins norns #1 went to sleep and it would not wake up.
i was able to get past the lockout on norns #1 using the Vulcan Death Grip (K3+K2+K1) and send a ;restart from maiden.
then i went ahead and did a proper shutdown using SLEEP.

went back in and setup my parameters again and got back to the noiz.

then i ran into a double whammy on both norns #1 & #2.
after about 15-20 mins all of a sudden all the noiz stopped.
both norns just froze.
i was able to get the WiFi started up and go through the ;restart and SLEEP procedure.

norns #1 still had it’s WiFi on and i left maiden open…but to no avail.
maiden just displayed that it was not connected to matron after the norns locked up.

not sure if this would be helpful…but here are some screenshots of my settings:



Sorry to hear about the issues. What version of the norns OS are you running? I’ve noticed my machine (norns shield) hanging on the very latest version (201202). I thought it was fluke, but maybe there is something in the very latest OS that is causing this?

I have also noticed that both klang engines can cause what seems like CPU overload at certain settings. I was going to mention it to @zebra (the creator of The Bangs engine) and see if they could shed any light on it.

Thanks for letting me know and I’ll see what I can find out.

2 Likes

oop…
sorry…
i’m running everything on the latest OS on factory norns.
:slight_smile:

1 Like

In each case, did the norns completely freeze? I personally had an instance where the norns screen went to sleep, the unit stopped making sound and I was unable to wake it. I had to hard reset it.

From the screenshots above it seems that one of your norns still seemed to function, but it no longer made sound.

In either case, the issue is possibly with the new update, or with The Bangs engine which I’m using in pixels. I haven’t been able to freeze my norns again as of this writing, so if you can figure out the steps involved in freezing yours, that would be helpful.

Thanks …

hi there @distropolis and @SPIKE -
im actually having the same issue. last night i was playing with pixels and using it to drive the included synth engine as well as my minilogue xd. im not sure if it makes a difference but i was also running my dictaphone through norns’ monitor buffer. after 20-30 minutes, pixels would freeze up completely and stop making sound. the pixels would no longer be moving across the screen, and i wasn’t able to access any sort of menus or change any parameters with k1, k2, k3, e1, e2, e3. in the end i had to forcefully restart my system (norns shield). this seems to be a decently widespread issue- initially i thought perhaps i was overloading my system’s capabilities. would be happy to provide any images or logs if they’ll help.

Share what you have and I’ll take a look! Thanks and sorry for the trouble.

not sure if these are much help but these are the settings i was using last night when i was getting the 20-30 minute crashes.

settings

at the moment, i’m running the script with these settings and hoping to reproduce the crash so that i can get logs for you

hey @distropolis - it winded up taking around 35 minutes this time. as you can see in the attached video, everything has stopped working. it was just playing and seemingly randomly stopped. my shield was connected to my network yet matron wasn’t connected, and supercollider was only reporting ‘bang_(klanglin)’ up to the moment that my system stopped responding.

running norns shield image 201202

Unfortunately, I can’t seem to determine why the app crashes after extended periods of time. I’ve been able to freeze my own norns a couple of times, but no errors are thrown in matron or the sc windows. It could be one of several things:

  • An error in the script itself. Matron should throw an error in most cases here, but I’m not seeing one.

  • An issue with the supercollider engine The Bangs that pixels uses. I know I can get both klang engines to max out the CPU under certain conditions and I’ve discovered that a value of “0” in mod2 for either klang engine will throw an error in supercollider. I’m pretty sure that I’ve been able to hang pixels using a variety of the available engines in The Bangs and I’ve even reverted it back to the original PolyPerc engine and I think I’ve had it hang on me with that as well, so hard to say there.

  • An OS issue. There could be some kind of memory leak that is tapping the script out after prolonged usage. This could be in my code or in the norns OS. I’ll try testing some other SC based scripts out to see.

I’m not sure where to take it from here …

yeah, it seems like we have a mystery on our hands. unfortunately my knowledge on .lua is virtually non-existent, so im afraid i can’t be of much help. always willing to provide any information i can, though.

as a first step, remove the debug prints from the engine code:

[ https://github.com/distropolis/pixels/blob/main/lib/thebgs.sc#L58]
[ https://github.com/distropolis/pixels/blob/main/lib/thebgs.sc#L63]
[ https://github.com/distropolis/pixels/blob/main/lib/OneshVoicer.sc#L91]